summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2011-11-13 09:25:16 +0000
committerFabio Erculiani <lxnay@gentoo.org>2011-11-13 09:25:16 +0000
commitb080b070c72158f8c280ecb4d4813d1cc7a5a0fc (patch)
tree7db1c7a76892762da68115a6b06369fbd237f14d /sys-apps/entropy
parentBump, port to EAPI4, drop old. Notable changes: should no longer silently att... (diff)
downloadgentoo-2-b080b070c72158f8c280ecb4d4813d1cc7a5a0fc.tar.gz
gentoo-2-b080b070c72158f8c280ecb4d4813d1cc7a5a0fc.tar.bz2
gentoo-2-b080b070c72158f8c280ecb4d4813d1cc7a5a0fc.zip
version bump
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/entropy')
-rw-r--r--sys-apps/entropy/ChangeLog7
-rw-r--r--sys-apps/entropy/entropy-1.0_rc76.ebuild87
2 files changed, 93 insertions, 1 deletions
diff --git a/sys-apps/entropy/ChangeLog b/sys-apps/entropy/ChangeLog
index 19116e213376..ecd16c585d20 100644
--- a/sys-apps/entropy/ChangeLog
+++ b/sys-apps/entropy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/entropy
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/entropy/ChangeLog,v 1.15 2011/11/02 21:42:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/entropy/ChangeLog,v 1.16 2011/11/13 09:25:16 lxnay Exp $
+
+*entropy-1.0_rc76 (13 Nov 2011)
+
+ 13 Nov 2011; Fabio Erculiani <lxnay@gentoo.org> +entropy-1.0_rc76.ebuild:
+ version bump
02 Nov 2011; Mike Frysinger <vapier@gentoo.org> entropy-1.0_rc38.ebuild,
entropy-1.0_rc43.ebuild, entropy-1.0_rc53.ebuild, entropy-1.0_rc59.ebuild:
diff --git a/sys-apps/entropy/entropy-1.0_rc76.ebuild b/sys-apps/entropy/entropy-1.0_rc76.ebuild
new file mode 100644
index 000000000000..7521155b536e
--- /dev/null
+++ b/sys-apps/entropy/entropy-1.0_rc76.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/entropy/entropy-1.0_rc76.ebuild,v 1.1 2011/11/13 09:25:16 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="sqlite"
+inherit eutils python
+
+DESCRIPTION="Entropy Package Manager foundation library"
+HOMEPAGE="http://www.sabayon.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+SRC_URI="mirror://sabayon/${CATEGORY}/${P}.tar.bz2"
+
+RDEPEND="dev-db/sqlite[soundex]
+ net-misc/rsync
+ sys-apps/diffutils
+ sys-apps/sandbox
+ >=sys-apps/portage-2.1.9
+ sys-devel/gettext"
+DEPEND="${RDEPEND}
+ dev-util/intltool"
+
+REPO_CONFPATH="${ROOT}/etc/entropy/repositories.conf"
+REPO_D_CONFPATH="${ROOT}/etc/entropy/repositories.conf.d"
+ENTROPY_CACHEDIR="${ROOT}/var/lib/entropy/caches"
+
+pkg_setup() {
+ # Can:
+ # - update repos
+ # - update security advisories
+ # - handle on-disk cache (atm)
+ enewgroup entropy || die "failed to create entropy group"
+ # Create unprivileged entropy user
+ enewgroup entropy-nopriv || die "failed to create entropy-nopriv group"
+ enewuser entropy-nopriv -1 -1 -1 entropy-nopriv || die "failed to create entropy-nopriv user"
+}
+
+src_compile() {
+ cd "${S}"/misc/po || die
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" entropy-install || die "make install failed"
+ cd "${S}"/misc/po || die
+ emake DESTDIR="${D}" LIBDIR="usr/lib" install || die "make install failed"
+}
+
+pkg_postinst() {
+ for ex_conf in "${REPO_D_CONFPATH}"/_entropy_sabayon-limbo.example; do
+ real_conf="${ex_conf%.example}"
+ if [ -f "${real_conf}" ] || [ -f "${real_conf/_}" ]; then
+ # skip installation then
+ continue
+ fi
+ elog "Installing: ${real_conf}"
+ cp "${ex_conf}" "${real_conf}" -p
+ done
+
+ # Copy config file over
+ if [ -f "${REPO_CONFPATH}.example" ] && [ ! -f "${REPO_CONFPATH}" ]; then
+ elog "Copying ${REPO_CONFPATH}.example over to ${REPO_CONFPATH}"
+ cp "${REPO_CONFPATH}.example" "${REPO_CONFPATH}" -p
+ fi
+
+ if [ -d "${ENTROPY_CACHEDIR}" ]; then
+ einfo "Purging current Entropy cache"
+ rm -rf "${ENTROPY_CACHEDIR}"/*
+ fi
+
+ python_mod_optimize "/usr/lib/entropy/lib/entropy"
+
+ echo
+ elog "If you want to enable Entropy packages delta download support, please"
+ elog "install dev-util/bsdiff."
+ echo
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/lib/entropy"
+}