summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-05-04 05:49:17 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-05-04 05:49:17 +0000
commitf3468c154670b702e1055cdeb2f5b9837757cfed (patch)
tree38e7f59075b6241655e6f07d771369b4068101c5 /sys-apps/fileutils
parentadd 4.1.71 (diff)
downloadgentoo-2-f3468c154670b702e1055cdeb2f5b9837757cfed.tar.gz
gentoo-2-f3468c154670b702e1055cdeb2f5b9837757cfed.tar.bz2
gentoo-2-f3468c154670b702e1055cdeb2f5b9837757cfed.zip
fix for acl patch if NLS is disabled; blocke is sending this one upstream
Diffstat (limited to 'sys-apps/fileutils')
-rw-r--r--sys-apps/fileutils/ChangeLog7
-rw-r--r--sys-apps/fileutils/files/acl.c.diff10
-rw-r--r--sys-apps/fileutils/fileutils-4.1.8-r1.ebuild7
3 files changed, 22 insertions, 2 deletions
diff --git a/sys-apps/fileutils/ChangeLog b/sys-apps/fileutils/ChangeLog
index e6cdf2794ffc..adc045365a68 100644
--- a/sys-apps/fileutils/ChangeLog
+++ b/sys-apps/fileutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/fileutils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fileutils/ChangeLog,v 1.3 2002/05/03 20:37:22 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fileutils/ChangeLog,v 1.4 2002/05/04 05:49:17 drobbins Exp $
+
+ 03 May 2002; Daniel Robbins <drobbins@gentoo.org>: Added acl.c.diff to fix
+ compilation with nls disabled. Blocke is sending this fix upstream to
+ acl.bestbits.at. No rev bump -- no need for a recompile if it worked for
+ people.
*fileutils-4.1.8-r1 (02 May 2002)
diff --git a/sys-apps/fileutils/files/acl.c.diff b/sys-apps/fileutils/files/acl.c.diff
new file mode 100644
index 000000000000..162845afd556
--- /dev/null
+++ b/sys-apps/fileutils/files/acl.c.diff
@@ -0,0 +1,10 @@
+--- acl.c.orig Fri May 3 23:47:34 2002
++++ acl.c Fri May 3 23:47:43 2002
+@@ -26,6 +26,7 @@
+ # include <libintl.h>
+ # define _(Text) gettext (Text)
+ #else
++# include <stddef.h>
+ # define _(Text) Text
+ #endif
+
diff --git a/sys-apps/fileutils/fileutils-4.1.8-r1.ebuild b/sys-apps/fileutils/fileutils-4.1.8-r1.ebuild
index c0500b819c28..9293ae019ca3 100644
--- a/sys-apps/fileutils/fileutils-4.1.8-r1.ebuild
+++ b/sys-apps/fileutils/fileutils-4.1.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fileutils/fileutils-4.1.8-r1.ebuild,v 1.1 2002/05/03 20:37:22 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fileutils/fileutils-4.1.8-r1.ebuild,v 1.2 2002/05/04 05:49:17 drobbins Exp $
ACLPV=4.1.8acl-0.8.25
@@ -17,6 +17,7 @@ RDEPEND="virtual/glibc
src_unpack() {
if [ "`use acl`" ]; then
+ echo "USING ACL"
cp ${DISTDIR}/${P}.tar.gz ${WORKDIR}/.
xdelta patch ${DISTDIR}/fileutils-${ACLPV}.xdelta ${WORKDIR}/${P}.tar.gz || die
tar xz --no-same-owner -f ${WORKDIR}/${P}acl.tar.gz || die
@@ -25,6 +26,8 @@ src_unpack() {
else
unpack ${P}.tar.gz ; cd ${S}
fi
+ cd ${S}/lib
+ cat ${FILESDIR}/acl.c.diff | patch -p0 -l || die
}
src_compile() {
@@ -35,6 +38,8 @@ src_compile() {
--infodir=/usr/share/info \
--bindir=/bin \
${myconf} || die
+ #fix NULL undefined compilation problem when nls not in USE (and no libintl.h is #included)
+ echo "#include <stddef.h>" >> config.in
emake || die
}