summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2003-10-23 10:51:44 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2003-10-23 10:51:44 +0000
commit85e23effa40e2add52d1d10c0d9906aef95c72cb (patch)
tree1abb277d8065ed8d122d11aecbe8543f6462b89b /sys-apps/findutils/findutils-4.1.20-r1.ebuild
parentEnlarge environment limit to at least temporarilly releave the presure by ebu... (diff)
downloadgentoo-2-85e23effa40e2add52d1d10c0d9906aef95c72cb.tar.gz
gentoo-2-85e23effa40e2add52d1d10c0d9906aef95c72cb.tar.bz2
gentoo-2-85e23effa40e2add52d1d10c0d9906aef95c72cb.zip
Enlarge environment limit to at least temporarilly releave the presure by ebuild.sh etc. so that openoffice can be build
Diffstat (limited to 'sys-apps/findutils/findutils-4.1.20-r1.ebuild')
-rw-r--r--sys-apps/findutils/findutils-4.1.20-r1.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/sys-apps/findutils/findutils-4.1.20-r1.ebuild b/sys-apps/findutils/findutils-4.1.20-r1.ebuild
new file mode 100644
index 000000000000..1fcf0e9534de
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.1.20-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.1.20-r1.ebuild,v 1.1 2003/10/23 10:51:39 pauldv Exp $
+
+IUSE="nls build afs selinux"
+
+inherit eutils
+
+DESCRIPTION="GNU utilities to find files"
+HOMEPAGE="http://www.gnu.org/software/findutils/findutils.html"
+
+# Note this doesn't point to gnu.org because alpha.gnu.org has quit
+# supplying the development versions. If it comes back in the future
+# then we might want to redirect the link. See bug 18729
+SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}.tar.gz
+ selinux? mirror://gentoo/${P}-2003011510-selinux-gentoo.patch.bz2"
+
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~hppa ~arm ~alpha ~ia64"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ >=sys-apps/sed-4
+ nls? ( sys-devel/gettext )
+ afs? ( net-fs/openafs )
+ selinux? ( sys-apps/selinux-small )"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Don't build or install locate because it conflicts with slocate,
+ # which is a secure version of locate. See bug 18729
+ sed -i '/^SUBDIRS/s/locate//' Makefile.in
+
+ #get a bigger environment as ebuild.sh is growing large
+ epatch ${FILESDIR}/findutils-env-size.patch
+
+ use selinux && epatch ${DISTDIR}/${P}-2003011510-selinux-gentoo.patch.bz2
+}
+
+src_compile() {
+ local myconf=
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ if use afs; then
+ export CPPFLAGS=-I/usr/afsws/include
+ export LDFLAGS=-lpam
+ export LIBS=/usr/afsws/lib/pam_afs.so.1
+ fi
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ ${myconf} || die
+
+ emake libexecdir=/usr/lib/find || die
+}
+
+src_install() {
+ einstall libexecdir=${D}/usr/lib/find || die
+
+ prepallman
+
+ rm -rf ${D}/usr/var
+ if ! use build; then
+ dodoc COPYING NEWS README TODO ChangeLog
+ else
+ rm -rf ${D}/usr/share
+ fi
+}
+
+pkg_postinst() {
+ ewarn "Please note that the locate and updatedb binaries"
+ ewarn "are not longer provided by findutils."
+ ewarn "Please emerge slocate"
+}