summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2013-10-10 18:10:29 +0000
committerTony Vroon <chainsaw@gentoo.org>2013-10-10 18:10:29 +0000
commit63f6678fdbfe6fd67cd862cc3ffa919af92d1397 (patch)
treef4b755753776599783197bf2fadcd3180a23aca2 /sys-apps/findutils
parentAdd unit file (#487498 by Rafal Rzepecki) (diff)
downloadgentoo-2-63f6678fdbfe6fd67cd862cc3ffa919af92d1397.tar.gz
gentoo-2-63f6678fdbfe6fd67cd862cc3ffa919af92d1397.tar.bz2
gentoo-2-63f6678fdbfe6fd67cd862cc3ffa919af92d1397.zip
Version bump, as requested by Lars "Polynomial-C" Wendler in bug #487514. -perm /MODE is no longer disabled when POSIXLY_CORRECT. The deprecated +MODE notation has been fully removed.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'sys-apps/findutils')
-rw-r--r--sys-apps/findutils/ChangeLog9
-rw-r--r--sys-apps/findutils/findutils-4.5.12.ebuild55
2 files changed, 63 insertions, 1 deletions
diff --git a/sys-apps/findutils/ChangeLog b/sys-apps/findutils/ChangeLog
index 8daff6266874..46707365afbe 100644
--- a/sys-apps/findutils/ChangeLog
+++ b/sys-apps/findutils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/findutils
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.218 2013/06/27 05:50:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.219 2013/10/10 18:10:29 chainsaw Exp $
+
+*findutils-4.5.12 (10 Oct 2013)
+
+ 10 Oct 2013; Tony Vroon <chainsaw@gentoo.org> +findutils-4.5.12.ebuild:
+ Version bump, as requested by Lars "Polynomial-C" Wendler in bug #487514.
+ -perm /MODE is no longer disabled when POSIXLY_CORRECT. The deprecated +MODE
+ notation has been fully removed.
27 Jun 2013; Mike Frysinger <vapier@gentoo.org> findutils-4.5.11.ebuild:
Control selinux dep via configure flag.
diff --git a/sys-apps/findutils/findutils-4.5.12.ebuild b/sys-apps/findutils/findutils-4.5.12.ebuild
new file mode 100644
index 000000000000..04d14de633fd
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.5.12.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.5.12.ebuild,v 1.1 2013/10/10 18:10:29 chainsaw Exp $
+
+EAPI="5"
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+DESCRIPTION="GNU utilities for finding files"
+HOMEPAGE="http://www.gnu.org/software/findutils/"
+SRC_URI="mirror://gnu-alpha/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-aix ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls selinux static"
+
+RDEPEND="selinux? ( sys-libs/libselinux )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ # Don't build or install locate because it conflicts with slocate,
+ # which is a secure version of locate. See bug 18729
+ sed -i '/^SUBDIRS/s/locate//' Makefile.in
+
+ if use prefix ; then #469206
+ cp tests/{rmdir,unlink,unlinkat,at-func}.c gl/lib/ || die
+ epatch "${FILESDIR}/${P}-unlinkat.patch"
+ fi
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ program_prefix=$(usex userland_GNU '' g)
+ econf \
+ --with-packager="Gentoo" \
+ --with-packager-version="${PVR}" \
+ --with-packager-bug-reports="http://bugs.gentoo.org/" \
+ --program-prefix=${program_prefix} \
+ $(use_enable nls) \
+ $(use_with selinux) \
+ --libexecdir='$(libdir)'/find
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc NEWS README TODO ChangeLog
+
+ # We don't need this, so punt it.
+ rm "${ED}"/usr/bin/${program_prefix}oldfind \
+ "${ED}"/usr/share/man/man1/${program_prefix}oldfind.1 || die
+}