summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-05-03 14:45:55 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-05-03 14:45:55 +0000
commitf55110d14a982d9b42ee106109d1568ff3a2b6fd (patch)
tree5a971af6db529170779bb6fb3cb215eeef1742d6 /sys-apps/gli
parentsmall change to wording (diff)
downloadgentoo-2-f55110d14a982d9b42ee106109d1568ff3a2b6fd.tar.gz
gentoo-2-f55110d14a982d9b42ee106109d1568ff3a2b6fd.tar.bz2
gentoo-2-f55110d14a982d9b42ee106109d1568ff3a2b6fd.zip
Added python eclass to pre-compile the python modules, and added a warning about proper usage of the current versions of gli.
(Portage version: 2.1_pre10-r2)
Diffstat (limited to 'sys-apps/gli')
-rw-r--r--sys-apps/gli/ChangeLog6
-rw-r--r--sys-apps/gli/gli-0.3.1.ebuild14
2 files changed, 17 insertions, 3 deletions
diff --git a/sys-apps/gli/ChangeLog b/sys-apps/gli/ChangeLog
index 0e8f8a784579..ce7f56152222 100644
--- a/sys-apps/gli/ChangeLog
+++ b/sys-apps/gli/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/gli
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gli/ChangeLog,v 1.4 2006/04/27 22:35:23 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gli/ChangeLog,v 1.5 2006/05/03 14:45:55 wolf31o2 Exp $
+
+ 03 May 2006; Chris Gianelloni <wolf31o2@gentoo.org> gli-0.3.1.ebuild:
+ Added python eclass to pre-compile the python modules, and added a warning
+ about proper usage of the current versions of gli.
27 Apr 2006; Alec Warner <antarus@gentoo.org> files/digest-gli-0.3,
Manifest:
diff --git a/sys-apps/gli/gli-0.3.1.ebuild b/sys-apps/gli/gli-0.3.1.ebuild
index 5c4649c80674..95978e7e0ed0 100644
--- a/sys-apps/gli/gli-0.3.1.ebuild
+++ b/sys-apps/gli/gli-0.3.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gli/gli-0.3.1.ebuild,v 1.1 2006/03/13 16:27:35 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gli/gli-0.3.1.ebuild,v 1.2 2006/05/03 14:45:55 wolf31o2 Exp $
-inherit eutils
+inherit python eutils
DESCRIPTION="Gentoo Linux Installer"
HOMEPAGE="http://www.gentoo.org/proj/en/releng/installer/"
@@ -47,3 +47,13 @@ src_install() {
domenu ${FILESDIR}/installer-gtk.desktop \
${FILESDIR}/installer-dialog.desktop
}
+
+pkg_postinst() {
+ python_mod_optimize
+ einfo "The Gentoo Linux Installer is currently only usable for two situations."
+ einfo "The first is for building an install profile."
+ einfo "The second is for installing using official Gentoo release media."
+ echo
+ ewarn "If you are trying to use the installer for anything else, please"
+ ewarn "file patches with any bugs."
+}