summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2007-04-12 16:13:00 +0000
committerDoug Goldstein <cardoe@gentoo.org>2007-04-12 16:13:00 +0000
commit4d15ba997697954ba2f6cdca1cd0b3cfc02dcde3 (patch)
tree17dfb53708cde3ef397f0fe2625c96e78de939d1 /sys-apps/hal
parentWarn about deprecated conf.d/wireless, #174282. (diff)
downloadgentoo-2-4d15ba997697954ba2f6cdca1cd0b3cfc02dcde3.tar.gz
gentoo-2-4d15ba997697954ba2f6cdca1cd0b3cfc02dcde3.tar.bz2
gentoo-2-4d15ba997697954ba2f6cdca1cd0b3cfc02dcde3.zip
HAL compiles on Gentoo/FreeBSD
(Portage version: 2.1.2.3)
Diffstat (limited to 'sys-apps/hal')
-rw-r--r--sys-apps/hal/ChangeLog7
-rw-r--r--sys-apps/hal/files/0.5.9/05_freebsd_partutil_make_fix.patch9
-rw-r--r--sys-apps/hal/files/0.5.9/06_freebsd_backend_fix.patch43
-rw-r--r--sys-apps/hal/hal-0.5.9.ebuild4
4 files changed, 38 insertions, 25 deletions
diff --git a/sys-apps/hal/ChangeLog b/sys-apps/hal/ChangeLog
index 4cf374c5a4fc..69961e9c553b 100644
--- a/sys-apps/hal/ChangeLog
+++ b/sys-apps/hal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hal
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.161 2007/04/11 23:39:56 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.162 2007/04/12 16:13:00 cardoe Exp $
+
+ 12 Apr 2007; Doug Goldstein <cardoe@gentoo.org>
+ files/0.5.9/05_freebsd_partutil_make_fix.patch,
+ files/0.5.9/06_freebsd_backend_fix.patch, hal-0.5.9.ebuild:
+ HAL compiles on Gentoo/FreeBSD
11 Apr 2007; Doug Goldstein <cardoe@gentoo.org>
files/0.5.9/06_freebsd_backend_fix.patch:
diff --git a/sys-apps/hal/files/0.5.9/05_freebsd_partutil_make_fix.patch b/sys-apps/hal/files/0.5.9/05_freebsd_partutil_make_fix.patch
index a3f5a7eee6c4..6fd63e119f66 100644
--- a/sys-apps/hal/files/0.5.9/05_freebsd_partutil_make_fix.patch
+++ b/sys-apps/hal/files/0.5.9/05_freebsd_partutil_make_fix.patch
@@ -1,8 +1,8 @@
Index: b/partutil/Makefile.am
===================================================================
--- a/partutil/Makefile.am 2007-04-11 15:50:44.000000000 -0400
-+++ b/partutil/Makefile.am 2007-04-11 15:51:14.000000000 -0400
-@@ -1,13 +1,8 @@
++++ b/partutil/Makefile.am 2007-04-12 11:42:23.000000000 -0400
+@@ -1,17 +1,12 @@
-if HALD_COMPILE_SOLARIS
-# do nothing
-else if HALD_COMPILE_FREEBSD
@@ -10,6 +10,7 @@ Index: b/partutil/Makefile.am
-else
+if HALD_COMPILE_LINUX
+noinst_LTLIBRARIES = libpartutil.la
++endif
INCLUDES = @GLIB_CFLAGS@
@@ -18,3 +19,7 @@ Index: b/partutil/Makefile.am
libpartutil_la_SOURCES = partutil.h partutil.c ../hald/logger.c
libpartutil_la_LIBADD = @GLIB_LIBS@ @PARTED_LIBS@
+
+ clean-local :
+ rm -f *~
+-endif
diff --git a/sys-apps/hal/files/0.5.9/06_freebsd_backend_fix.patch b/sys-apps/hal/files/0.5.9/06_freebsd_backend_fix.patch
index 95125ac9081a..d18c03212673 100644
--- a/sys-apps/hal/files/0.5.9/06_freebsd_backend_fix.patch
+++ b/sys-apps/hal/files/0.5.9/06_freebsd_backend_fix.patch
@@ -1,7 +1,7 @@
Index: b/hald/freebsd/hf-usb.c
===================================================================
---- a/hald/freebsd/hf-usb.c 2007-04-11 15:50:44.000000000 -0400
-+++ b/hald/freebsd/hf-usb.c 2007-04-11 19:19:07.000000000 -0400
+--- a/hald/freebsd/hf-usb.c 2007-04-12 11:42:05.000000000 -0400
++++ b/hald/freebsd/hf-usb.c 2007-04-12 11:59:40.000000000 -0400
@@ -372,11 +372,11 @@
can_wake_up = (config_desc.bmAttributes & UC_REMOTE_WAKEUP) != 0;
num_interfaces = config_desc.bNumInterface;
@@ -36,31 +36,32 @@ Index: b/hald/freebsd/hf-usb.c
p += USB_INTERFACE_DESCRIPTOR_SIZE + if_desc->bNumEndpoints * USB_ENDPOINT_DESCRIPTOR_SIZE;
Index: b/hald/freebsd/hf-pci.c
===================================================================
---- a/hald/freebsd/hf-pci.c 2007-04-11 14:55:43.000000000 -0400
-+++ b/hald/freebsd/hf-pci.c 2007-04-11 19:32:33.000000000 -0400
-@@ -207,12 +207,22 @@
- for (p = conf; p < &conf[pc.num_matches]; p++)
- {
- DeviceInfo *info;
-+ HalProperty *pcibus, *pcidevice, *pcifunc;
-+
-+ pcibus = hal_property_new(HAL_PROPERTY_TYPE_INT32);
-+ hal_property_set_int(pcibus, p->pc_sel.pc_bus);
-+
-+ pcidevice = hal_property_new(HAL_PROPERTY_TYPE_INT32);
-+ hal_property_set_int(pcidevice, p->pc_sel.pc_dev);
-+
-+ pcifunc = hal_property_new(HAL_PROPERTY_TYPE_INT32);
-+ hal_property_set_int(pcifunc, p->pc_sel.pc_func);
+--- a/hald/freebsd/hf-pci.c 2007-04-12 11:42:05.000000000 -0400
++++ b/hald/freebsd/hf-pci.c 2007-04-12 12:04:48.000000000 -0400
+@@ -38,6 +38,7 @@
+
+ #include "../hald.h"
+ #include "../ids.h"
++#include "../device.h"
+ #include "../logger.h"
+ #include "../util.h"
+
+@@ -210,9 +211,15 @@
info = g_new(DeviceInfo, 1);
info->device = hf_device_store_match(hald_get_gdl(),
- hal_property_new_int("pci.freebsd.bus", p->pc_sel.pc_bus),
- hal_property_new_int("pci.freebsd.device", p->pc_sel.pc_dev),
- hal_property_new_int("pci.freebsd.function", p->pc_sel.pc_func),
-+ pcibus,
-+ pcidevice,
-+ pcifunc,
++ "pci.freebsd.bus",
++ HAL_PROPERTY_TYPE_INT32,
++ p->pc_sel.pc_bus,
++ "pci.freebsd.device",
++ HAL_PROPERTY_TYPE_INT32,
++ p->pc_sel.pc_dev,
++ "pci.freebsd.function",
++ HAL_PROPERTY_TYPE_INT32,
++ p->pc_sel.pc_func,
NULL);
info->p = *p;
info->secondary_bus = hf_pci_get_register(p, PCIR_SECBUS_1);
diff --git a/sys-apps/hal/hal-0.5.9.ebuild b/sys-apps/hal/hal-0.5.9.ebuild
index ec43c42a14a5..160560625896 100644
--- a/sys-apps/hal/hal-0.5.9.ebuild
+++ b/sys-apps/hal/hal-0.5.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.9.ebuild,v 1.16 2007/04/11 16:12:42 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.9.ebuild,v 1.17 2007/04/12 16:13:00 cardoe Exp $
inherit eutils linux-info autotools flag-o-matic
@@ -105,6 +105,8 @@ src_unpack() {
# Gentoo Patch Set
EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" epatch ${FILESDIR}/${PV}
+
+ eautoreconf
}
src_compile() {