summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-06-19 18:41:28 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-06-19 18:41:28 +0000
commit541b45dbc282500a1917a4f3190e0ef7d76a8fc9 (patch)
tree249939f1031ea63bca7aa5bb7ac09d5b5274030e /sys-apps/halevt/halevt-0.1.4-r2.ebuild
parentRemove gksu dep -- bug 274483 (diff)
downloadgentoo-2-541b45dbc282500a1917a4f3190e0ef7d76a8fc9.tar.gz
gentoo-2-541b45dbc282500a1917a4f3190e0ef7d76a8fc9.tar.bz2
gentoo-2-541b45dbc282500a1917a4f3190e0ef7d76a8fc9.zip
New init script thanks to George Kargiotakis. Remove old ebuilds
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/halevt/halevt-0.1.4-r2.ebuild')
-rw-r--r--sys-apps/halevt/halevt-0.1.4-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/halevt/halevt-0.1.4-r2.ebuild b/sys-apps/halevt/halevt-0.1.4-r2.ebuild
new file mode 100644
index 000000000000..7236949d8d2f
--- /dev/null
+++ b/sys-apps/halevt/halevt-0.1.4-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/halevt/halevt-0.1.4-r2.ebuild,v 1.1 2009/06/19 18:41:27 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A daemon built on ivman that executes arbitrary commands on HAL events"
+HOMEPAGE="http://www.environnement.ens.fr/perso/dumas/halevt.html"
+SRC_URI="http://www.environnement.ens.fr/perso/dumas/halevt-download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls rpath"
+
+DEPEND=">=sys-apps/hal-0.5.11-r1
+ >=sys-apps/dbus-1.2.3-r1
+ >=dev-libs/dbus-glib-0.76
+ >=dev-libs/boolstuff-0.1.12"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_enable nls) $(use_enable rpath)
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "install failed"
+ doinitd "${FILESDIR}"/${PN} || die "failed to install init script"
+ dodoc AUTHORS NEWS README || die "dodoc failed"
+
+ insinto /etc/${PN}/
+ doins ${PN}.xml || die "doins ${PN}.xml failed"
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Default config file resides at /etc/halevt/halevt.xml."
+ einfo
+}