summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-11 09:03:20 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-11 09:03:20 +0000
commit02293b4204bc61047dfbdec2b7a5e82f8c9f9498 (patch)
tree557147940d6cfb14df7f39e71cc1b145f908859f /sys-apps/hwids
parentDepend on xf86dgaproto, bug #425774. (diff)
downloadgentoo-2-02293b4204bc61047dfbdec2b7a5e82f8c9f9498.tar.gz
gentoo-2-02293b4204bc61047dfbdec2b7a5e82f8c9f9498.tar.bz2
gentoo-2-02293b4204bc61047dfbdec2b7a5e82f8c9f9498.zip
Version bump.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/hwids')
-rw-r--r--sys-apps/hwids/ChangeLog7
-rw-r--r--sys-apps/hwids/hwids-20120711.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/sys-apps/hwids/ChangeLog b/sys-apps/hwids/ChangeLog
index d3a1ebbc7799..9acab01fcad6 100644
--- a/sys-apps/hwids/ChangeLog
+++ b/sys-apps/hwids/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hwids
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.14 2012/06/30 15:16:10 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.15 2012/07/11 09:03:20 flameeyes Exp $
+
+*hwids-20120711 (11 Jul 2012)
+
+ 11 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org> +hwids-20120711.ebuild:
+ Version bump.
30 Jun 2012; Diego E. Pettenò <flameeyes@gentoo.org> hwids-20120625.ebuild:
Fix; next time make sure the box you test and the box you commit are the same.
diff --git a/sys-apps/hwids/hwids-20120711.ebuild b/sys-apps/hwids/hwids-20120711.ebuild
new file mode 100644
index 000000000000..8fbb274cde08
--- /dev/null
+++ b/sys-apps/hwids/hwids-20120711.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20120711.ebuild,v 1.1 2012/07/11 09:03:20 flameeyes Exp $
+
+EAPI="4"
+
+DESCRIPTION="Hardware (PCI, USB) IDs databases"
+HOMEPAGE="https://github.com/gentoo/hwids"
+SRC_URI="https://github.com/gentoo/hwids/tarball/${P} -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 BSD )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!<sys-apps/pciutils-3.1.9-r2
+ !<sys-apps/usbutils-005-r1"
+
+S="${WORKDIR}"
+
+src_compile() {
+ cd "${S}"/gentoo-hwids-*
+
+ for file in {usb,pci}.ids; do
+ gzip -c ${file} > ${file}.gz || die
+ done
+}
+
+src_install() {
+ cd "${S}"/gentoo-hwids-*
+
+ insinto /usr/share/misc
+ doins {usb,pci}.ids{,.gz}
+
+ dodoc README.md
+}