summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-12-14 05:17:21 +0000
committerMike Gilbert <floppym@gentoo.org>2014-12-14 05:17:21 +0000
commitd368f880dd5cd2d6e5e68c7a623d708aebbaade1 (patch)
tree451dbddf33dca5f202c5dd3e1400e3a6df09b4e0 /sys-apps/hwids
parentLoosen glib and gtk deps in glade-0.12.5.0-r2 (diff)
downloadgentoo-2-d368f880dd5cd2d6e5e68c7a623d708aebbaade1.tar.gz
gentoo-2-d368f880dd5cd2d6e5e68c7a623d708aebbaade1.tar.bz2
gentoo-2-d368f880dd5cd2d6e5e68c7a623d708aebbaade1.zip
Version bump. Added udev/70-mouse.hwdb.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-apps/hwids')
-rw-r--r--sys-apps/hwids/ChangeLog7
-rw-r--r--sys-apps/hwids/hwids-20141214.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/sys-apps/hwids/ChangeLog b/sys-apps/hwids/ChangeLog
index bc1f1ae1312f..7e99f6745dfa 100644
--- a/sys-apps/hwids/ChangeLog
+++ b/sys-apps/hwids/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hwids
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.155 2014/11/10 17:00:24 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.156 2014/12/14 05:17:21 floppym Exp $
+
+*hwids-20141214 (14 Dec 2014)
+
+ 14 Dec 2014; Mike Gilbert <floppym@gentoo.org> +hwids-20141214.ebuild:
+ Version bump. Added udev/70-mouse.hwdb.
*hwids-20141110 (10 Nov 2014)
diff --git a/sys-apps/hwids/hwids-20141214.ebuild b/sys-apps/hwids/hwids-20141214.ebuild
new file mode 100644
index 000000000000..9b3a2d3db7b1
--- /dev/null
+++ b/sys-apps/hwids/hwids-20141214.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20141214.ebuild,v 1.1 2014/12/14 05:17:21 floppym Exp $
+
+EAPI=5
+inherit udev eutils
+
+DESCRIPTION="Hardware (PCI, USB, OUI, IAB) IDs databases"
+HOMEPAGE="https://github.com/gentoo/hwids"
+if [[ ${PV} == "99999999" ]]; then
+ EGIT_REPO_URI="${HOMEPAGE}.git"
+ inherit git-2
+else
+ SRC_URI="${HOMEPAGE}/archive/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux"
+fi
+
+LICENSE="|| ( GPL-2 BSD ) public-domain"
+SLOT="0"
+IUSE="+net +pci +udev +usb"
+
+DEPEND="udev? (
+ dev-lang/perl
+ >=virtual/udev-206
+)"
+[[ ${PV} == "99999999" ]] && DEPEND+=" udev? ( net-misc/curl )"
+RDEPEND="!<sys-apps/pciutils-3.1.9-r2
+ !<sys-apps/usbutils-005-r1"
+
+S=${WORKDIR}/hwids-${P}
+
+src_prepare() {
+ [[ ${PV} == "99999999" ]] && emake fetch
+
+ sed -i -e '/udevadm hwdb/d' Makefile || die
+}
+
+_emake() {
+ emake \
+ NET=$(usex net) \
+ PCI=$(usex pci) \
+ UDEV=$(usex udev) \
+ USB=$(usex usb) \
+ "$@"
+}
+
+src_compile() {
+ _emake
+}
+
+src_install() {
+ _emake install \
+ DOCDIR="${EPREFIX}/usr/share/doc/${PF}" \
+ MISCDIR="${EPREFIX}/usr/share/misc" \
+ HWDBDIR="${EPREFIX}$(get_udevdir)/hwdb.d" \
+ DESTDIR="${D}"
+}
+
+pkg_postinst() {
+ if use udev; then
+ udevadm hwdb --update --root="${ROOT%/}"
+ # http://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
+ [ "${ROOT:-/}" = "/" ] && udevadm control --reload
+ fi
+}