summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-07-14 00:30:54 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-07-14 00:30:54 +0000
commitbc8607519a5939b1ae04be1cd93598885eec67b2 (patch)
tree09950175e86bc4709b302e56211d07716e2b05fe /sys-apps/hwinfo/hwinfo-14.19.ebuild
parentStable for HPPA (bug #196834). (diff)
downloadgentoo-2-bc8607519a5939b1ae04be1cd93598885eec67b2.tar.gz
gentoo-2-bc8607519a5939b1ae04be1cd93598885eec67b2.tar.bz2
gentoo-2-bc8607519a5939b1ae04be1cd93598885eec67b2.zip
Version bump per bug #231668.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc4-00103-g1beee8d x86_64)
Diffstat (limited to 'sys-apps/hwinfo/hwinfo-14.19.ebuild')
-rw-r--r--sys-apps/hwinfo/hwinfo-14.19.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-apps/hwinfo/hwinfo-14.19.ebuild b/sys-apps/hwinfo/hwinfo-14.19.ebuild
new file mode 100644
index 000000000000..e8ba35ff833f
--- /dev/null
+++ b/sys-apps/hwinfo/hwinfo-14.19.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwinfo/hwinfo-14.19.ebuild,v 1.1 2008/07/14 00:30:54 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="hwinfo is the hardware detection tool used in SuSE Linux."
+HOMEPAGE="http://www.suse.com"
+DEBIAN_PV="2"
+DEBIAN_BASE_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/"
+SRC_URI="${DEBIAN_BASE_URI}/${PN}_${PV}.orig.tar.gz
+ ${DEBIAN_BASE_URI}/${PN}_${PV}-${DEBIAN_PV}.diff.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86 ~amd64"
+IUSE=""
+RDEPEND=">=sys-fs/sysfsutils-2
+ sys-apps/hal
+ sys-apps/dbus"
+# this package won't work on *BSD
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.17"
+
+src_unpack (){
+ unpack ${PN}_${PV}.orig.tar.gz
+ EPATCH_OPTS="-p1 -d ${S}" epatch "${DISTDIR}"/${PN}_${PV}-${DEBIAN_PV}.diff.gz
+ rm "${S}"/debian/patches/series
+ cd "${S}"
+ EPATCH_SUFFIX="" EPATCH_FORCE="yes" epatch "${S}"/debian/patches/
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-13.11-makefile-fixes.patch
+ #sed -i -e "s,^LIBS[ \t]*= -lhd,LIBS = -lhd -lsysfs," ${S}/Makefile
+ #sed -i -e "s,^LIBDIR[ \t]*= /usr/lib$,LIBDIR = /usr/$(get_libdir)," ${S}/Makefile
+ echo 'libs: $(LIBHD) $(LIBHD_SO)' >>${S}/Makefile
+}
+
+src_compile(){
+ # build is NOT parallel safe
+ emake -j1 EXTRA_FLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ [[ "$(get_libdir)" != "lib" ]] && mv "${D}"/usr/lib "${D}/usr/$(get_libdir)"
+ dodoc VERSION README COPYING
+ doman doc/hwinfo.8
+}