summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-07-22 04:31:17 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-07-22 04:31:17 +0000
commitc753da7e14d2f306264d0255b2a9a9c87d01be1c (patch)
treed00e9b2f780a49ebac759ae70481203402485d33 /sys-apps/hwinfo
parentStable on alpha and amd64 wrt Bug #140618. (diff)
downloadgentoo-2-c753da7e14d2f306264d0255b2a9a9c87d01be1c.tar.gz
gentoo-2-c753da7e14d2f306264d0255b2a9a9c87d01be1c.tar.bz2
gentoo-2-c753da7e14d2f306264d0255b2a9a9c87d01be1c.zip
Fix for GCC4 breakages with a version bump, bug #140911.
(Portage version: 2.1.1_pre3-r1)
Diffstat (limited to 'sys-apps/hwinfo')
-rw-r--r--sys-apps/hwinfo/ChangeLog9
-rw-r--r--sys-apps/hwinfo/files/digest-hwinfo-13.06
-rw-r--r--sys-apps/hwinfo/files/digest-hwinfo-8.382
-rw-r--r--sys-apps/hwinfo/hwinfo-13.0.ebuild47
4 files changed, 62 insertions, 2 deletions
diff --git a/sys-apps/hwinfo/ChangeLog b/sys-apps/hwinfo/ChangeLog
index 971d10754740..1af1c5868f52 100644
--- a/sys-apps/hwinfo/ChangeLog
+++ b/sys-apps/hwinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hwinfo
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwinfo/ChangeLog,v 1.2 2005/07/04 07:45:03 dholm Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwinfo/ChangeLog,v 1.3 2006/07/22 04:31:17 robbat2 Exp $
+
+*hwinfo-13.0 (22 Jul 2006)
+
+ 22 Jul 2006; Robin H. Johnson <robbat2@gentoo.org> +hwinfo-13.0.ebuild:
+ Fix for GCC4 breakages with a version bump, bug #140911.
04 Jul 2005; David Holm <dholm@gentoo.org> hwinfo-8.38.ebuild:
Added to ~ppc.
diff --git a/sys-apps/hwinfo/files/digest-hwinfo-13.0 b/sys-apps/hwinfo/files/digest-hwinfo-13.0
new file mode 100644
index 000000000000..5e0fa1bf0cf9
--- /dev/null
+++ b/sys-apps/hwinfo/files/digest-hwinfo-13.0
@@ -0,0 +1,6 @@
+MD5 86481141f48b6539e6b4cbb3eca6a50e hwinfo_13.0-4.diff.gz 10308
+RMD160 bf323419c70c4e474d14e6b38fe4ebd042141827 hwinfo_13.0-4.diff.gz 10308
+SHA256 26b6da993ffafe471bdb86c9d2dacb3865b102e7fcad48f7cf288aa232a171dd hwinfo_13.0-4.diff.gz 10308
+MD5 f56351cd8ddda192c3e2c7379c7f9920 hwinfo_13.0.orig.tar.gz 792900
+RMD160 26dba3dea1553da097208b93d54d65b981820ef0 hwinfo_13.0.orig.tar.gz 792900
+SHA256 35f3affcd122cecf98435fbeff8971149faa80e5b3c4c31664ba6167f2566ad9 hwinfo_13.0.orig.tar.gz 792900
diff --git a/sys-apps/hwinfo/files/digest-hwinfo-8.38 b/sys-apps/hwinfo/files/digest-hwinfo-8.38
index 7345fad85c44..f64457231b3a 100644
--- a/sys-apps/hwinfo/files/digest-hwinfo-8.38
+++ b/sys-apps/hwinfo/files/digest-hwinfo-8.38
@@ -1 +1,3 @@
MD5 260f89a3a64e215105e07cfc1ac2fced hwinfo-8.38.tar.gz 569050
+RMD160 3ccb827a4addb2688f7b1c7faf661ef8a6667c2f hwinfo-8.38.tar.gz 569050
+SHA256 5b77373beb11ad558ba786a279580143214e1b5bd3e873b191c72bc266224ea2 hwinfo-8.38.tar.gz 569050
diff --git a/sys-apps/hwinfo/hwinfo-13.0.ebuild b/sys-apps/hwinfo/hwinfo-13.0.ebuild
new file mode 100644
index 000000000000..4a016e44b1c8
--- /dev/null
+++ b/sys-apps/hwinfo/hwinfo-13.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwinfo/hwinfo-13.0.ebuild,v 1.1 2006/07/22 04:31:17 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="hwinfo is the hardware detection tool used in SuSE Linux."
+HOMEPAGE="http://www.suse.com"
+DEBIAN_PV="4"
+DEBIAN_BASE_URI=" mirror://debian/pool/main/${PN:0:1}/${PN}/"
+SRC_URI="${DEBIAN_BASE_URI}/${PN}_${PV}.orig.tar.gz
+ ${DEBIAN_BASE_URI}/${PN}_${PV}-${DEBIAN_PV}.diff.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+DEPEND="sys-fs/sysfsutils
+ sys-apps/hal
+ sys-apps/dbus"
+
+src_unpack (){
+ unpack ${PN}_${PV}.orig.tar.gz
+ mv ${S}/${P}.tar.gz ${WORKDIR} && rmdir ${S}
+ unpack ./${P}.tar.gz
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${DISTDIR}/${PN}_${PV}-${DEBIAN_PV}.diff.gz
+ for p in ${S}/debian/patches/*; do
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${p}
+ done
+ #EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${P}-makefile-fixes.patch
+ #sed -i -e "s,^LIBS[ \t]*= -lhd,LIBS = -lhd -lsysfs," ${S}/Makefile
+ #sed -i -e "s,^LIBDIR[ \t]*= /usr/lib$,LIBDIR = /usr/$(get_libdir)," ${S}/Makefile
+ echo 'libs: $(LIBHD) $(LIBHD_SO)' >>${S}/Makefile
+}
+
+src_compile(){
+ # build is NOT parallel safe
+ emake -j1 EXTRA_FLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc VERSION README COPYING ChangeLog
+ doman doc/hwinfo.8
+ # this is the SuSE version
+ # somebody needs to port it still
+ rm ${D}/etc/init.d/hwscan
+}