summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-06-11 13:18:52 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-06-11 13:18:52 +0000
commite4c5a6756818bfc63459fbfb89c3b9b1b0a98b84 (patch)
tree02523e6ad8613b780ee30f1456a09587ff909909 /sys-apps/iproute2/files
parentadd ~arm, bug #359137 (diff)
downloadgentoo-2-e4c5a6756818bfc63459fbfb89c3b9b1b0a98b84.tar.gz
gentoo-2-e4c5a6756818bfc63459fbfb89c3b9b1b0a98b84.tar.bz2
gentoo-2-e4c5a6756818bfc63459fbfb89c3b9b1b0a98b84.zip
Cleanup live version to use git-2 and base eclasses, EAPI=4, remove wrong prepalldocs call. Version bump to 2.6.38 (copy from live) which works with latest iptables. Punt all overshadowed versions keeping 2 in testing and 2 in stable. This also fixes bug #370793.
(Portage version: 2.2.0_alpha39/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/iproute2/files')
-rw-r--r--sys-apps/iproute2/files/iproute2-2.6.26-linux-2.6.27-API.patch48
-rw-r--r--sys-apps/iproute2/files/iproute2-2.6.34-dnet-fix-strict-aliasing-warnings.patch75
-rw-r--r--sys-apps/iproute2/files/iproute2-2.6.34-netem-fix-installs-of-dist-files.patch36
-rw-r--r--sys-apps/iproute2/files/iproute2-2.6.34-tc-revert-echo-in-install-target.patch36
4 files changed, 0 insertions, 195 deletions
diff --git a/sys-apps/iproute2/files/iproute2-2.6.26-linux-2.6.27-API.patch b/sys-apps/iproute2/files/iproute2-2.6.26-linux-2.6.27-API.patch
deleted file mode 100644
index 78647efa2cac..000000000000
--- a/sys-apps/iproute2/files/iproute2-2.6.26-linux-2.6.27-API.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From 5a67f8f9d3a7f80a49554fb1ca4e68a1effd5399 Mon Sep 17 00:00:00 2001
-From: Stephen Hemminger <stephen.hemminger@vyatta.com>
-Date: Mon, 15 Sep 2008 12:05:11 -0700
-Subject: [PATCH] Update to 2.6.27 API
-
-The one issue was the old multiqueue API, so that is handled
-by tc_util.h
----
- include/linux/atm.h | 1 +
- include/linux/if.h | 15 ++++++++-------
- include/linux/if_vlan.h | 1 +
- include/linux/ip6_tunnel.h | 4 ----
- include/linux/netfilter.h | 1 +
- include/linux/netfilter_ipv4.h | 1 +
- include/linux/netfilter_ipv4/ip_tables.h | 1 +
- include/linux/pkt_cls.h | 1 +
- include/linux/pkt_sched.h | 29 ++++++++++++++++++++---------
- include/linux/rtnetlink.h | 1 +
- include/linux/socket.h | 5 ++++-
- tc/tc_util.h | 12 ++++++++++++
- 12 files changed, 51 insertions(+), 21 deletions(-)
-
-diff --git a/tc/tc_util.h b/tc/tc_util.h
-index 796da54..39d5367 100644
---- a/tc/tc_util.h
-+++ b/tc/tc_util.h
-@@ -7,6 +7,18 @@
- #include <linux/gen_stats.h>
- #include "tc_core.h"
-
-+/* This is the deprecated multiqueue interface */
-+#ifndef TCA_PRIO_MAX
-+enum
-+{
-+ TCA_PRIO_UNSPEC,
-+ TCA_PRIO_MQ,
-+ __TCA_PRIO_MAX
-+};
-+
-+#define TCA_PRIO_MAX (__TCA_PRIO_MAX - 1)
-+#endif
-+
- struct qdisc_util
- {
- struct qdisc_util *next;
---
-1.6.0.2
-
diff --git a/sys-apps/iproute2/files/iproute2-2.6.34-dnet-fix-strict-aliasing-warnings.patch b/sys-apps/iproute2/files/iproute2-2.6.34-dnet-fix-strict-aliasing-warnings.patch
deleted file mode 100644
index 7dbe9fa970d4..000000000000
--- a/sys-apps/iproute2/files/iproute2-2.6.34-dnet-fix-strict-aliasing-warnings.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-From f9ec992065291ddada270aebad0d5c82d8ed72db Mon Sep 17 00:00:00 2001
-From: Mike Frysinger <vapier@gentoo.org>
-Date: Wed, 9 Jun 2010 20:46:33 -0400
-Subject: [PATCH] dnet: fix strict aliasing warnings
-
-Recent gcc doesn't like it when you cast char pointers to uint16_t
-pointers and then dereference it. So use memcpy() instead and let
-gcc take care of optimizing things away (when appropriate). This
-should also fix alignment issues on arches where gcc packs the char
-pointer tighter than 16bits.
-
-Signed-off-by: Mike Frysinger <vapier@gentoo.org>
----
- lib/dnet_ntop.c | 8 ++++++--
- lib/dnet_pton.c | 5 ++++-
- 2 files changed, 10 insertions(+), 3 deletions(-)
-
-diff --git a/lib/dnet_ntop.c b/lib/dnet_ntop.c
-index 9500df8..507a7eb 100644
---- a/lib/dnet_ntop.c
-+++ b/lib/dnet_ntop.c
-@@ -1,4 +1,5 @@
- #include <errno.h>
-+#include <string.h>
- #include <sys/types.h>
- #include <netinet/in.h>
-
-@@ -35,11 +36,14 @@ static __inline__ int do_digit(char *str, u_int16_t *addr, u_int16_t scale, size
-
- static const char *dnet_ntop1(const struct dn_naddr *dna, char *str, size_t len)
- {
-- u_int16_t addr = dn_ntohs(*(u_int16_t *)dna->a_addr);
-- u_int16_t area = addr >> 10;
-+ u_int16_t addr, area;
- size_t pos = 0;
- int started = 0;
-
-+ memcpy(&addr, dna->a_addr, sizeof(addr));
-+ addr = dn_ntohs(addr);
-+ area = addr >> 10;
-+
- if (dna->a_len != 2)
- return NULL;
-
-diff --git a/lib/dnet_pton.c b/lib/dnet_pton.c
-index bd7727a..7385756 100644
---- a/lib/dnet_pton.c
-+++ b/lib/dnet_pton.c
-@@ -1,4 +1,5 @@
- #include <errno.h>
-+#include <string.h>
- #include <sys/types.h>
- #include <netinet/in.h>
-
-@@ -37,6 +38,7 @@ static int dnet_num(const char *src, u_int16_t * dst)
-
- static int dnet_pton1(const char *src, struct dn_naddr *dna)
- {
-+ u_int16_t addr;
- u_int16_t area = 0;
- u_int16_t node = 0;
- int pos;
-@@ -48,7 +50,8 @@ static int dnet_pton1(const char *src, struct dn_naddr *dna)
- if ((pos == 0) || (node > 1023))
- return 0;
- dna->a_len = 2;
-- *(u_int16_t *)dna->a_addr = dn_htons((area << 10) | node);
-+ addr = dn_htons((area << 10) | node);
-+ memcpy(dna->a_addr, &addr, sizeof(addr));
-
- return 1;
- }
---
-1.7.1
-
diff --git a/sys-apps/iproute2/files/iproute2-2.6.34-netem-fix-installs-of-dist-files.patch b/sys-apps/iproute2/files/iproute2-2.6.34-netem-fix-installs-of-dist-files.patch
deleted file mode 100644
index fc74638fc24c..000000000000
--- a/sys-apps/iproute2/files/iproute2-2.6.34-netem-fix-installs-of-dist-files.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From a84389f8d3f0960c60db81f83057140a17f5c841 Mon Sep 17 00:00:00 2001
-From: Mike Frysinger <vapier@gentoo.org>
-Date: Wed, 9 Jun 2010 20:36:57 -0400
-Subject: [PATCH] netem: fix installs of dist files
-
-The tc program searches LIBDIR by default for the .dist files, and that
-defaults to /usr/lib. But the netem subdir has /lib/ hardcoded which
-means the default build+install results in the files not being found.
-
-Further, these are plain text files which are read at runtime, so it
-doesn't make sense to give them executable bits.
-
-Signed-off-by: Mike Frysinger <vapier@gentoo.org>
----
- netem/Makefile | 4 ++--
- 1 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/netem/Makefile b/netem/Makefile
-index b6ccfc6..e52e125 100644
---- a/netem/Makefile
-+++ b/netem/Makefile
-@@ -20,9 +20,9 @@ stats: stats.c
- $(HOSTCC) $(CCOPTS) -I../include -o $@ $@.c -lm
-
- install: all
-- mkdir -p $(DESTDIR)/lib/tc
-+ mkdir -p $(DESTDIR)$(LIBDIR)/tc
- for i in $(DISTDATA); \
-- do install -m 755 $$i $(DESTDIR)/lib/tc; \
-+ do install -m 644 $$i $(DESTDIR)$(LIBDIR)/tc; \
- done
-
- clean:
---
-1.7.1
-
diff --git a/sys-apps/iproute2/files/iproute2-2.6.34-tc-revert-echo-in-install-target.patch b/sys-apps/iproute2/files/iproute2-2.6.34-tc-revert-echo-in-install-target.patch
deleted file mode 100644
index f9c90898fa9e..000000000000
--- a/sys-apps/iproute2/files/iproute2-2.6.34-tc-revert-echo-in-install-target.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 94efd93e2bdd2a1d739f4f86bf6a013b081a481a Mon Sep 17 00:00:00 2001
-From: Mike Frysinger <vapier@gentoo.org>
-Date: Wed, 9 Jun 2010 20:32:26 -0400
-Subject: [PATCH] tc: revert "echo" in install target
-
-The recent commit "iproute2: add option to build m_xt as a tc module"
-(ab814d635529787) looks like it wrongly included debug changes in the
-install target. So drop the `echo` so the tc binary actually gets
-installed again.
-
-Signed-off-by: Mike Frysinger <vapier@gentoo.org>
----
- tc/Makefile | 6 +++---
- 1 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/tc/Makefile b/tc/Makefile
-index 01a16fc..3aa9f26 100644
---- a/tc/Makefile
-+++ b/tc/Makefile
-@@ -99,10 +99,10 @@ libtc.a: $(TCLIB)
- $(AR) rcs $@ $(TCLIB)
-
- install: all
-- echo mkdir -p $(MODDESTDIR)
-- echo install -m 0755 tc $(DESTDIR)$(SBINDIR)
-+ mkdir -p $(MODDESTDIR)
-+ install -m 0755 tc $(DESTDIR)$(SBINDIR)
- for i in $(TCSO); \
-- do echo install -m 755 $$i $(MODDESTDIR); \
-+ do install -m 755 $$i $(MODDESTDIR); \
- done
- if [ ! -f $(MODDESTDIR)/m_ipt.so ]; then \
- if [ -f $(MODDESTDIR)/m_xt.so ]; \
---
-1.7.1
-