summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-09-06 08:40:00 +0000
committerRoy Marples <uberlord@gentoo.org>2006-09-06 08:40:00 +0000
commit986ed85efa94f4deda3242fe956b7a55354ac1f2 (patch)
treef0306a728e05bf2de5ec99d17bc5c08e87ef56b9 /sys-apps/iproute2/iproute2-2.6.16.20060323.ebuild
parentUpdate to layman-1.0.7 (diff)
downloadgentoo-2-986ed85efa94f4deda3242fe956b7a55354ac1f2.tar.gz
gentoo-2-986ed85efa94f4deda3242fe956b7a55354ac1f2.tar.bz2
gentoo-2-986ed85efa94f4deda3242fe956b7a55354ac1f2.zip
Warn about needing NETLINK for kernels prior to 2.4.17
(Portage version: 2.1.1_rc1-r4)
Diffstat (limited to 'sys-apps/iproute2/iproute2-2.6.16.20060323.ebuild')
-rw-r--r--sys-apps/iproute2/iproute2-2.6.16.20060323.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/sys-apps/iproute2/iproute2-2.6.16.20060323.ebuild b/sys-apps/iproute2/iproute2-2.6.16.20060323.ebuild
index 4d502c7d4076..66697fba4ab3 100644
--- a/sys-apps/iproute2/iproute2-2.6.16.20060323.ebuild
+++ b/sys-apps/iproute2/iproute2-2.6.16.20060323.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.6.16.20060323.ebuild,v 1.6 2006/08/18 10:21:25 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.6.16.20060323.ebuild,v 1.7 2006/09/06 08:40:00 uberlord Exp $
inherit eutils toolchain-funcs
@@ -23,6 +23,15 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}-${MY_PV}-${SNAP}
+pkg_setup() {
+ if use kernel_linux ; then
+ ewarn
+ ewarn "${PN} requires kernel support for Netlink (CONFIG_NETLINK)."
+ ewarn "This is only applies for kernels prior to 2.4.17"
+ ewarn
+ fi
+}
+
src_unpack() {
unpack ${A}
cd "${S}"