summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-06-24 06:07:47 +0000
committerMike Frysinger <vapier@gentoo.org>2006-06-24 06:07:47 +0000
commit51fec676a54782644c143bab7f7a39bd756a612e (patch)
tree19a9946bf48e6614ba73fa95d22c3c1ee2aaa70e /sys-apps/iproute2
parentfix building with USE=-ssl #137796 (diff)
downloadgentoo-2-51fec676a54782644c143bab7f7a39bd756a612e.tar.gz
gentoo-2-51fec676a54782644c143bab7f7a39bd756a612e.tar.bz2
gentoo-2-51fec676a54782644c143bab7f7a39bd756a612e.zip
Let portage strip binaries #137574 by Tristan Heaven.
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'sys-apps/iproute2')
-rw-r--r--sys-apps/iproute2/ChangeLog7
-rw-r--r--sys-apps/iproute2/files/iproute2-2.6.16.20060323-build.patch41
-rw-r--r--sys-apps/iproute2/iproute2-2.6.16.20060323.ebuild3
3 files changed, 49 insertions, 2 deletions
diff --git a/sys-apps/iproute2/ChangeLog b/sys-apps/iproute2/ChangeLog
index 8ca646ec5b09..d6e99dc65463 100644
--- a/sys-apps/iproute2/ChangeLog
+++ b/sys-apps/iproute2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/iproute2
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/ChangeLog,v 1.54 2006/04/19 00:32:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/ChangeLog,v 1.55 2006/06/24 06:07:47 vapier Exp $
+
+ 24 Jun 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/iproute2-2.6.16.20060323-build.patch,
+ iproute2-2.6.16.20060323.ebuild:
+ Let portage strip binaries #137574 by Tristan Heaven.
19 Apr 2006; Mike Frysinger <vapier@gentoo.org>
+files/iproute2-2.6.16.20060323-ifcfg-catch-missing-argument.patch,
diff --git a/sys-apps/iproute2/files/iproute2-2.6.16.20060323-build.patch b/sys-apps/iproute2/files/iproute2-2.6.16.20060323-build.patch
new file mode 100644
index 000000000000..7512cfcc6b55
--- /dev/null
+++ b/sys-apps/iproute2/files/iproute2-2.6.16.20060323-build.patch
@@ -0,0 +1,41 @@
+let portage strip the binaries
+
+http://bugs.gentoo.org/137574
+
+--- ip/Makefile
++++ ip/Makefile
+@@ -16,7 +16,7 @@
+ rtmon: $(RTMONOBJ) $(LIBNETLINK)
+
+ install: all
+- install -m 0755 -s $(TARGETS) $(DESTDIR)$(SBINDIR)
++ install -m 0755 $(TARGETS) $(DESTDIR)$(SBINDIR)
+ install -m 0755 $(SCRIPTS) $(DESTDIR)$(SBINDIR)
+
+ clean:
+
+--- misc/Makefile
++++ misc/Makefile
+@@ -27,7 +27,7 @@
+ lnstat: $(LNSTATOBJ)
+
+ install: all
+- install -m 0755 -s $(TARGETS) $(DESTDIR)$(SBINDIR)
++ install -m 0755 $(TARGETS) $(DESTDIR)$(SBINDIR)
+ ln -sf lnstat $(DESTDIR)$(SBINDIR)/rtstat
+ ln -sf lnstat $(DESTDIR)$(SBINDIR)/ctstat
+
+--- tc/Makefile
++++ tc/Makefile
+@@ -70,9 +70,9 @@
+
+ install: all
+ mkdir -p $(DESTDIR)/usr/lib/tc
+- install -m 0755 -s tc $(DESTDIR)$(SBINDIR)
++ install -m 0755 tc $(DESTDIR)$(SBINDIR)
+ for i in $(TCSO); \
+- do install -m 755 -s $$i $(DESTDIR)/usr/lib/tc; \
++ do install -m 755 $$i $(DESTDIR)/usr/lib/tc; \
+ done
+
+ clean:
diff --git a/sys-apps/iproute2/iproute2-2.6.16.20060323.ebuild b/sys-apps/iproute2/iproute2-2.6.16.20060323.ebuild
index b54a082bf9d0..12d6defd4af8 100644
--- a/sys-apps/iproute2/iproute2-2.6.16.20060323.ebuild
+++ b/sys-apps/iproute2/iproute2-2.6.16.20060323.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.6.16.20060323.ebuild,v 1.3 2006/06/11 14:47:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.6.16.20060323.ebuild,v 1.4 2006/06/24 06:07:47 vapier Exp $
inherit eutils toolchain-funcs
@@ -29,6 +29,7 @@ src_unpack() {
sed -i -e "s:-O2:${CFLAGS}:" Makefile || die "sed Makefile failed"
epatch "${FILESDIR}"/${P}-ifcfg-catch-missing-argument.patch #130243
+ epatch "${FILESDIR}"/${P}-build.patch #137574
#68948 - esfq/wrr patches
epatch "${FILESDIR}"/${PN}-051007-esfq-2.6.13.patch