summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-15 07:31:42 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-15 07:31:42 +0000
commitdc989913fe3e38b03c3442478026eeb20d76fece (patch)
tree8564765a8253eb9c8a54fed3780797bb98963ddf /sys-apps/iproute2
parentppc stable (diff)
downloadgentoo-2-dc989913fe3e38b03c3442478026eeb20d76fece.tar.gz
gentoo-2-dc989913fe3e38b03c3442478026eeb20d76fece.tar.bz2
gentoo-2-dc989913fe3e38b03c3442478026eeb20d76fece.zip
Make routef a little saner #139853 by Lars Strojny.
(Portage version: 2.1.1_pre2-r8)
Diffstat (limited to 'sys-apps/iproute2')
-rw-r--r--sys-apps/iproute2/ChangeLog7
-rw-r--r--sys-apps/iproute2/files/iproute2-2.6.16.20060323-routef-safe.patch17
-rw-r--r--sys-apps/iproute2/iproute2-2.6.16.20060323.ebuild3
3 files changed, 25 insertions, 2 deletions
diff --git a/sys-apps/iproute2/ChangeLog b/sys-apps/iproute2/ChangeLog
index d6e99dc65463..6f3ceb801727 100644
--- a/sys-apps/iproute2/ChangeLog
+++ b/sys-apps/iproute2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/iproute2
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/ChangeLog,v 1.55 2006/06/24 06:07:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/ChangeLog,v 1.56 2006/07/15 07:31:42 vapier Exp $
+
+ 15 Jul 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/iproute2-2.6.16.20060323-routef-safe.patch,
+ iproute2-2.6.16.20060323.ebuild:
+ Make routef a little saner #139853 by Lars Strojny.
24 Jun 2006; Mike Frysinger <vapier@gentoo.org>
+files/iproute2-2.6.16.20060323-build.patch,
diff --git a/sys-apps/iproute2/files/iproute2-2.6.16.20060323-routef-safe.patch b/sys-apps/iproute2/files/iproute2-2.6.16.20060323-routef-safe.patch
new file mode 100644
index 000000000000..a592d11a26f9
--- /dev/null
+++ b/sys-apps/iproute2/files/iproute2-2.6.16.20060323-routef-safe.patch
@@ -0,0 +1,17 @@
+http://bugs.gentoo.org/139853
+
+diff --git a/ip/routef b/ip/routef
+index db43b5d..d266e2d 100644
+--- a/ip/routef
++++ b/ip/routef
+@@ -1,3 +1,9 @@
+ #! /bin/sh
+
+-exec ip -4 ro flush scope global type unicast
++if [ -z "$*" ] ; then
++ exec ip -4 ro flush scope global type unicast
++else
++ echo "Usage: routef"
++ echo
++ echo "This script will flush the IPv4 routing table"
++fi
diff --git a/sys-apps/iproute2/iproute2-2.6.16.20060323.ebuild b/sys-apps/iproute2/iproute2-2.6.16.20060323.ebuild
index 12d6defd4af8..9fdd5c482911 100644
--- a/sys-apps/iproute2/iproute2-2.6.16.20060323.ebuild
+++ b/sys-apps/iproute2/iproute2-2.6.16.20060323.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.6.16.20060323.ebuild,v 1.4 2006/06/24 06:07:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.6.16.20060323.ebuild,v 1.5 2006/07/15 07:31:42 vapier Exp $
inherit eutils toolchain-funcs
@@ -30,6 +30,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-ifcfg-catch-missing-argument.patch #130243
epatch "${FILESDIR}"/${P}-build.patch #137574
+ epatch "${FILESDIR}"/${P}-routef-safe.patch #139853
#68948 - esfq/wrr patches
epatch "${FILESDIR}"/${PN}-051007-esfq-2.6.13.patch