summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-12-04 23:32:04 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-12-04 23:32:04 +0000
commit8407623c8e13102b14d132fd814cec3df48dd0b6 (patch)
treecedc577c1cf7fd7fb2516581074fef5a519de33d /sys-apps/ivman
parentRestoring older version due to broken dep of a stale package :(. Band aid whe... (diff)
downloadgentoo-2-8407623c8e13102b14d132fd814cec3df48dd0b6.tar.gz
gentoo-2-8407623c8e13102b14d132fd814cec3df48dd0b6.tar.bz2
gentoo-2-8407623c8e13102b14d132fd814cec3df48dd0b6.zip
version bump to fix bug 149112 thanks to Victor Ashirov <victor.ashirov@gmail.com> for testing
(Portage version: 2.1.2_rc2-r5)
Diffstat (limited to 'sys-apps/ivman')
-rw-r--r--sys-apps/ivman/ChangeLog8
-rw-r--r--sys-apps/ivman/files/digest-ivman-0.6.133
-rw-r--r--sys-apps/ivman/ivman-0.6.13.ebuild67
3 files changed, 77 insertions, 1 deletions
diff --git a/sys-apps/ivman/ChangeLog b/sys-apps/ivman/ChangeLog
index 084abcd4cd4a..c07df9c7ca91 100644
--- a/sys-apps/ivman/ChangeLog
+++ b/sys-apps/ivman/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/ivman
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/ivman/ChangeLog,v 1.45 2006/08/18 00:45:02 malc Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ivman/ChangeLog,v 1.46 2006/12/04 23:32:04 genstef Exp $
+
+*ivman-0.6.13 (04 Dec 2006)
+
+ 04 Dec 2006; Stefan Schweizer <genstef@gentoo.org> +ivman-0.6.13.ebuild:
+ version bump to fix bug 149112 thanks to Victor Ashirov
+ <victor.ashirov@gmail.com> for testing
18 Aug 2006; <malc@gentoo.org> ivman-0.6.12.ebuild:
Stable on amd64
diff --git a/sys-apps/ivman/files/digest-ivman-0.6.13 b/sys-apps/ivman/files/digest-ivman-0.6.13
new file mode 100644
index 000000000000..3718e4c1efcd
--- /dev/null
+++ b/sys-apps/ivman/files/digest-ivman-0.6.13
@@ -0,0 +1,3 @@
+MD5 0edfa11c099a3f421cca029eacca5349 ivman-0.6.13.tar.bz2 317106
+RMD160 a350d01ba4544813b9c738f2151023a11cb2a87e ivman-0.6.13.tar.bz2 317106
+SHA256 c6cd955c33c8c6a20c4729d4c76571c08799f96f062e8d053b392a8e9a64a1a4 ivman-0.6.13.tar.bz2 317106
diff --git a/sys-apps/ivman/ivman-0.6.13.ebuild b/sys-apps/ivman/ivman-0.6.13.ebuild
new file mode 100644
index 000000000000..67ffc14bc2b7
--- /dev/null
+++ b/sys-apps/ivman/ivman-0.6.13.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ivman/ivman-0.6.13.ebuild,v 1.1 2006/12/04 23:32:04 genstef Exp $
+
+inherit eutils
+
+DESCRIPTION="Daemon to mount/unmount devices, based on info from HAL"
+HOMEPAGE="http://ivman.sf.net"
+SRC_URI="mirror://sourceforge/ivman/${P}.tar.bz2"
+LICENSE="GPL-2 QPL"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+SLOT="0"
+
+RDEPEND=">=dev-libs/glib-2.6
+ dev-libs/libxml2
+ sys-devel/gettext
+ >=sys-apps/hal-0.4.0
+ >=sys-apps/pmount-0.8"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.5
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf $(use_enable debug) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ exeinto /etc/init.d/
+ newexe ${FILESDIR}/ivman-0.3.init ivman
+}
+
+pkg_postinst() {
+ # Ivman can now run as a non-root user :-) Create a dedicated user account,
+ # so users can add rules to /etc/sudoers for programs Ivman wants to
+ # execute...
+ # The group here is intended to be the one needed to use pmount, but Ivman
+ # will still work as long as the group in IvmConfigBase.xml is correct.
+ enewuser ivman -1 -1 /dev/null plugdev
+
+ if has_version "<sys-apps/hal-0.5.0"; then
+ einfo "Ivman was built against HAL 0.4.x. If you later upgrade to HAL 0.5,"
+ einfo "you must re-merge Ivman."
+ echo
+ else
+ einfo "Ivman was built against HAL 0.5.x. If you later downgrade to HAL 0.4,"
+ einfo "you must re-merge Ivman."
+ echo
+ fi
+
+ einfo "Note that, as of version 0.6.0, the IvmConfigMappings.xml configuration"
+ einfo "file is no longer required to correctly mount fstab entries which"
+ einfo "use symbolic links. You may safely remove this file if desired."
+ einfo "However, HAL typically does not correctly deal with fstab"
+ einfo "entries of this nature, therefore it is strongly recommanded that"
+ einfo "you have real device names (i.e. not symlinks) in /etc/fstab."
+ echo
+
+ einfo "By default, Ivman will mount any removable disks as they are"
+ einfo "attached. If you want Ivman to do more, such as hibernating"
+ einfo "your laptop when the lid is closed or when the battery is low,"
+ einfo "look at the configuration files in /etc/ivman/ ."
+}