summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGordon Malm <gengor@gentoo.org>2009-07-25 01:03:21 +0000
committerGordon Malm <gengor@gentoo.org>2009-07-25 01:03:21 +0000
commit010aa194053ef48598dbc931cd3d8a4bd6e46dfb (patch)
treecfc01ea414730f28ea6f89b1c9d83b0b898217bf /sys-apps/lm_sensors
parentremove unused use flag (diff)
downloadgentoo-2-010aa194053ef48598dbc931cd3d8a4bd6e46dfb.tar.gz
gentoo-2-010aa194053ef48598dbc931cd3d8a4bd6e46dfb.tar.bz2
gentoo-2-010aa194053ef48598dbc931cd3d8a4bd6e46dfb.zip
Version bump lm_sensors-3.0.3, bug 244598.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'sys-apps/lm_sensors')
-rw-r--r--sys-apps/lm_sensors/ChangeLog8
-rw-r--r--sys-apps/lm_sensors/files/lm_sensors-3.0.3-sensors-detect-gentoo.patch116
-rw-r--r--sys-apps/lm_sensors/lm_sensors-3.0.3.ebuild114
3 files changed, 237 insertions, 1 deletions
diff --git a/sys-apps/lm_sensors/ChangeLog b/sys-apps/lm_sensors/ChangeLog
index 9e68e2d1f3cc..bdb240b11e44 100644
--- a/sys-apps/lm_sensors/ChangeLog
+++ b/sys-apps/lm_sensors/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/lm_sensors
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/ChangeLog,v 1.92 2009/06/07 14:48:27 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/ChangeLog,v 1.93 2009/07/25 01:03:21 gengor Exp $
+
+*lm_sensors-3.0.3 (25 Jul 2009)
+
+ 25 Jul 2009; Gordon Malm <gengor@gentoo.org> +lm_sensors-3.0.3.ebuild,
+ +files/lm_sensors-3.0.3-sensors-detect-gentoo.patch:
+ Version bump lm_sensors-3.0.3, bug 244598.
*lm_sensors-2.10.8 (07 Jun 2009)
diff --git a/sys-apps/lm_sensors/files/lm_sensors-3.0.3-sensors-detect-gentoo.patch b/sys-apps/lm_sensors/files/lm_sensors-3.0.3-sensors-detect-gentoo.patch
new file mode 100644
index 000000000000..ff353f957b58
--- /dev/null
+++ b/sys-apps/lm_sensors/files/lm_sensors-3.0.3-sensors-detect-gentoo.patch
@@ -0,0 +1,116 @@
+diff -urN lm_sensors-3.0.3.orig/prog/detect/sensors-detect lm_sensors-3.0.3/prog/detect/sensors-detect
+--- lm_sensors-3.0.3.orig/prog/detect/sensors-detect 2008-09-19 17:05:28.000000000 +0200
++++ lm_sensors-3.0.3/prog/detect/sensors-detect 2008-10-27 10:03:39.000000000 +0100
+@@ -27,6 +27,9 @@
+ # each be put in a separate file, using modules and packages. That is beyond
+ # me.
+
++# Gentoo specific modifications based on a patch from Rudo Thomas
++# <thomr9am@ss1000.ms.mff.cuni.cz>
++
+ require 5.004;
+
+ use strict;
+@@ -6076,29 +6079,35 @@
+ print MODPROBE_D $configfile;
+ close(MODPROBE_D);
+ } else {
++ print "\nIf you want to load the modules at startup, generate a config file\n",
++ "below and make sure lm_sensors gets started at boot time; e.g\n",
++ "\$ rc-update add lm_sensors default\n";
+ print "To make the sensors modules behave correctly, add these lines to\n".
+- "$modules_conf:\n\n";
++ "/etc/modules.d/lm_sensors and run modules-update:\n\n";
+ print "#----cut here----\n".
+ $configfile.
+ "#----cut here----\n\n";
+ }
+ }
+
+- my $have_sysconfig = -d '/etc/sysconfig';
+- printf "Do you want to \%s /etc/sysconfig/lm_sensors? (\%s): ",
+- (-e '/etc/sysconfig/lm_sensors' ? 'overwrite' : 'generate'),
+- ($have_sysconfig ? 'YES/no' : 'yes/NO');
+- $_ = <STDIN>;
+- if (($have_sysconfig and not m/^\s*n/i) or m/^\s*y/i) {
+- unless ($have_sysconfig) {
+- mkdir('/etc/sysconfig', 0777)
+- or die "Sorry, can't create /etc/sysconfig ($!)";
+- }
+- open(local *SYSCONFIG, ">/etc/sysconfig/lm_sensors")
+- or die "Sorry, can't create /etc/sysconfig/lm_sensors ($!)";
+- print SYSCONFIG <<'EOT';
+-# /etc/sysconfig/lm_sensors - Defines modules loaded by
+-# /etc/init.d/lm_sensors
++ my $have_config = -f '/etc/conf.d/lm_sensors';
++ print "\nDo you want to ".($have_config?"overwrite":"generate").
++ " /etc/conf.d/lm_sensors? Enter s to specify other file name?\n",
++ " (".($have_config?"yes/NO":"YES/no")."/s): ";
++ my $reply = <STDIN>;
++
++ if (($have_config and $reply =~ /^\s*[Yy]/) or
++ (not $have_config and not $reply =~ /^\s*[Nn]/) or
++ $reply =~ /^\s*[Ss]/) {
++ my $filename = "/etc/conf.d/lm_sensors";
++ if ($reply =~ /^\s*[Ss]/) {
++ print "Specify the file to store the configuration to: ";
++ $filename = <STDIN>;
++ }
++ open(SYSCONFIG, ">".$filename)
++ or die "Sorry, can't create $filename ($!).";
++ print SYSCONFIG <<'EOT';
++# /etc/conf.d/sensors - Defines modules loaded by /etc/init.d/lm_sensors
+ # Copyright (c) 1998 - 2001 Frodo Looijaard <frodol@dds.nl>
+ #
+ # This program is free software; you can redistribute it and/or modify
+@@ -6127,12 +6136,21 @@
+ # in order as normal variables with the special names:
+ # MODULE_0, MODULE_1, MODULE_2, etc.
+ #
++# Please note that the numbers in MODULE_X must start at 0 and increase in
++# steps of 1. Any number that is missing will make the init script skip the
++# rest of the modules. Use MODULE_X_ARGS for arguments.
++#
+ # List the modules that are to be loaded for your system
+ #
+ EOT
+ print SYSCONFIG
+- "# Generated by sensors-detect on " . scalar localtime() . "\n";
++ "# Generated by sensors-detect on " . scalar localtime() . "\n\n";
+ my @modules = grep /^modprobe /, split "\n", $modprobes;
++ print SYSCONFIG
++ "# Load modules at startup\n".
++ "LOADMODULES=yes\n\n".
++ "# Initialize sensors at startup\n".
++ "INITSENSORS=yes\n\n";
+ my $i = 0;
+ my $sysconfig = "";
+ foreach (@modules) {
+@@ -6142,10 +6160,8 @@
+ }
+ print SYSCONFIG $sysconfig;
+ close(SYSCONFIG);
++ print "Done.\n";
+
+- print "Copy prog/init/lm_sensors.init to /etc/init.d/lm_sensors\n".
+- "for initialization at boot time.\n"
+- unless -f "/etc/init.d/lm_sensors";
+
+ if (-x "/sbin/insserv" && -f "/etc/init.d/lm_sensors") {
+ system("/sbin/insserv", "/etc/init.d/lm_sensors");
+@@ -6159,15 +6175,6 @@
+ "kernel modules.\n\n";
+ }
+ } else {
+- print "To load everything that is needed, add this to one of the system\n".
+- "initialization scripts (e.g. /etc/rc.d/rc.local):\n\n";
+- print "#----cut here----\n".
+- $modprobes.
+- (-e '/usr/bin/sensors' ?
+- "/usr/bin/sensors -s\n" :
+- "/usr/local/bin/sensors -s\n") .
+- "#----cut here----\n\n";
+-
+ print "If you have some drivers built into your kernel, the list above will\n".
+ "contain too many modules. Skip the appropriate ones! You really\n".
+ "should try these commands right now to make sure everything is\n".
diff --git a/sys-apps/lm_sensors/lm_sensors-3.0.3.ebuild b/sys-apps/lm_sensors/lm_sensors-3.0.3.ebuild
new file mode 100644
index 000000000000..4d8bd26bb280
--- /dev/null
+++ b/sys-apps/lm_sensors/lm_sensors-3.0.3.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/lm_sensors-3.0.3.ebuild,v 1.1 2009/07/25 01:03:21 gengor Exp $
+
+EAPI=2
+
+inherit eutils flag-o-matic linux-info toolchain-funcs multilib
+
+DESCRIPTION="Hardware Monitoring user-space utilities"
+HOMEPAGE="http://www.lm-sensors.org/"
+SRC_URI="http://dl.lm-sensors.org/lm-sensors/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="sensord"
+
+COMMON="sensord? ( net-analyzer/rrdtool )"
+DEPEND="${COMMON}
+ sys-apps/sed"
+RDEPEND="${COMMON}
+ dev-lang/perl
+ virtual/logger"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ if ! linux_chkconfig_present HWMON; then
+ eerror
+ eerror "${P} requires CONFIG_HWMON to be enabled."
+ eerror
+ die "CONFIG_HWMON not detected"
+ fi
+ if ! linux_chkconfig_present I2C_CHARDEV; then
+ ewarn
+ ewarn "sensors-detect requires CONFIG_I2C_CHARDEV to be enabled."
+ ewarn
+ fi
+ if ! linux_chkconfig_present I2C; then
+ ewarn
+ ewarn "${P} requires CONFIG_I2C to be enabled for most sensors."
+ ewarn
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.0.3-sensors-detect-gentoo.patch
+
+ if use sensord; then
+ sed -i -e 's:^# \(PROG_EXTRA\):\1:' "${S}"/Makefile || die
+ fi
+
+ # Respect LDFLAGS
+ sed -i -e 's/\$(LIBDIR)$/\$(LIBDIR) \$(LDFLAGS)/g' Makefile || die
+ sed -i -e 's/\$(LIBSHSONAME) -o/$(LIBSHSONAME) \$(LDFLAGS) -o/g' lib/Module.mk || die
+}
+
+src_compile() {
+ einfo
+ einfo "You may safely ignore any errors from compilation"
+ einfo "that contain \"No such file or directory\" references."
+ einfo
+
+ filter-flags -fstack-protector
+
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr MANDIR=/usr/share/man LIBDIR=/usr/$(get_libdir) \
+ install || die "emake install failed"
+
+ newinitd "${FILESDIR}"/lm_sensors-3-init.d lm_sensors || die
+ newinitd "${FILESDIR}"/fancontrol-init.d fancontrol || die
+
+ if use sensord; then
+ newconfd "${FILESDIR}"/sensord-conf.d sensord || die
+ newinitd "${FILESDIR}"/sensord-init.d sensord || die
+ fi
+
+ dodoc CHANGES CONTRIBUTORS INSTALL README* || die
+
+ dodoc doc/donations doc/fancontrol.txt doc/fan-divisors \
+ doc/progs doc/temperature-sensors doc/vid || die
+
+ docinto chips
+ dodoc doc/chips/* || die
+
+ docinto developers
+ dodoc doc/developers/applications || die
+}
+
+pkg_postinst() {
+ elog
+ elog "Please run \`/usr/sbin/sensors-detect' in order to setup"
+ elog "/etc/conf.d/lm_sensors."
+ elog
+ elog "/etc/conf.d/lm_sensors is vital to the init-script."
+ elog "Please make sure you also add lm_sensors to the desired"
+ elog "runlevel. Otherwise your I2C modules won't get loaded"
+ elog "on the next startup."
+ elog
+ elog "You will also need to run the above command if you're upgrading from"
+ elog "<=${PN}-2, as the needed entries in /etc/conf.d/lm_sensors has"
+ elog "changed."
+ elog
+ elog "Be warned, the probing of hardware in your system performed by"
+ elog "sensors-detect could freeze your system. Also make sure you read"
+ elog "the documentation before running lm_sensors on IBM ThinkPads."
+ elog
+ elog "Please refer to the lm_sensors documentation for more information."
+ elog "(http://www.lm-sensors.org/wiki/Documentation)"
+ elog
+}