summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-06-12 08:52:16 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-06-12 08:52:16 +0000
commit7a4acf5af441b98c3549bf98c4333a47827f17d2 (patch)
tree61a24a8fe1034d353b6429d0c6883f58f225e1ed /sys-apps/lm_sensors
parentstable x86, bug 181398 (diff)
downloadgentoo-2-7a4acf5af441b98c3549bf98c4333a47827f17d2.tar.gz
gentoo-2-7a4acf5af441b98c3549bf98c4333a47827f17d2.tar.bz2
gentoo-2-7a4acf5af441b98c3549bf98c4333a47827f17d2.zip
Last piece in init-script busybox/dash compatibility, replacing &> redirections.
(Portage version: 2.1.2.9)
Diffstat (limited to 'sys-apps/lm_sensors')
-rw-r--r--sys-apps/lm_sensors/ChangeLog7
-rw-r--r--sys-apps/lm_sensors/files/lm_sensors-init.d16
2 files changed, 14 insertions, 9 deletions
diff --git a/sys-apps/lm_sensors/ChangeLog b/sys-apps/lm_sensors/ChangeLog
index 6b9e386e386b..ec2826236352 100644
--- a/sys-apps/lm_sensors/ChangeLog
+++ b/sys-apps/lm_sensors/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/lm_sensors
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/ChangeLog,v 1.72 2007/06/05 18:43:08 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/ChangeLog,v 1.73 2007/06/12 08:52:16 zzam Exp $
+
+ 12 Jun 2007; Matthias Schwarzott <zzam@gentoo.org>
+ files/lm_sensors-init.d:
+ Last piece in init-script busybox/dash compatibility, replacing &>
+ redirections.
05 Jun 2007; Marien Zwart <marienz@gentoo.org> lm_sensors-2.10.1.ebuild,
lm_sensors-2.10.2.ebuild, lm_sensors-2.10.3.ebuild:
diff --git a/sys-apps/lm_sensors/files/lm_sensors-init.d b/sys-apps/lm_sensors/files/lm_sensors-init.d
index 5c08441c7467..c80ed31eb6a5 100644
--- a/sys-apps/lm_sensors/files/lm_sensors-init.d
+++ b/sys-apps/lm_sensors/files/lm_sensors-init.d
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/files/lm_sensors-init.d,v 1.2 2007/05/18 07:39:12 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/files/lm_sensors-init.d,v 1.3 2007/06/12 08:52:16 zzam Exp $
checkconfig() {
if [ ! -f /etc/conf.d/lm_sensors ]; then
@@ -23,11 +23,11 @@ start() {
if [ "${LOADMODULES}" = "yes" -a -f /proc/modules ]; then
einfo "Loading lm_sensors modules..."
- mount | grep sysfs &> /dev/null
+ mount | grep sysfs >/dev/null 2>&1
if [ ${?} = 0 ]; then
if ! ( [ -e /sys/i2c ] || [ -e /sys/bus/i2c ] ); then
ebegin " Loading i2c-core"
- modprobe i2c-core &> /dev/null
+ modprobe i2c-core >/dev/null 2>&1
if [ ${?} != 0 ]; then
eerror " Could not load i2c-core!"
eend 1
@@ -37,7 +37,7 @@ start() {
fi
elif ! [ -e /proc/sys/dev/sensors ]; then
ebegin " Loading i2c-proc"
- modprobe i2c-proc &> /dev/null
+ modprobe i2c-proc >/dev/null 2>&1
if [ ${?} != 0 ]; then
eerror " Could not load i2c-proc!"
eend 1
@@ -54,7 +54,7 @@ start() {
break
fi
ebegin " Loading ${module}"
- modprobe ${module} ${module_args} &> /dev/null
+ modprobe ${module} ${module_args} >/dev/null 2>&1
eend $?
i=$(($i+1))
done
@@ -67,7 +67,7 @@ start() {
fi
ebegin "Initializing sensors"
- /usr/bin/sensors -s &> /dev/null
+ /usr/bin/sensors -s >/dev/null 2>&1
eend ${?}
fi
}
@@ -92,13 +92,13 @@ stop() {
i=$(($i-1))
module=`eval echo '$'MODULE_${i}`
ebegin " Unloading ${module}"
- rmmod ${module} &> /dev/null
+ rmmod ${module} >/dev/null 2>&1
eend $?
done
if [ -e /proc/sys/dev/sensors ] ; then
ebegin " Unloading i2c-proc"
- rmmod i2c-proc &> /dev/null
+ rmmod i2c-proc >/dev/null 2>&1
eend $?
fi
fi