summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-28 04:32:39 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-28 04:32:39 +0000
commitbe121b0a7f6640d87e9b2fccb0d0f18e91f0507e (patch)
treeac54499967f9225570dd28424bcf9279d742bbca /sys-apps/logwatch
parentsneak into ppc64 for logwatch like a fine-ass ninja sneaking into your house ... (diff)
downloadgentoo-2-be121b0a7f6640d87e9b2fccb0d0f18e91f0507e.tar.gz
gentoo-2-be121b0a7f6640d87e9b2fccb0d0f18e91f0507e.tar.bz2
gentoo-2-be121b0a7f6640d87e9b2fccb0d0f18e91f0507e.zip
add Date::Calc and Tie::IxHash #74551
(Portage version: 2.0.51.20-r4)
Diffstat (limited to 'sys-apps/logwatch')
-rw-r--r--sys-apps/logwatch/logwatch-5.2.2.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/sys-apps/logwatch/logwatch-5.2.2.ebuild b/sys-apps/logwatch/logwatch-5.2.2.ebuild
index 729de3c12841..b953a8c26e43 100644
--- a/sys-apps/logwatch/logwatch-5.2.2.ebuild
+++ b/sys-apps/logwatch/logwatch-5.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/logwatch/logwatch-5.2.2.ebuild,v 1.8 2005/04/07 01:45:31 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/logwatch/logwatch-5.2.2.ebuild,v 1.9 2005/04/28 04:32:39 vapier Exp $
DESCRIPTION="Analyzes and Reports on system logs"
HOMEPAGE="http://www.logwatch.org/"
@@ -8,13 +8,14 @@ SRC_URI="ftp://ftp.kaybee.org/pub/linux/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~x86 ppc ~amd64 ppc64 sparc"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
IUSE=""
-RDEPEND="virtual/libc
- virtual/cron
+RDEPEND="virtual/cron
virtual/mta
dev-lang/perl
+ dev-perl/Tie-IxHash
+ dev-perl/Date-Calc
virtual/mailx"
DEPEND=""
@@ -28,10 +29,8 @@ src_install() {
newsbin scripts/logwatch.pl logwatch.pl
for i in scripts/logfiles/* ; do
- if [ $(ls $i | wc -l) -ne 0 ] ; then
- exeinto /etc/log.d/$i
- doexe $i/*
- fi
+ exeinto /etc/log.d/$i
+ doexe $i/* || die "doexe $i failed"
done
exeinto /etc/log.d/lib
@@ -57,8 +56,6 @@ src_install() {
}
pkg_postinst() {
- einfo
- einfo "you have to manually add ${PN} to cron..."
+ einfo "you have to manually add ${PN} to cron ..."
einfo "0 0 * * * /usr/sbin/logwatch.pl 2>&1 > /dev/null"
- einfo
}