summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-10-26 23:07:19 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-10-26 23:07:19 +0000
commit73e696cb93d89f965a0b856763cf63c02db03318 (patch)
tree1110ca15cffd373916a9dba9359916841656bf62 /sys-apps/lsof
parentVersion bump (diff)
downloadgentoo-2-73e696cb93d89f965a0b856763cf63c02db03318.tar.gz
gentoo-2-73e696cb93d89f965a0b856763cf63c02db03318.tar.bz2
gentoo-2-73e696cb93d89f965a0b856763cf63c02db03318.zip
Version bump
Diffstat (limited to 'sys-apps/lsof')
-rw-r--r--sys-apps/lsof/ChangeLog7
-rw-r--r--sys-apps/lsof/Manifest4
-rw-r--r--sys-apps/lsof/files/digest-lsof-4.691
-rw-r--r--sys-apps/lsof/lsof-4.69.ebuild68
4 files changed, 77 insertions, 3 deletions
diff --git a/sys-apps/lsof/ChangeLog b/sys-apps/lsof/ChangeLog
index 884b496dc7cb..f4dec16a490e 100644
--- a/sys-apps/lsof/ChangeLog
+++ b/sys-apps/lsof/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/lsof
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lsof/ChangeLog,v 1.18 2003/09/21 17:41:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lsof/ChangeLog,v 1.19 2003/10/26 23:02:22 aliz Exp $
+
+*lsof-4.69 (26 Oct 2003)
+
+ 26 Oct 2003; Daniel Ahlberg <aliz@gentoo.org lsof-4.69.ebuild:
+ Version bump
*lsof-4.68 (30 Jun 2003)
diff --git a/sys-apps/lsof/Manifest b/sys-apps/lsof/Manifest
index 957d021d6593..f6bf3779a896 100644
--- a/sys-apps/lsof/Manifest
+++ b/sys-apps/lsof/Manifest
@@ -1,8 +1,8 @@
-MD5 cacd71b7742daef95d96ea32515fc189 ChangeLog 2444
+MD5 df8183c3d7c2af91c553739f089c7c13 ChangeLog 2549
MD5 3fffec62a3278a98c22bc6c92314d2d0 lsof-4.64.ebuild 1543
MD5 eb72c8f3844ef2a0ee82bd9477493624 lsof-4.67.ebuild 1552
MD5 a26d97b42561006dab31a4d74604f006 lsof-4.68.ebuild 1810
-MD5 a26d97b42561006dab31a4d74604f006 lsof-4.69.ebuild 1810
+MD5 b5482f6d8003237a957f0dd353709820 lsof-4.69.ebuild 1817
MD5 8d9d90e05e24a5ffaf927bb83670715a files/digest-lsof-4.64 61
MD5 4da5c4c30e43d53ea46517baa6125d1a files/digest-lsof-4.67 61
MD5 ce8b6000c8273dd5481bc4f4fcdd9ec2 files/digest-lsof-4.68 61
diff --git a/sys-apps/lsof/files/digest-lsof-4.69 b/sys-apps/lsof/files/digest-lsof-4.69
new file mode 100644
index 000000000000..b92ea65649c8
--- /dev/null
+++ b/sys-apps/lsof/files/digest-lsof-4.69
@@ -0,0 +1 @@
+MD5 d13e98fc85806424e371efde71f1e186 lsof_4.69.tar.gz 969757
diff --git a/sys-apps/lsof/lsof-4.69.ebuild b/sys-apps/lsof/lsof-4.69.ebuild
new file mode 100644
index 000000000000..8b8e3efce1ba
--- /dev/null
+++ b/sys-apps/lsof/lsof-4.69.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lsof/lsof-4.69.ebuild,v 1.1 2003/10/26 23:02:22 aliz Exp $
+
+inherit flag-o-matic
+
+MY_P=${P/-/_}
+S=${WORKDIR}/${MY_P}/${MY_P}_src
+DESCRIPTION="Lists open files for running Unix processes"
+HOMEPAGE="ftp://vic.cc.purdue.edu/pub/tools/unix/lsof/README"
+SRC_URI="ftp://vic.cc.purdue.edu/pub/tools/unix/lsof/${MY_P}.tar.gz
+ ftp://ftp.cerias.purdue.edu/pub/tools/unix/sysutils/lsof/${MY_P}.tar.gz"
+
+DEPEND="virtual/glibc"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~hppa ~arm ~mips ~ia64"
+IUSE="static"
+
+#This pkg appears to be highly kernel-dependent.
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}/${MY_P}
+ tar xf ${MY_P}_src.tar || die
+}
+
+src_compile() {
+
+ # #26576 lsof 4.68 compile with -fstack-protector fails on Alpha
+ # -taviso (15 Aug 03)
+ use alpha && filter-flags -fstack-protector
+
+ use static && LDFLAGS="${LDFLAGS} -static"
+
+ #interactive script: Enable HASSECURITY, WARNINGSTATE, and HASKERNIDCK
+ #is there a way to avoid the "echo to a file + file read"?
+ #Just piping in the results didn't seem to work.
+ echo -e "y\ny\ny\nn\ny\ny\n" > ${T}/junk
+ ./Configure linux < ${T}/junk
+
+ #simple Makefile hack to insert CFLAGS
+ cp Makefile Makefile.orig
+ sed \
+ -e "s/-DLINUXV/${CFLAGS} -DLINUXV/" \
+ -e "/^CFGL=/ s/\$/ ${LDFLAGS}/" \
+ Makefile.orig > Makefile
+
+ make all || die
+}
+
+src_install() {
+ #/usr/sbin is a good location -- drobbins
+ dosbin lsof
+ # .a libs not needed during boot so they go in /usr/lib -- drobbins
+ dolib lib/liblsof.a
+ insinto /usr/share/lsof/scripts
+ doins scripts/*
+ doman lsof.8
+ local x
+ for x in 00*
+ do
+ newdoc ${x} ${x/00/}
+ done
+ cd ${D}/usr/share/doc/${PF}
+ mv .README.FIRST.gz README.FIRST.gz
+}