summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-06-29 05:46:23 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-06-29 05:46:23 +0000
commit77d3760cc923fa94e8e622917c25976befe5f22c (patch)
treeedcdd5b3ada39d1d9e590b5f22bb40f92db8c674 /sys-apps/lsof
parent*** empty log message *** (diff)
downloadgentoo-2-77d3760cc923fa94e8e622917c25976befe5f22c.tar.gz
gentoo-2-77d3760cc923fa94e8e622917c25976befe5f22c.tar.bz2
gentoo-2-77d3760cc923fa94e8e622917c25976befe5f22c.zip
This is a majorly overhauled version of g2boojum's original.
Diffstat (limited to 'sys-apps/lsof')
-rw-r--r--sys-apps/lsof/lsof-4.56.ebuild36
1 files changed, 20 insertions, 16 deletions
diff --git a/sys-apps/lsof/lsof-4.56.ebuild b/sys-apps/lsof/lsof-4.56.ebuild
index 0e2a905f3906..1c1485330f30 100644
--- a/sys-apps/lsof/lsof-4.56.ebuild
+++ b/sys-apps/lsof/lsof-4.56.ebuild
@@ -1,43 +1,47 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Grant Goodyear <g2boojum@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lsof/lsof-4.56.ebuild,v 1.1 2001/06/29 01:10:51 g2boojum Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lsof/lsof-4.56.ebuild,v 1.2 2001/06/29 05:46:23 drobbins Exp $
-P=lsof_4.56
-A=${P}_W.tar.gz
+#Not a good idea to override ${P}; changed to ${P2}
+P0=lsof_4.56
+#${A} autogenerated from SRC_URI, no need to define here
S0=${WORKDIR}
-S=${WORKDIR}/${P}
+S=${WORKDIR}/${P0}
DESCRIPTION="Lists open files for running Unix processes"
-SRC_URI="ftp://vic.cc.purdue.edu/pub/tools/unix/lsof/${A}"
+SRC_URI="ftp://vic.cc.purdue.edu/pub/tools/unix/lsof/lsof_4.56_W.tar.gz ftp://ftp.cerias.purdue.edu/pub/tools/unix/sysutils/lsof/lsof_4.56_W.tar.gz"
HOMEPAGE="http://"
-DEPEND=""
+DEPEND="virtual/glibc virtual/kernel"
+
+#This pkg appears to be highly kernel-dependent.
src_unpack() {
unpack ${A}
cd ${S0}
- try tar xvf ${P}.tar
+ try tar xvf ${P0}.tar
}
src_compile() {
-
#interactive script: Enable HASSECURITY, WARNINGSTATE, and HASKERNIDCK
#is there a way to avoid the "echo to a file + file read"?
#Just piping in the results didn't seem to work.
echo -e "y\ny\ny\nn\ny\ny\n" > junk
- ./Configure linux < junk
- try make all
-
+ #${T} is for temporary stuff. Don't create stray files just anywhere
+ ./Configure linux < junk
+ #simple Makefile hack to insert CFLAGS
+ cp Makefile Makefile.orig
+ sed -e "s/-DLINUXV/${CFLAGS} -DLINUXV/" Makefile.orig > Makefile
+ try make all
}
src_install () {
-
doman lsof.8
- exeinto /bin/
- doexe lsof
- into /lib
+ #/usr/sbin is a good location -- drobbins
+ dosbin lsof
+ # .a libs not needed during boot so they go in /usr/lib -- drobbins
dolib lib/liblsof.a
- dodoc 00*
+ dodoc
insinto /usr/share/lsof/scripts
doins scripts/*
}