summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-03-07 05:01:43 +0000
committerMike Frysinger <vapier@gentoo.org>2010-03-07 05:01:43 +0000
commit162ba4c3b3fbab42d1598f2fe018c90d46bc318a (patch)
tree7997005373b91791cd93388962e6509eecacfb38 /sys-apps/man-db
parentold (diff)
downloadgentoo-2-162ba4c3b3fbab42d1598f2fe018c90d46bc318a.tar.gz
gentoo-2-162ba4c3b3fbab42d1598f2fe018c90d46bc318a.tar.bz2
gentoo-2-162ba4c3b3fbab42d1598f2fe018c90d46bc318a.zip
Version bump #307991 by C W Rose.
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/man-db')
-rw-r--r--sys-apps/man-db/ChangeLog9
-rw-r--r--sys-apps/man-db/man-db-2.5.7.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/sys-apps/man-db/ChangeLog b/sys-apps/man-db/ChangeLog
index d1a1fc59cc0b..6cde51a01bdc 100644
--- a/sys-apps/man-db/ChangeLog
+++ b/sys-apps/man-db/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/man-db
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.10 2009/10/02 22:13:26 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.11 2010/03/07 05:01:43 vapier Exp $
+
+*man-db-2.5.7 (07 Mar 2010)
+
+ 07 Mar 2010; Mike Frysinger <vapier@gentoo.org> +man-db-2.5.7.ebuild:
+ Version bump #307991 by C W Rose.
02 Oct 2009; Diego E. Pettenò <flameeyes@gentoo.org> man-db-2.5.6.ebuild:
Fix doc installation.
diff --git a/sys-apps/man-db/man-db-2.5.7.ebuild b/sys-apps/man-db/man-db-2.5.7.ebuild
new file mode 100644
index 000000000000..f493aadff147
--- /dev/null
+++ b/sys-apps/man-db/man-db-2.5.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/man-db-2.5.7.ebuild,v 1.1 2010/03/07 05:01:43 vapier Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="a man replacement that utilizes berkdb instead of flat files"
+HOMEPAGE="http://www.nongnu.org/man-db/"
+SRC_URI="http://download.savannah.nongnu.org/releases/man-db/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="berkdb +gdbm nls"
+
+RDEPEND="berkdb? ( sys-libs/db )
+ gdbm? ( sys-libs/gdbm )
+ !berkdb? ( !gdbm? ( sys-libs/gdbm ) )
+ || ( sys-apps/groff >=app-doc/heirloom-doctools-080407-r2 )
+ !sys-apps/man"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+PROVIDE="virtual/man"
+
+pkg_setup() {
+ enewgroup man 15
+ enewuser man 13 -1 /usr/share/man man
+}
+
+src_configure() {
+ local db="gdbm"
+ use berkdb && ! use gdbm && db="db"
+ econf \
+ --with-sections="1 1p 8 2 3 3p 4 5 6 7 9 0p tcl n l p o 1x 2x 3x 4x 5x 6x 7x 8x" \
+ $(use_enable nls) \
+ --with-db=${db} \
+ || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc README ChangeLog NEWS docs/{HACKING,TODO}
+}