summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-06-15 03:51:02 +0000
committerJeroen Roovers <jer@gentoo.org>2011-06-15 03:51:02 +0000
commitb9ad881a200654270d3e0b13ab1e6e31de6ad508 (patch)
treea2a00dadf04ce2a6936036c2d0f8530304c60044 /sys-apps/man-db
parentVersion bump. Fix missing include. (diff)
downloadgentoo-2-b9ad881a200654270d3e0b13ab1e6e31de6ad508.tar.gz
gentoo-2-b9ad881a200654270d3e0b13ab1e6e31de6ad508.tar.bz2
gentoo-2-b9ad881a200654270d3e0b13ab1e6e31de6ad508.zip
Version bump. Introduce USE=static-libs.
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/man-db')
-rw-r--r--sys-apps/man-db/ChangeLog9
-rw-r--r--sys-apps/man-db/files/man-db-2.5.7-non-gnu-nroff.patch97
-rw-r--r--sys-apps/man-db/files/man-db-2.5.7-uncompressed-non-en.patch120
-rw-r--r--sys-apps/man-db/man-db-2.6.0.2.ebuild (renamed from sys-apps/man-db/man-db-2.5.7-r1.ebuild)31
4 files changed, 24 insertions, 233 deletions
diff --git a/sys-apps/man-db/ChangeLog b/sys-apps/man-db/ChangeLog
index f3a03894737f..f4c02b94b3bd 100644
--- a/sys-apps/man-db/ChangeLog
+++ b/sys-apps/man-db/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/man-db
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.15 2011/04/13 15:05:52 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.16 2011/06/15 03:51:02 jer Exp $
+
+*man-db-2.6.0.2 (15 Jun 2011)
+
+ 15 Jun 2011; Jeroen Roovers <jer@gentoo.org> -man-db-2.5.7-r1.ebuild,
+ -files/man-db-2.5.7-non-gnu-nroff.patch,
+ -files/man-db-2.5.7-uncompressed-non-en.patch, +man-db-2.6.0.2.ebuild:
+ Version bump. Introduce USE=static-libs.
13 Apr 2011; Ulrich Mueller <ulm@gentoo.org> man-db-2.5.7-r1.ebuild,
man-db-2.5.9.ebuild:
diff --git a/sys-apps/man-db/files/man-db-2.5.7-non-gnu-nroff.patch b/sys-apps/man-db/files/man-db-2.5.7-non-gnu-nroff.patch
deleted file mode 100644
index 4e93c44363f4..000000000000
--- a/sys-apps/man-db/files/man-db-2.5.7-non-gnu-nroff.patch
+++ /dev/null
@@ -1,97 +0,0 @@
-fix from upstream for building w/out GNU nroff
-
-http://bugs.gentoo.org/309635
-
-Wed Mar 24 11:04:46 GMT 2010 Colin Watson <cjwatson@debian.org>
-
- Fix build regression when GNU_NROFF is undefined (Savannah bug
- #29318).
-
- * src/man.c (add_col): New function, split out from
- make_display_command.
- (make_roff_command): Reinstate tbl/col logic here, as by the time
- we get to make_display_command we've forgotten whether tbl was
- used.
- (make_display_command): Remove tbl/col logic, useless here. Use
- add_col.
-
-=== modified file 'src/man.c'
---- src/man.c 2010-03-21 22:05:16 +0000
-+++ src/man.c 2010-03-24 11:07:23 +0000
-@@ -43,6 +43,7 @@
- #include <string.h>
- #include <stdlib.h>
- #include <stdio.h>
-+#include <stdarg.h>
- #include <assert.h>
- #include <errno.h>
- #include <termios.h>
-@@ -1406,6 +1407,26 @@
- return get_locale_charset ();
- }
-
-+static void add_col (pipeline *p, const char *locale_charset, ...)
-+{
-+ command *cmd;
-+ va_list argv;
-+ char *col_locale;
-+
-+ cmd = command_new (COL);
-+ va_start (argv, locale_charset);
-+ command_argv (cmd, argv);
-+ va_end (argv);
-+
-+ col_locale = find_charset_locale (locale_charset);
-+ if (col_locale) {
-+ command_setenv (cmd, "LC_CTYPE", col_locale);
-+ free (col_locale);
-+ }
-+
-+ pipeline_command (p, cmd);
-+}
-+
- /* Return pipeline to format file to stdout. */
- static pipeline *make_roff_command (const char *dir, const char *file,
- pipeline *decomp, const char *dbfilters,
-@@ -1699,6 +1720,11 @@
- !isatty (STDOUT_FILENO))
- /* we'll run col later, but prepare for it */
- setenv ("GROFF_NO_SGR", "1", 1);
-+#ifndef GNU_NROFF
-+ /* tbl needs col */
-+ else if (using_tbl && !troff && *COL)
-+ add_col (p, locale_charset, NULL);
-+#endif /* GNU_NROFF */
- }
- } else {
- /* use external formatter script, it takes arguments
-@@ -1851,27 +1877,9 @@
- */
- const char *man_keep_formatting =
- getenv ("MAN_KEEP_FORMATTING");
-- command *colcmd = NULL;
- if ((!man_keep_formatting || !*man_keep_formatting) &&
- !isatty (STDOUT_FILENO))
-- colcmd = command_new_args (
-- COL, "-b", "-p", "-x", NULL);
--#ifndef GNU_NROFF
-- /* tbl needs col */
-- else if (using_tbl && !troff && *COL)
-- colcmd = command_new (COL);
--#endif /* GNU_NROFF */
--
-- if (colcmd) {
-- char *col_locale =
-- find_charset_locale (locale_charset);
-- if (col_locale) {
-- command_setenv (colcmd, "LC_CTYPE",
-- col_locale);
-- free (col_locale);
-- }
-- pipeline_command (p, colcmd);
-- }
-+ add_col (p, locale_charset, "-b", "-p", "-x", NULL);
- }
-
- if (ascii) {
-
diff --git a/sys-apps/man-db/files/man-db-2.5.7-uncompressed-non-en.patch b/sys-apps/man-db/files/man-db-2.5.7-uncompressed-non-en.patch
deleted file mode 100644
index b781dbc038e1..000000000000
--- a/sys-apps/man-db/files/man-db-2.5.7-uncompressed-non-en.patch
+++ /dev/null
@@ -1,120 +0,0 @@
-https://bugs.gentoo.org/327347
-
-fix from upstream for display of uncompressed non-English manpages
-
---- man-db-2.5.7/lib/pipeline.c
-+++ man-db-2.5.7/lib/pipeline.c
-@@ -329,6 +329,25 @@
- return cmd;
- }
-
-+static void passthrough (void *data ATTRIBUTE_UNUSED)
-+{
-+ for (;;) {
-+ char buffer[4096];
-+ int r = read (STDIN_FILENO, buffer, 4096);
-+ if (r <= 0)
-+ break;
-+ if (fwrite (buffer, 1, (size_t) r, stdout) < (size_t) r)
-+ break;
-+ }
-+
-+ return;
-+}
-+
-+command *command_new_passthrough (void)
-+{
-+ return command_new_function ("cat", &passthrough, NULL, NULL);
-+}
-+
- command *command_dup (command *cmd)
- {
- command *newcmd = XMALLOC (command);
-@@ -831,20 +850,6 @@
- return p;
- }
-
--static void passthrough (void *data ATTRIBUTE_UNUSED)
--{
-- for (;;) {
-- char buffer[4096];
-- int r = read (STDIN_FILENO, buffer, 4096);
-- if (r <= 0)
-- break;
-- if (fwrite (buffer, 1, (size_t) r, stdout) < (size_t) r)
-- break;
-- }
--
-- return;
--}
--
- void pipeline_connect (pipeline *source, pipeline *sink, ...)
- {
- va_list argv;
-@@ -876,11 +881,8 @@
- * because it has nowhere to send output. Until this is
- * fixed, this kludge is necessary.
- */
-- if (arg->ncommands == 0) {
-- command *cmd = command_new_function
-- ("cat", &passthrough, NULL, NULL);
-- pipeline_command (arg, cmd);
-- }
-+ if (arg->ncommands == 0)
-+ pipeline_command (arg, command_new_passthrough ());
- }
- va_end (argv);
- }
---- man-db-2.5.7/lib/pipeline.h
-+++ man-db-2.5.7/lib/pipeline.h
-@@ -172,6 +172,9 @@
- */
- command *command_new_sequence (const char *name, ...) ATTRIBUTE_SENTINEL;
-
-+/* Return a new command that just passes data from its input to its output. */
-+command *command_new_passthrough (void);
-+
- /* Return a duplicate of a command. */
- command *command_dup (command *cmd);
-
---- man-db-2.5.7/NEWS
-+++ man-db-2.5.7/NEWS
-@@ -1,3 +1,15 @@
-+man-db 2.5.8
-+============
-+
-+Major changes since man-db 2.5.7:
-+
-+ Fixes:
-+ ------
-+
-+ o Fix assertion failure on 'man -l' with an uncompressed page and
-+ any of --no-hyphenation, --no-justification, or a non-English
-+ page.
-+
- man-db 2.5.7 (16 February 2010)
- ===============================
-
---- man-db-2.5.7/src/man.c
-+++ man-db-2.5.7/src/man.c
-@@ -2390,9 +2390,16 @@
- #endif /* TROFF_IS_GROFF */
-
- if (seq->u.sequence.ncommands) {
-- assert (decomp->ncommands == 1);
-- command_sequence_command (seq, decomp->commands[0]);
-- decomp->commands[0] = seq;
-+ assert (decomp->ncommands <= 1);
-+ if (decomp->ncommands) {
-+ command_sequence_command
-+ (seq, decomp->commands[0]);
-+ decomp->commands[0] = seq;
-+ } else {
-+ command_sequence_command
-+ (seq, command_new_passthrough ());
-+ pipeline_command (decomp, seq);
-+ }
- } else
- command_free (seq);
- }
-
diff --git a/sys-apps/man-db/man-db-2.5.7-r1.ebuild b/sys-apps/man-db/man-db-2.6.0.2.ebuild
index 37fb24e58d3d..4a6191e229d6 100644
--- a/sys-apps/man-db/man-db-2.5.7-r1.ebuild
+++ b/sys-apps/man-db/man-db-2.6.0.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/man-db-2.5.7-r1.ebuild,v 1.2 2011/04/13 15:05:53 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/man-db-2.6.0.2.ebuild,v 1.1 2011/06/15 03:51:02 jer Exp $
EAPI="2"
-inherit eutils
+inherit autotools-utils eutils
DESCRIPTION="a man replacement that utilizes berkdb instead of flat files"
HOMEPAGE="http://www.nongnu.org/man-db/"
@@ -12,38 +12,39 @@ SRC_URI="http://download.savannah.nongnu.org/releases/man-db/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="berkdb +gdbm nls"
+KEYWORDS="~amd64 ~x86"
+IUSE="berkdb +gdbm nls static-libs"
-RDEPEND="berkdb? ( sys-libs/db )
+RDEPEND="
+ dev-libs/libpipeline
+ berkdb? ( sys-libs/db )
gdbm? ( sys-libs/gdbm )
!berkdb? ( !gdbm? ( sys-libs/gdbm ) )
|| ( sys-apps/groff >=app-doc/heirloom-doctools-080407-r2 )
- !sys-apps/man"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
+ !sys-apps/man
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
pkg_setup() {
enewgroup man 15
enewuser man 13 -1 /usr/share/man man
}
-src_prepare() {
- epatch "${FILESDIR}"/${P}-non-gnu-nroff.patch #309635
- epatch "${FILESDIR}"/${P}-uncompressed-non-en.patch #327347
-}
-
src_configure() {
local db="gdbm"
use berkdb && ! use gdbm && db="db"
econf \
--with-sections="1 1p 8 2 3 3p 4 5 6 7 9 0p tcl n l p o 1x 2x 3x 4x 5x 6x 7x 8x" \
$(use_enable nls) \
- --with-db=${db} \
- || die
+ $(use_enable static-libs static) \
+ --with-db=${db}
}
src_install() {
emake install DESTDIR="${D}" || die
dodoc README ChangeLog NEWS docs/{HACKING,TODO}
+ use static-libs || remove_libtool_files
}