summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-11-27 13:04:04 +0000
committerMichael Januszewski <spock@gentoo.org>2008-11-27 13:04:04 +0000
commit4368af9367debb886e19d488dc0f375aed4bd8b3 (patch)
treee10e18174f991c6d944c51a6f33ab3075d9c95c0 /sys-apps/memtest86+
parentAdded qt-assistant dependency, closing bug #248659 (diff)
downloadgentoo-2-4368af9367debb886e19d488dc0f375aed4bd8b3.tar.gz
gentoo-2-4368af9367debb886e19d488dc0f375aed4bd8b3.tar.bz2
gentoo-2-4368af9367debb886e19d488dc0f375aed4bd8b3.zip
Version bump.
(Portage version: 2.1.6_rc2/cvs/Linux 2.6.27 x86_64)
Diffstat (limited to 'sys-apps/memtest86+')
-rw-r--r--sys-apps/memtest86+/ChangeLog8
-rw-r--r--sys-apps/memtest86+/files/memtest86+-2.10-hardcoded_cc.patch30
-rw-r--r--sys-apps/memtest86+/memtest86+-2.10.ebuild69
3 files changed, 106 insertions, 1 deletions
diff --git a/sys-apps/memtest86+/ChangeLog b/sys-apps/memtest86+/ChangeLog
index 3a688c786264..2a63290c6c55 100644
--- a/sys-apps/memtest86+/ChangeLog
+++ b/sys-apps/memtest86+/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/memtest86+
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86+/ChangeLog,v 1.44 2008/10/18 17:25:16 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86+/ChangeLog,v 1.45 2008/11/27 13:04:04 spock Exp $
+
+*memtest86+-2.10 (27 Nov 2008)
+
+ 27 Nov 2008; Michał Januszewski <spock@gentoo.org>
+ +files/memtest86+-2.10-hardcoded_cc.patch, +memtest86+-2.10.ebuild:
+ Version bump.
18 Oct 2008; Michał Januszewski <spock@gentoo.org>
-files/memtest86+-1.50-hardened.patch,
diff --git a/sys-apps/memtest86+/files/memtest86+-2.10-hardcoded_cc.patch b/sys-apps/memtest86+/files/memtest86+-2.10-hardcoded_cc.patch
new file mode 100644
index 000000000000..43e3fbb3fcc5
--- /dev/null
+++ b/sys-apps/memtest86+/files/memtest86+-2.10-hardcoded_cc.patch
@@ -0,0 +1,30 @@
+diff -Naurp memtest86+-2.10-orig/Makefile memtest86+-2.10/Makefile
+--- memtest86+-2.10-orig/Makefile 2008-11-27 13:54:49.000000000 +0100
++++ memtest86+-2.10/Makefile 2008-11-27 13:56:32.000000000 +0100
+@@ -8,10 +8,9 @@
+ #
+ FDISK=/dev/fd0
+
+-AS=as -32
+-CC=gcc
+-
+-CFLAGS= -fno-stack-protector -Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC
++CPPFLAGS=-m32
++CFLAGS=-Wall -m32 -march=i486 -O1 -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC -fno-stack-protector
++ASFLAGS=-32
+
+ OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
+ config.o linuxbios.o memsize.o pci.o controller.o random.o extra.o \
+@@ -47,10 +46,10 @@ memtest.bin: memtest_shared.bin bootsect
+ memtest_shared.bin -o memtest.bin
+
+ reloc.o: reloc.c
+- $(CC) -c $(CFLAGS) -fno-strict-aliasing reloc.c
++ $(CC) -c $(CFLAGS) -fno-strict-aliasing -fno-stack-protector reloc.c
+
+ test.o: test.c
+- $(CC) -c -Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding test.c
++ $(CC) -c -Wall -march=i486 -m32 -O1 -fomit-frame-pointer -fno-builtin -ffreestanding -fno-stack-protector -fno-pie -nopie test.c
+
+ clean:
+ rm -f *.o *.s *.iso memtest.bin memtest memtest_shared memtest_shared.bin
diff --git a/sys-apps/memtest86+/memtest86+-2.10.ebuild b/sys-apps/memtest86+/memtest86+-2.10.ebuild
new file mode 100644
index 000000000000..17548f8540ca
--- /dev/null
+++ b/sys-apps/memtest86+/memtest86+-2.10.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86+/memtest86+-2.10.ebuild,v 1.1 2008/11/27 13:04:04 spock Exp $
+
+inherit mount-boot eutils
+
+DESCRIPTION="Memory tester based on memtest86"
+HOMEPAGE="http://www.memtest.org/"
+SRC_URI="http://www.memtest.org/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="serial"
+RESTRICT="test"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-2.10-hardcoded_cc.patch
+ epatch "${FILESDIR}"/${PN}-1.70-gnu_hash.patch
+
+ if use serial ; then
+ sed -e 's/#define SERIAL_CONSOLE_DEFAULT 0/#define SERIAL_CONSOLE_DEFAULT 1/' -i config.h
+ fi
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ insinto /boot/memtest86plus
+ doins memtest.bin || die
+ dodoc README README.build-process
+}
+
+pkg_postinst() {
+ einfo
+ einfo "memtest.bin has been installed in /boot/memtest86plus/"
+ einfo "You may wish to update your bootloader configs"
+ einfo "by adding these lines:"
+
+ # a little magic to make users' life as easy as possible ;)
+ local fstab=${ROOT}/etc/fstab
+ local root="(hd0,0)"
+ local res=$(awk '$2 == "/boot" {print $1}' "${fstab}")
+ if [[ -z ${res} ]] ; then
+ res=$(awk '$2 == "/" {print $1}' "${fstab}")
+ fi
+ if [[ -n ${res} ]] ; then
+ # transform /dev/hd* magic into grub naming ...
+ # /dev/hda1 -> a1 -> 01
+ root=$(echo "${res}" | grep -o '[a-z][0-9]' | tr -t a-z 0123456789)
+ root="(hd${root:0:1},$((${root:1:1}-1)))"
+ fi
+ einfo " - For grub:"
+ einfo " > title=Memtest86Plus"
+ einfo " > root ${root}"
+ einfo " > kernel /boot/memtest86plus/memtest.bin"
+
+ einfo " - For lilo:"
+ einfo " > image = /boot/memtest86plus/memtest.bin"
+ einfo " > label = Memtest86Plus"
+ einfo
+}