summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-04-25 10:00:16 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-04-25 10:00:16 +0000
commit840a7bc8a900cc8e2826d803cf115b7aeebf8e3e (patch)
tree2a04dfac5b293370b62892eb87017d9d649ca039 /sys-apps/mlocate
parentcreate the logrotate file with the correct permissions as pointed out on bug ... (diff)
downloadgentoo-2-840a7bc8a900cc8e2826d803cf115b7aeebf8e3e.tar.gz
gentoo-2-840a7bc8a900cc8e2826d803cf115b7aeebf8e3e.tar.bz2
gentoo-2-840a7bc8a900cc8e2826d803cf115b7aeebf8e3e.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-apps/mlocate')
-rw-r--r--sys-apps/mlocate/ChangeLog7
-rw-r--r--sys-apps/mlocate/mlocate-0.20.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/sys-apps/mlocate/ChangeLog b/sys-apps/mlocate/ChangeLog
index b1f370292a2c..e05797fe4701 100644
--- a/sys-apps/mlocate/ChangeLog
+++ b/sys-apps/mlocate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/mlocate
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/mlocate/ChangeLog,v 1.13 2008/04/05 21:20:42 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mlocate/ChangeLog,v 1.14 2008/04/25 10:00:16 opfer Exp $
+
+*mlocate-0.20 (25 Apr 2008)
+
+ 25 Apr 2008; Christian Faulhammer <opfer@gentoo.org> +mlocate-0.20.ebuild:
+ version bump
05 Apr 2008; Joseph Jezak <josejx@gentoo.org> mlocate-0.19.ebuild:
Marked ppc stable for bug #215795.
diff --git a/sys-apps/mlocate/mlocate-0.20.ebuild b/sys-apps/mlocate/mlocate-0.20.ebuild
new file mode 100644
index 000000000000..9e326d1d4636
--- /dev/null
+++ b/sys-apps/mlocate/mlocate-0.20.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mlocate/mlocate-0.20.ebuild,v 1.1 2008/04/25 10:00:16 opfer Exp $
+
+inherit eutils
+
+DESCRIPTION="Merging locate is an utility to index and quickly search for files"
+HOMEPAGE="https://fedorahosted.org/mlocate/"
+SRC_URI="https://fedorahosted.org/mlocate/attachment/wiki/MlocateDownloads/${P}.tar.bz2?format=raw"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="!sys-apps/slocate
+ !sys-apps/rlocate"
+
+pkg_setup() {
+ enewgroup locate
+}
+
+src_unpack() {
+ mv "${DISTDIR}/${P}.tar.bz2?format=raw" "${DISTDIR}/${P}.tar.bz2"
+ unpack "${P}.tar.bz2"
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake groupname=locate || die "emake failed"
+}
+
+src_install() {
+ emake groupname=locate DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README NEWS
+
+ insinto /etc
+ doins "${FILESDIR}/updatedb.conf"
+ fperms 0644 /etc/updatedb.conf
+
+ insinto /etc/cron.daily
+ newins "${FILESDIR}/mlocate.cron" mlocate
+ fperms 0755 /etc/cron.daily/mlocate
+
+ fowners 0:locate /usr/bin/locate
+ fperms go-r,g+s /usr/bin/locate
+
+ chown -R 0:locate "${D}/var/lib/mlocate"
+ fperms 0750 /var/lib/mlocate
+ keepdir /var/lib/mlocate
+}
+
+src_test() {
+ if has userpriv ${FEATURES} && ! has usersandbox ${FEATURES}; then
+ make check-local || die "test suite failed"
+ else
+ ewarn "Activate FEATURES=userpriv and deactivate FEATURES=usersandbox to run testsuite."
+ fi
+}
+
+pkg_postinst() {
+ elog "Note that the /etc/updatedb.conf file is generic"
+ elog "Please customize it to your system requirements"
+}