summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-06-28 16:36:08 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-06-28 16:36:08 +0000
commitdba3650de57cb03182245c05b9dbd65e20d4c285 (patch)
tree8ca3501bd512909363b112dbe6ad50d7b505efe3 /sys-apps/most
parent. (diff)
downloadgentoo-2-dba3650de57cb03182245c05b9dbd65e20d4c285.tar.gz
gentoo-2-dba3650de57cb03182245c05b9dbd65e20d4c285.tar.bz2
gentoo-2-dba3650de57cb03182245c05b9dbd65e20d4c285.zip
Version bump.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-apps/most')
-rw-r--r--sys-apps/most/ChangeLog9
-rw-r--r--sys-apps/most/Manifest8
-rw-r--r--sys-apps/most/files/digest-most-4.10.11
-rw-r--r--sys-apps/most/most-4.10.1.ebuild59
4 files changed, 72 insertions, 5 deletions
diff --git a/sys-apps/most/ChangeLog b/sys-apps/most/ChangeLog
index 4c59bc60c391..80987498ccbf 100644
--- a/sys-apps/most/ChangeLog
+++ b/sys-apps/most/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/most
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/most/ChangeLog,v 1.14 2004/12/31 18:32:17 gongloo Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/most/ChangeLog,v 1.15 2005/06/28 16:36:08 ka0ttic Exp $
+
+*most-4.10.1 (28 Jun 2005)
+
+ 28 Jun 2005; Aaron Walker <ka0ttic@gentoo.org> +most-4.10.1.ebuild:
+ Version bump.
31 Dec 2004; <gongloo@gentoo.org> most-4.9.5.ebuild:
Added ~ppc-macos.
diff --git a/sys-apps/most/Manifest b/sys-apps/most/Manifest
index 12137a64424c..ec83fc6adcf5 100644
--- a/sys-apps/most/Manifest
+++ b/sys-apps/most/Manifest
@@ -1,8 +1,10 @@
-MD5 55ee4c4ddc78f6c4d26480cec0df23b5 ChangeLog 1975
-MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+MD5 41b8b888faa9f3b506b05ee25c8cfdb2 most-4.10.1.ebuild 1450
+MD5 3d7e9a837c0a3750ed8bde64ed288f83 most-4.9.5.ebuild 1449
MD5 9d17807077a730fc3c811e5c4e51086c most-4.9.2.ebuild 938
+MD5 5b9193d351aea72281447c6b64061fa0 ChangeLog 2090
+MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 b5f584582bee28ce05fa5aaf8d0f5d8e most-4.9.4.ebuild 939
-MD5 3d7e9a837c0a3750ed8bde64ed288f83 most-4.9.5.ebuild 1449
MD5 a23dcc37cb7e0fb3d5fde35a36d9f270 files/digest-most-4.9.2 61
MD5 fca955f15889eb7ffb4639dd1484ccfa files/digest-most-4.9.4 62
MD5 f50722839e33523b309eda86c46e465d files/digest-most-4.9.5 62
+MD5 7c547a411bfa9671282b24ee98adf0c6 files/digest-most-4.10.1 63
diff --git a/sys-apps/most/files/digest-most-4.10.1 b/sys-apps/most/files/digest-most-4.10.1
new file mode 100644
index 000000000000..64f25ac8e0ef
--- /dev/null
+++ b/sys-apps/most/files/digest-most-4.10.1
@@ -0,0 +1 @@
+MD5 3feeb1855e0e902b5a4decde68f9159e most-4.10.1.tar.gz 138230
diff --git a/sys-apps/most/most-4.10.1.ebuild b/sys-apps/most/most-4.10.1.ebuild
new file mode 100644
index 000000000000..303eb3d0aea4
--- /dev/null
+++ b/sys-apps/most/most-4.10.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/most/most-4.10.1.ebuild,v 1.1 2005/06/28 16:36:08 ka0ttic Exp $
+
+DESCRIPTION="An extremely excellent text file reader"
+HOMEPAGE="http://freshmeat.net/projects/most/"
+SLOT="0"
+LICENSE="GPL-2"
+SRC_URI="ftp://space.mit.edu/pub/davis/${PN}/${P}.tar.gz"
+IUSE=""
+
+# Note to arch maintainers: you'll need to add to src_install() for your
+# arch, since the app's Makefile does strange things with different
+# directories for each arch. -- ciaranm, 27 June 2004
+KEYWORDS="~amd64 ~mips ~ppc ~ppc-macos ~sparc ~x86"
+
+DEPEND=">=sys-libs/slang-1.4.2
+ >=sys-libs/ncurses-5.2-r2"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc || die
+
+ #*possible* (not definite) pmake problems, let's not risk it.
+ make SYS_INITFILE="/etc/most.conf" || die
+}
+
+src_install() {
+ # Changing this to use src/${ARCH}objs/most probably isn't a good
+ # idea...
+ local objsdir
+ case ${ARCH} in
+ x86)
+ objsdir=x86objs
+ ;;
+ amd64)
+ objsdir=amd64objs
+ ;;
+ sparc)
+ objsdir=sparcobjs
+ ;;
+ mips)
+ objsdir=mipsobjs
+ ;;
+ ppc)
+ # This should also be the case of ppc-macos
+ objsdir=ppcobjs
+ ;;
+ esac
+ dobin src/${objsdir:-objs}/most || die "Couldn't install binary"
+
+ doman most.1
+
+ dodoc COPYING COPYRIGHT README changes.txt
+ docinto txt
+ dodoc default.rc lesskeys.rc most-fun.txt
+}