summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-06-09 03:08:23 +0000
committerDonny Davies <woodchip@gentoo.org>2002-06-09 03:08:23 +0000
commit6557ab1cfae19df285004fb545219f5f3bfb64e3 (patch)
treed517bd820bed3e860e027c46610726d3c3a531d0 /sys-apps/parted
parentbugs #2686, #3210, #3084 (diff)
downloadgentoo-2-6557ab1cfae19df285004fb545219f5f3bfb64e3.tar.gz
gentoo-2-6557ab1cfae19df285004fb545219f5f3bfb64e3.tar.bz2
gentoo-2-6557ab1cfae19df285004fb545219f5f3bfb64e3.zip
update to 1.6.1; new reiserfs support
Diffstat (limited to 'sys-apps/parted')
-rw-r--r--sys-apps/parted/ChangeLog10
-rw-r--r--sys-apps/parted/files/digest-parted-1.6.11
-rw-r--r--sys-apps/parted/parted-1.6.1.ebuild43
3 files changed, 53 insertions, 1 deletions
diff --git a/sys-apps/parted/ChangeLog b/sys-apps/parted/ChangeLog
index 4cb2377f8772..c6f5cb783848 100644
--- a/sys-apps/parted/ChangeLog
+++ b/sys-apps/parted/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/parted
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/ChangeLog,v 1.4 2002/04/16 19:32:28 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/ChangeLog,v 1.5 2002/06/09 03:08:22 woodchip Exp $
+
+*parted-1.6.1 (8 Jun 2002)
+
+ 8 Jun 2002; Donny Davies <woodchip@gentoo.org> :
+
+ New 1.6 release + small install patch. This one can use dev-libs/progsreiserfs
+ optionally at runtime; not installed per default at the moment. Testing/feedback
+ on this welcome.
*parted-1.4.24-r3 (16 Apr 2002)
diff --git a/sys-apps/parted/files/digest-parted-1.6.1 b/sys-apps/parted/files/digest-parted-1.6.1
new file mode 100644
index 000000000000..42b141555902
--- /dev/null
+++ b/sys-apps/parted/files/digest-parted-1.6.1
@@ -0,0 +1 @@
+MD5 3f02f530605a17a23f55d10d458dd080 parted-1.6.1.tar.gz 1088871
diff --git a/sys-apps/parted/parted-1.6.1.ebuild b/sys-apps/parted/parted-1.6.1.ebuild
new file mode 100644
index 000000000000..181cfe8eb3bf
--- /dev/null
+++ b/sys-apps/parted/parted-1.6.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.6.1.ebuild,v 1.1 2002/06/09 03:08:22 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
+SRC_URI="ftp://ftp.gnu.org/gnu/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/parted"
+DEPEND="virtual/glibc
+ >=sys-apps/e2fsprogs-1.27
+ >=sys-libs/ncurses-5.2
+ readline? ( >=sys-libs/readline-4.1-r4 )
+ nls? ( sys-devel/gettext )"
+# masked out for now. any objections to enabling this per default?
+# //woodchip
+#RDEPEND="${DEPEND} =dev-libs/progsreiserfs-0.3.0*"
+LICENSE="GPL-2"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ #fix a manpage glitch
+ patch -p1 <${FILESDIR}/${PN}-1.6.0-destdir.patch || die
+}
+
+src_compile() {
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+ use readline || myconf="${myconf} --without-readline"
+ [ -z "${DEBUGBUILD}" ] && myconf="${myconf} --disable-debug"
+ use static && myconf="${myconf} --enable-all-static"
+ econf --target=${CHOST} ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog \
+ INSTALL NEWS README THANKS TODO
+ docinto doc; cd doc
+ dodoc API COPYING.DOC FAQ FAT USER USER.jp
+}