summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-14 00:30:44 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-14 00:30:44 +0000
commitffa24d32851aa70d1f288005f37a22e1a528be46 (patch)
tree6e26d0dee5f748822c09c2c768e7037ac1bee722 /sys-apps/parted
parentVersion bump 0.93.2 (#73919) and clean out. (Manifest recommit) (diff)
downloadgentoo-2-ffa24d32851aa70d1f288005f37a22e1a528be46.tar.gz
gentoo-2-ffa24d32851aa70d1f288005f37a22e1a528be46.tar.bz2
gentoo-2-ffa24d32851aa70d1f288005f37a22e1a528be46.zip
Clean up and push into stable.
Diffstat (limited to 'sys-apps/parted')
-rw-r--r--sys-apps/parted/ChangeLog5
-rw-r--r--sys-apps/parted/parted-1.6.15.ebuild37
2 files changed, 20 insertions, 22 deletions
diff --git a/sys-apps/parted/ChangeLog b/sys-apps/parted/ChangeLog
index 31faa1f37f9c..ce1dfc870838 100644
--- a/sys-apps/parted/ChangeLog
+++ b/sys-apps/parted/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/parted
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/ChangeLog,v 1.58 2004/11/30 20:56:03 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/ChangeLog,v 1.59 2004/12/14 00:30:44 vapier Exp $
+
+ 13 Dec 2004; Mike Frysinger <vapier@gentoo.org> parted-1.6.15.ebuild:
+ Clean up and push into stable.
30 Nov 2004; Luca Barbato <lu_zero@gentoo.org> parted-1.6.15.ebuild:
Fix libtool, research and fix from Joe Jezak <josejx@gentoo.org>, solves bug
diff --git a/sys-apps/parted/parted-1.6.15.ebuild b/sys-apps/parted/parted-1.6.15.ebuild
index ba5f3d120ccc..ed3287741882 100644
--- a/sys-apps/parted/parted-1.6.15.ebuild
+++ b/sys-apps/parted/parted-1.6.15.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.6.15.ebuild,v 1.4 2004/11/30 20:56:03 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.6.15.ebuild,v 1.5 2004/12/14 00:30:44 vapier Exp $
-inherit eutils gnuconfig
+inherit eutils
DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
HOMEPAGE="http://www.gnu.org/software/parted"
@@ -13,7 +13,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ppc ~alpha hppa ~amd64 ~ia64 ppc64"
+KEYWORDS="~alpha amd64 hppa ia64 ppc ppc64 x86"
IUSE="nls static readline debug"
DEPEND=">=sys-fs/e2fsprogs-1.27
@@ -21,34 +21,29 @@ DEPEND=">=sys-fs/e2fsprogs-1.27
nls? ( sys-devel/gettext )
readline? ( >=sys-libs/readline-4.1-r4 )"
-PATCHDIR=${WORKDIR}/patches
-
src_unpack() {
- local WANT_AUTOCONF=1.7
unpack ${A}
cd ${S}
- EPATCH_SUFFIX="patch" epatch ${PATCHDIR}
- gnuconfig_update
- libtoolize --force
- aclocal
- autoconf
+ EPATCH_SUFFIX="patch" epatch ${WORKDIR}/patches
+ aclocal || die "aclocal failed"
+ libtoolize --copy --force || die "libtoolize failed"
+ automake || die "automake failed"
+ autoconf || die "autoconf failed"
}
src_compile() {
econf \
- `use_with readline` \
- `use_enable nls` \
- `use_enable debug` \
- `use_enable static all-static` \
+ $(use_with readline) \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_enable static all-static) \
--disable-Werror \
- --target=${CHOST} ${myconf} || die "Configure failed"
+ ${myconf} || die "Configure failed"
emake || die "Make failed"
}
src_install() {
- einstall || die "Install failed"
- dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog \
- INSTALL NEWS README THANKS TODO
- docinto doc; cd doc
- dodoc API FAQ FAT USER.jp
+ make install DESTDIR="${D}" || die "Install failed"
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README THANKS TODO
+ dodoc doc/{API,FAQ,FAT,USER.jp}
}