summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-03-23 00:44:07 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-03-23 00:44:07 +0000
commit0eeebd217aca8c8be37865a6bb5ae05c095b77c3 (patch)
treebd0d8e5aad5a3262ba401817068e9b768b95de71 /sys-apps/paxctl
parent2.2.0_alpha94 version bump. This includes all of the fixes in (diff)
downloadgentoo-2-0eeebd217aca8c8be37865a6bb5ae05c095b77c3.tar.gz
gentoo-2-0eeebd217aca8c8be37865a6bb5ae05c095b77c3.tar.bz2
gentoo-2-0eeebd217aca8c8be37865a6bb5ae05c095b77c3.zip
Version bump fixes bug #408377
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/paxctl')
-rw-r--r--sys-apps/paxctl/ChangeLog7
-rw-r--r--sys-apps/paxctl/paxctl-0.7.ebuild26
2 files changed, 32 insertions, 1 deletions
diff --git a/sys-apps/paxctl/ChangeLog b/sys-apps/paxctl/ChangeLog
index 265400ae84b4..cb3948ac5cb2 100644
--- a/sys-apps/paxctl/ChangeLog
+++ b/sys-apps/paxctl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/paxctl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/paxctl/ChangeLog,v 1.31 2012/02/20 00:50:09 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paxctl/ChangeLog,v 1.32 2012/03/23 00:44:07 blueness Exp $
+
+*paxctl-0.7 (23 Mar 2012)
+
+ 23 Mar 2012; Anthony G. Basile <blueness@gentoo.org> +paxctl-0.7.ebuild:
+ Version bump fixes bug #408377
*paxctl-0.6 (20 Feb 2012)
diff --git a/sys-apps/paxctl/paxctl-0.7.ebuild b/sys-apps/paxctl/paxctl-0.7.ebuild
new file mode 100644
index 000000000000..442992f6c1d9
--- /dev/null
+++ b/sys-apps/paxctl/paxctl-0.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paxctl/paxctl-0.7.ebuild,v 1.1 2012/03/23 00:44:07 blueness Exp $
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Manages various PaX related program header flags for Elf32, Elf64, binaries."
+SRC_URI="http://pax.grsecurity.net/paxctl-${PV}.tar.gz"
+HOMEPAGE="http://pax.grsecurity.net"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-devel/binutils-2.14.90.0.8-r1"
+RDEPEND=""
+
+src_compile() {
+ tc-export CC
+ emake CC="${CC}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ einstall DESTDIR="${D}"
+ dodoc README ChangeLog
+}