summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-01-19 21:37:29 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-01-19 21:37:29 +0000
commit74c786f789f0702f7d5552d3c719662e30cc8952 (patch)
tree7f82ed843d076e55391cb7c7d328f0b0da91627d /sys-apps/pcsc-lite
parentFix bug 148224, thanks to James Rowe <jnrowe at ukfsn dot org> for the initia... (diff)
downloadgentoo-2-74c786f789f0702f7d5552d3c719662e30cc8952.tar.gz
gentoo-2-74c786f789f0702f7d5552d3c719662e30cc8952.tar.bz2
gentoo-2-74c786f789f0702f7d5552d3c719662e30cc8952.zip
Version bump
(Portage version: 2.1.2)
Diffstat (limited to 'sys-apps/pcsc-lite')
-rw-r--r--sys-apps/pcsc-lite/ChangeLog9
-rw-r--r--sys-apps/pcsc-lite/files/digest-pcsc-lite-1.3.33
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.3.3.ebuild48
3 files changed, 58 insertions, 2 deletions
diff --git a/sys-apps/pcsc-lite/ChangeLog b/sys-apps/pcsc-lite/ChangeLog
index 3f50dbd4e59d..fb970893f290 100644
--- a/sys-apps/pcsc-lite/ChangeLog
+++ b/sys-apps/pcsc-lite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/pcsc-lite
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.33 2006/12/18 19:40:57 gustavoz Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.34 2007/01/19 21:37:29 alonbl Exp $
+
+*pcsc-lite-1.3.3 (19 Jan 2007)
+
+ 19 Jan 2007; Alon Bar-Lev <alonbl@gentoo.org> +pcsc-lite-1.3.3.ebuild:
+ Version bump
18 Dec 2006; Gustavo Zacarias <gustavoz@gentoo.org>
pcsc-lite-1.3.2.ebuild:
diff --git a/sys-apps/pcsc-lite/files/digest-pcsc-lite-1.3.3 b/sys-apps/pcsc-lite/files/digest-pcsc-lite-1.3.3
new file mode 100644
index 000000000000..441bd813e38d
--- /dev/null
+++ b/sys-apps/pcsc-lite/files/digest-pcsc-lite-1.3.3
@@ -0,0 +1,3 @@
+MD5 851b090aa0efedd0196f6afd9c0c61bb pcsc-lite-1.3.3.tar.gz 859571
+RMD160 d7f700128896b4f37405f4a4c373af0db74082fc pcsc-lite-1.3.3.tar.gz 859571
+SHA256 8f3a565b13760e9e05ffff1944755f8651e105069fda96d56e8ae64ae17365f7 pcsc-lite-1.3.3.tar.gz 859571
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.3.3.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.3.3.ebuild
new file mode 100644
index 000000000000..e1b9eaaac26f
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.3.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/pcsc-lite-1.3.3.ebuild,v 1.1 2007/01/19 21:37:29 alonbl Exp $
+
+inherit multilib
+
+STUPID_NUM="1869"
+MY_P="${PN}-${PV/_/-}"
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="http://www.linuxnet.com/middle.html"
+SRC_URI="http://alioth.debian.org/download.php/${STUPID_NUM}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static debug"
+
+RDEPEND="!static? ( dev-libs/libusb )"
+DEPEND="dev-libs/libusb
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf \
+ --enable-usbdropdir=/usr/$(get_libdir)/readers/usb \
+ --enable-muscledropdir=/usr/share/pcsc/services \
+ --enable-runpid=/var/run/pcscd.pid \
+ $(use_enable debug) \
+ $(use_enable static) \
+ || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog DRIVERS HELP INSTALL NEWS README SECURITY
+ dodoc doc/*.pdf doc/README.DAEMON
+ rm -r "${D}"/usr/doc
+
+ newinitd "${FILESDIR}"/pcscd-init pcscd
+ newconfd "${FILESDIR}"/pcscd-confd pcscd
+}
+
+pkg_postinst() {
+ ewarn "You should run 'revdep-rebuild --library libpcsclite.so.0'"
+}