summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2008-10-20 22:58:41 +0000
committerJeremy Olexa <darkside@gentoo.org>2008-10-20 22:58:41 +0000
commit984969368abf173a8db6303df17cf35089696631 (patch)
tree2c13cde544ce7ecb46f5d907d5e7f8eb1894f26b /sys-apps/preload
parentKeyworded and stable for sparc, security bug #192989 (diff)
downloadgentoo-2-984969368abf173a8db6303df17cf35089696631.tar.gz
gentoo-2-984969368abf173a8db6303df17cf35089696631.tar.bz2
gentoo-2-984969368abf173a8db6303df17cf35089696631.zip
sys-apps/preload add patch by Pacho Ramos to include files in /opt or /lib32 to be preloaded, bug #242580. One minor conf file tweak.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-git6 x86_64)
Diffstat (limited to 'sys-apps/preload')
-rw-r--r--sys-apps/preload/ChangeLog10
-rw-r--r--sys-apps/preload/files/conf.d-preload5
-rw-r--r--sys-apps/preload/files/preload-0.6.3-conf.patch20
-rw-r--r--sys-apps/preload/preload-0.6.3-r2.ebuild43
4 files changed, 74 insertions, 4 deletions
diff --git a/sys-apps/preload/ChangeLog b/sys-apps/preload/ChangeLog
index 7913698f9347..e61ffff7645f 100644
--- a/sys-apps/preload/ChangeLog
+++ b/sys-apps/preload/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/preload
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/preload/ChangeLog,v 1.3 2008/10/20 18:58:10 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/preload/ChangeLog,v 1.4 2008/10/20 22:58:40 darkside Exp $
+
+*preload-0.6.3-r2 (20 Oct 2008)
+
+ 20 Oct 2008; Jeremy Olexa <darkside@gentoo.org>
+ +files/preload-0.6.3-conf.patch, files/conf.d-preload,
+ +preload-0.6.3-r2.ebuild:
+ sys-apps/preload add patch by Pacho Ramos to include files in /opt or /lib32
+ to be preloaded, bug #242580. One minor conf file tweak.
*preload-0.6.3-r1 (20 Oct 2008)
diff --git a/sys-apps/preload/files/conf.d-preload b/sys-apps/preload/files/conf.d-preload
index 3ff0eea79700..52de3301b6b7 100644
--- a/sys-apps/preload/files/conf.d-preload
+++ b/sys-apps/preload/files/conf.d-preload
@@ -1,5 +1,5 @@
# Copyright 1999-2008 Gentoo Foundation
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/preload/files/conf.d-preload,v 1.2 2008/10/20 18:58:11 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/preload/files/conf.d-preload,v 1.3 2008/10/20 22:58:41 darkside Exp $
# preload configuration file
# verbosity. 0-9, Default is 4.
@@ -9,8 +9,7 @@ PRELOAD_VERBOSITY="4"
PRELOAD_NICE="15"
# log file (default is /var/log/preload.log )
-# Empty means default location.
-#PRELOAD_LOGFILE="/var/log/preload.log"
+PRELOAD_LOGFILE="/var/log/preload.log"
# prelaod state file (default is /var/lib/preload/preload.state )
# Empty means no state is saved.
diff --git a/sys-apps/preload/files/preload-0.6.3-conf.patch b/sys-apps/preload/files/preload-0.6.3-conf.patch
new file mode 100644
index 000000000000..e7e27367039d
--- /dev/null
+++ b/sys-apps/preload/files/preload-0.6.3-conf.patch
@@ -0,0 +1,20 @@
+--- src/preload.conf.in~ 2008-10-18 17:12:39.000000000 +0200
++++ src/preload.conf.in 2008-10-18 17:12:39.000000000 +0200
+@@ -132,7 +132,7 @@
+ # preload doesn't special-handle device files internally.
+ #
+ # default: (empty list, accept all)
+-mapprefix = /usr;/lib;/lib64;/var/cache;!/
++mapprefix = /usr;/lib;/lib64;/lib32;/opt;/var/cache;!/
+
+ # exeprefix:
+ #
+@@ -141,7 +141,7 @@
+ # files instead of maps.
+ #
+ # default: (empty list, accept all)
+-exeprefix = !/usr/sbin;!/usr/local/sbin;/usr;!/
++exeprefix = !/usr/sbin;!/usr/local/sbin;/usr;/opt;!/
+
+ # maxprocs
+ #
diff --git a/sys-apps/preload/preload-0.6.3-r2.ebuild b/sys-apps/preload/preload-0.6.3-r2.ebuild
new file mode 100644
index 000000000000..c9683aece7d7
--- /dev/null
+++ b/sys-apps/preload/preload-0.6.3-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/preload/preload-0.6.3-r2.ebuild,v 1.1 2008/10/20 22:58:40 darkside Exp $
+
+EAPI="2"
+inherit eutils
+
+DESCRIPTION="Adaptive readahead daemon."
+HOMEPAGE="http://sourceforge.net/projects/preload"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # Patch to add /opt & /lib32 to allowed files to preload. Submitted
+ # upstream, bug #242580
+ epatch "${FILESDIR}/${P}-conf.patch"
+}
+
+src_configure() {
+ econf --localstatedir=/var
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ rm -rf "${D}/etc/rc.d" || die "rm rc.d failed"
+ rm -rf "${D}/etc/sysconfig" || die "rm sysconfig failed"
+ newinitd "${FILESDIR}/init.d-preload" preload || die "initd failed"
+ newconfd "${FILESDIR}/conf.d-preload" preload || die "confd failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}
+