summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-12-30 01:20:57 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-12-30 01:20:57 +0000
commitb7f9be5c6c47abcbde9380e9dd99acc41df8ae61 (patch)
treef2e6571b61de165167049c8deeb57482f35750d5 /sys-apps/procps
parentcleanups (diff)
downloadgentoo-2-b7f9be5c6c47abcbde9380e9dd99acc41df8ae61.tar.gz
gentoo-2-b7f9be5c6c47abcbde9380e9dd99acc41df8ae61.tar.bz2
gentoo-2-b7f9be5c6c47abcbde9380e9dd99acc41df8ae61.zip
I suck, forgot to commit these, thanks drobbins for reminding me
Diffstat (limited to 'sys-apps/procps')
-rw-r--r--sys-apps/procps/files/digest-procps-2.0.7-r61
-rw-r--r--sys-apps/procps/procps-2.0.7-r6.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/sys-apps/procps/files/digest-procps-2.0.7-r6 b/sys-apps/procps/files/digest-procps-2.0.7-r6
new file mode 100644
index 000000000000..c5bca40ccd89
--- /dev/null
+++ b/sys-apps/procps/files/digest-procps-2.0.7-r6
@@ -0,0 +1 @@
+MD5 bd8d68a9fd0c3f37365f924e75009c8a procps-2.0.7.tar.gz 200704
diff --git a/sys-apps/procps/procps-2.0.7-r6.ebuild b/sys-apps/procps/procps-2.0.7-r6.ebuild
new file mode 100644
index 000000000000..c509e37fac04
--- /dev/null
+++ b/sys-apps/procps/procps-2.0.7-r6.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/procps-2.0.7-r6.ebuild,v 1.1 2001/12/30 01:20:57 hallski Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard informational utilities and process-handling tools"
+SRC_URI="ftp://people.redhat.com/johnsonm/${PN}/${P}.tar.gz"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.10.35"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ # Patches from Red Hat SRPM 2.0.7-11
+ # Didn't apply the -desktop and the -aix patches.
+
+ patch -p1 < ${FILESDIR}/${PV}/${P}-locale.patch
+ patch -p1 < ${FILESDIR}/${PV}/${P}-negvalue.patch
+ patch -p1 < ${FILESDIR}/${PV}/${P}-retcode.patch
+ patch -p1 < ${FILESDIR}/${PV}/${P}-biguid.patch
+ patch -p1 < ${FILESDIR}/${PV}/${P}-bigbuff.patch
+ patch -p1 < ${FILESDIR}/${PV}/${P}-sysctl-error.patch
+
+ # Use the CFLAGS from /etc/make.conf.
+
+ mv Makefile Makefile.orig
+ sed -e "s/-O3/${CFLAGS}/" -e 's/all: config/all: /' \
+ -e "s:--strip::" Makefile.orig > Makefile
+
+ cd ${S}/ps
+ mv Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/" -e "s:--strip::" Makefile.orig > Makefile
+
+ cd ${S}/proc
+ mv Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/" -e "s:--strip::" Makefile.orig > Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /sbin
+ dodir /usr/X11R6/bin
+ dodir /usr/share/man/man{1,5,8}
+ dodir /lib
+ dodir /bin
+
+ make DESTDIR=${D} MANDIR=/usr/share/man install || die
+
+ dodoc BUGS COPYING COPYING.LIB NEWS TODO
+ docinto proc
+ dodoc proc/COPYING
+ docinto ps
+ dodoc ps/COPYING ps/HACKING
+}
+