summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2005-07-10 21:32:36 +0000
committerDaniel Drake <dsd@gentoo.org>2005-07-10 21:32:36 +0000
commitf77b754b6ad63b0b9d9e922abff4dcba822237cf (patch)
tree4d53d8c7bf3ec7cd7ce26e2882d1086201d2312d /sys-apps/rlocate/rlocate-0.3.1-r1.ebuild
parent#98534: ./configure can now find x11 in gentoo; patch thanks to basic <basic@... (diff)
downloadgentoo-2-f77b754b6ad63b0b9d9e922abff4dcba822237cf.tar.gz
gentoo-2-f77b754b6ad63b0b9d9e922abff4dcba822237cf.tar.bz2
gentoo-2-f77b754b6ad63b0b9d9e922abff4dcba822237cf.zip
Convert to linux-mod, closes bug #98563
(Portage version: 1.589-cvs)
Diffstat (limited to 'sys-apps/rlocate/rlocate-0.3.1-r1.ebuild')
-rw-r--r--sys-apps/rlocate/rlocate-0.3.1-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sys-apps/rlocate/rlocate-0.3.1-r1.ebuild b/sys-apps/rlocate/rlocate-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..d74450225bce
--- /dev/null
+++ b/sys-apps/rlocate/rlocate-0.3.1-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/rlocate-0.3.1-r1.ebuild,v 1.1 2005/07/10 21:32:36 dsd Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="locate implementation that is always up-to-date"
+HOMEPAGE="http://rlocate.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rlocate/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="!sys-apps/slocate"
+
+pkg_setup() {
+ MODULE_NAMES="rlocate(misc:${S}/rlocate-module)"
+ CONFIG_CHECK="SECURITY"
+ SECURITY_ERROR="You need to select the \"Enable different security models\" option in the kernel configuration (CONFIG_SECURITY)."
+ BUILD_TARGETS="all"
+ linux-mod_pkg_setup
+
+ enewgroup locate
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^RLOCATE_GRP/s:=.*:=locate:' \
+ -e 's/rlocate-module//g' \
+ Makefile.in || die "sed group"
+ rm -f rlocate-scripts/Makefile
+ sed -i \
+ -e '/groupadd/d' \
+ -e '/chown/s/root:$(rlocate)/root:locate/g' \
+ Makefile.in rlocate-scripts/Makefile.in
+ sed -i \
+ -e '/DRLOCATE_GRP/s:$(rlocate):locate:' \
+ rlocate-daemon/Makefile.in
+}
+
+src_compile() {
+ econf --enable-sandboxed --with-kernel=${KV_DIR} || die
+ emake || die
+ linux-mod_src_compile
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ linux-mod_src_install
+ dodoc AUTHORS ChangeLog* NEWS README
+}