summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2006-05-19 12:15:28 +0000
committerMartin Schlemmer <azarah@gentoo.org>2006-05-19 12:15:28 +0000
commitebe20c6f0ae998c29269c9ad7d5d73fdddd193fa (patch)
tree84dee5de1dc58292cf3d7ec58ff53f960c850add /sys-apps/sandbox
parentadd some extra depends (diff)
downloadgentoo-2-ebe20c6f0ae998c29269c9ad7d5d73fdddd193fa.tar.gz
gentoo-2-ebe20c6f0ae998c29269c9ad7d5d73fdddd193fa.tar.bz2
gentoo-2-ebe20c6f0ae998c29269c9ad7d5d73fdddd193fa.zip
New bugfix release.
(Portage version: 2.1_rc1-r3)
Diffstat (limited to 'sys-apps/sandbox')
-rw-r--r--sys-apps/sandbox/ChangeLog8
-rw-r--r--sys-apps/sandbox/files/digest-sandbox-1.2.18.13
-rw-r--r--sys-apps/sandbox/sandbox-1.2.18.1.ebuild117
3 files changed, 127 insertions, 1 deletions
diff --git a/sys-apps/sandbox/ChangeLog b/sys-apps/sandbox/ChangeLog
index a18ad64ec46b..f4b3a699875e 100644
--- a/sys-apps/sandbox/ChangeLog
+++ b/sys-apps/sandbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/sandbox
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.63 2006/05/11 03:29:52 tsunam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.64 2006/05/19 12:15:28 azarah Exp $
+
+*sandbox-1.2.18.1 (19 May 2006)
+
+ 19 May 2006; Martin Schlemmer <azarah@gentoo.org>
+ +sandbox-1.2.18.1.ebuild:
+ New bugfix release.
11 May 2006; Joshua Jackson <tsunam@gentoo.org> sandbox-1.2.17.ebuild:
stable x86; bug #132025
diff --git a/sys-apps/sandbox/files/digest-sandbox-1.2.18.1 b/sys-apps/sandbox/files/digest-sandbox-1.2.18.1
new file mode 100644
index 000000000000..f894e17eaa8e
--- /dev/null
+++ b/sys-apps/sandbox/files/digest-sandbox-1.2.18.1
@@ -0,0 +1,3 @@
+MD5 8637808ea8fa55fe10c57d335911e847 sandbox-1.2.18.1.tar.bz2 236755
+RMD160 62e1e33d7f64db14d9c34d103d50256934a6d253 sandbox-1.2.18.1.tar.bz2 236755
+SHA256 3404381bfdea3042e6ddb7c309eaef08201d8731d8e0a756c42cd389edda14c0 sandbox-1.2.18.1.tar.bz2 236755
diff --git a/sys-apps/sandbox/sandbox-1.2.18.1.ebuild b/sys-apps/sandbox/sandbox-1.2.18.1.ebuild
new file mode 100644
index 000000000000..77158d711a17
--- /dev/null
+++ b/sys-apps/sandbox/sandbox-1.2.18.1.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.2.18.1.ebuild,v 1.1 2006/05/19 12:15:28 azarah Exp $
+
+#
+# don't monkey with this ebuild unless contacting portage devs.
+# period.
+#
+
+inherit eutils flag-o-matic eutils toolchain-funcs multilib
+
+DESCRIPTION="sandbox'd LD_PRELOAD hack"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~azarah/sandbox/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+RESTRICT="multilib-pkg-force"
+
+DEPEND=""
+
+setup_multilib() {
+ if use amd64 && has_m32 && [[ ${CONF_MULTILIBDIR} == "lib32" ]]; then
+ export DEFAULT_ABI="amd64"
+ export MULTILIB_ABIS="x86 amd64"
+ export CFLAGS_amd64=${CFLAGS_amd64:-"-m64"}
+ export CFLAGS_x86=${CFLAGS_x86-"-m32 -L/emul/linux/x86/lib -L/emul/linux/x86/usr/lib"}
+ export CHOST_amd64="x86_64-pc-linux-gnu"
+ export CHOST_x86="i686-pc-linux-gnu"
+ export LIBDIR_amd64=${LIBDIR_amd64-${CONF_LIBDIR}}
+ export LIBDIR_x86=${LIBDIR_x86-${CONF_MULTILIBDIR}}
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+}
+
+abi_fail_check() {
+ local ABI=$1
+ if [[ ${ABI} == "x86" ]] ; then
+ echo
+ eerror "Building failed for ABI=x86!. This usually means a broken"
+ eerror "multilib setup. Please fix that before filling a bugreport"
+ eerror "against sandbox."
+ echo
+ fi
+}
+
+src_compile() {
+ local myconf
+ local iscross=0
+
+ setup_multilib
+
+ filter-lfs-flags #90228
+
+ has_multilib_profile && myconf="--enable-multilib"
+
+ ewarn "If configure fails with a 'cannot run C compiled programs' error, try this:"
+ ewarn "FEATURES=-sandbox emerge sandbox"
+
+ [[ -n ${CBUILD} && ${CBUILD} != ${CHOST} ]] && iscross=1
+
+ OABI=${ABI}
+ OCHOST=${CHOST}
+ for ABI in $(get_install_abis); do
+ mkdir "${WORKDIR}/build-${ABI}-${OCHOST}"
+ cd "${WORKDIR}/build-${ABI}-${OCHOST}"
+
+ # Needed for older broken portage versions (bug #109036)
+ has_version '<sys-apps/portage-2.0.51.22' && \
+ unset EXTRA_ECONF
+
+ export ABI
+ export CHOST=$(get_abi_CHOST)
+ [[ ${iscross} == 0 ]] && export CBUILD=${CHOST}
+
+ einfo "Configuring sandbox for ABI=${ABI}..."
+ ECONF_SOURCE="../${P}/" \
+ econf --libdir="/usr/$(get_libdir)" ${myconf}
+ einfo "Building sandbox for ABI=${ABI}..."
+ emake || {
+ abi_fail_check "${ABI}"
+ die "emake failed for ${ABI}"
+ }
+ done
+ ABI=${OABI}
+ CHOST=${OCHOST}
+}
+
+src_install() {
+ setup_multilib
+
+ OABI=${ABI}
+ for ABI in $(get_install_abis); do
+ cd "${WORKDIR}/build-${ABI}-${CHOST}"
+ einfo "Installing sandbox for ABI=${ABI}..."
+ make DESTDIR="${D}" install || die "make install failed for ${ABI}"
+ done
+ ABI=${OABI}
+
+ keepdir /var/log/sandbox
+ fowners root:portage /var/log/sandbox
+ fperms 0770 /var/log/sandbox
+
+ cd ${S}
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_preinst() {
+ chown root:portage ${IMAGE}/var/log/sandbox
+ chmod 0770 ${IMAGE}/var/log/sandbox
+}