summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-07-28 15:49:20 +0000
committerPeter Gavin <pete@gentoo.org>2001-07-28 15:49:20 +0000
commit00370f2de9e5825d29ca212d51ed35388567b48d (patch)
treefbd98eac91baf6271f55be3aa165475eae5ce777 /sys-apps/sed/sed-3.02.80-r3.ebuild
parentapply a patch that makes it work better with autoconf 2.13 (diff)
downloadgentoo-2-00370f2de9e5825d29ca212d51ed35388567b48d.tar.gz
gentoo-2-00370f2de9e5825d29ca212d51ed35388567b48d.tar.bz2
gentoo-2-00370f2de9e5825d29ca212d51ed35388567b48d.zip
bootcd fixups and additions. set USE=bootcd to build these packages
for the installation cd. autoiso.sh is the cd building automation script. (its not nearly complete though)
Diffstat (limited to 'sys-apps/sed/sed-3.02.80-r3.ebuild')
-rw-r--r--sys-apps/sed/sed-3.02.80-r3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/sed/sed-3.02.80-r3.ebuild b/sys-apps/sed/sed-3.02.80-r3.ebuild
new file mode 100644
index 000000000000..c35d128af82a
--- /dev/null
+++ b/sys-apps/sed/sed-3.02.80-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-3.02.80-r3.ebuild,v 1.1 2001/07/28 15:49:20 pete Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Super-useful stream editor"
+SRC_URI="ftp://alpha.gnu.org/pub/gnu/sed/${A}"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+ try ./configure --prefix=/usr --host=${CHOST} ${myconf}
+ if [ -z "`use static`" ]
+ then
+ try make ${MAKEOPTS}
+ else
+ try make ${MAKEOPTS} LDFLAGS=-static
+ fi
+}
+
+src_install() {
+
+ into /
+ dobin sed/sed
+ dodir /usr/bin
+ dosym ../../bin/sed /usr/bin/sed
+
+ if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
+ then
+ into /usr
+ doinfo doc/sed.info
+ doman doc/sed.1
+ dodoc COPYING NEWS README* THANKS TODO AUTHORS BUGS ANNOUNCE
+ else
+ rm -rf ${D}/usr/share
+ fi
+
+}
+