summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-27 16:46:47 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-27 16:46:47 +0000
commit0b669818473c53d66ede591d59b68ece6d8f90ea (patch)
treed1a92585685945d7bca0dc2814c45e7e0906d364 /sys-apps/sed
parentNow supports USE static build (diff)
downloadgentoo-2-0b669818473c53d66ede591d59b68ece6d8f90ea.tar.gz
gentoo-2-0b669818473c53d66ede591d59b68ece6d8f90ea.tar.bz2
gentoo-2-0b669818473c53d66ede591d59b68ece6d8f90ea.zip
Now uses USE build static nls
Diffstat (limited to 'sys-apps/sed')
-rw-r--r--sys-apps/sed/sed-3.02.80-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-apps/sed/sed-3.02.80-r2.ebuild b/sys-apps/sed/sed-3.02.80-r2.ebuild
new file mode 100644
index 000000000000..a3ea2cafebc8
--- /dev/null
+++ b/sys-apps/sed/sed-3.02.80-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-3.02.80-r2.ebuild,v 1.1 2001/02/27 16:46:47 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Super-useful stream editor"
+SRC_URI="ftp://alpha.gnu.org/pub/gnu/sed/${A}"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+ try ./configure --prefix=/usr --host=${CHOST} ${myconf}
+ if [ -z "`use static`" ]
+ then
+ try make ${MAKEOPTS}
+ else
+ try make ${MAKEOPTS} LDFLAGS=-static
+ fi
+}
+
+src_install() {
+
+ into /
+ dobin sed/sed
+ dodir /usr/bin
+ dosym /bin/sed /usr/bin/sed
+
+ if [ -z "`use build`" ]
+ then
+ into /usr
+ doinfo doc/sed.info
+ doman doc/sed.1
+ dodoc COPYING NEWS README* THANKS TODO AUTHORS BUGS ANNOUNCE
+ fi
+
+}
+