summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-03-05 16:53:36 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-03-05 16:53:36 +0000
commit61369404d5ec7485413c69bd09bc936c7ca74693 (patch)
tree6fcae50d2f45c35e81877497136e3d1bf6a0f63b /sys-apps/sed
parentversion bump #16012 (diff)
downloadgentoo-2-61369404d5ec7485413c69bd09bc936c7ca74693.tar.gz
gentoo-2-61369404d5ec7485413c69bd09bc936c7ca74693.tar.bz2
gentoo-2-61369404d5ec7485413c69bd09bc936c7ca74693.zip
Fix static use var, stuff
Diffstat (limited to 'sys-apps/sed')
-rw-r--r--sys-apps/sed/ChangeLog5
-rw-r--r--sys-apps/sed/sed-4.0.5-r1.ebuild12
2 files changed, 10 insertions, 7 deletions
diff --git a/sys-apps/sed/ChangeLog b/sys-apps/sed/ChangeLog
index 08d02ac8ff3b..3b16d2867fa0 100644
--- a/sys-apps/sed/ChangeLog
+++ b/sys-apps/sed/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for sys-apps/sed
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/ChangeLog,v 1.21 2003/03/04 21:38:52 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/ChangeLog,v 1.22 2003/03/05 16:53:36 lostlogic Exp $
*sed-4.0.5-r1 (04 Mar 2002)
+ 05 Mar 2003; Brandon Low <lostlogic@gentoo.org> sed-4.0.5-r1.ebuild:
+ Fix static use variables, and add appropriate die messages
+
04 Mar 2003; Brandon Low <lostlogic@gentoo.org> sed-4.0.5-r1.ebuild:
Add examples to installed docs
diff --git a/sys-apps/sed/sed-4.0.5-r1.ebuild b/sys-apps/sed/sed-4.0.5-r1.ebuild
index d06d0bd7f3bd..f1725206a6eb 100644
--- a/sys-apps/sed/sed-4.0.5-r1.ebuild
+++ b/sys-apps/sed/sed-4.0.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.0.5-r1.ebuild,v 1.2 2003/03/04 21:38:52 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.0.5-r1.ebuild,v 1.3 2003/03/05 16:53:36 lostlogic Exp $
DESCRIPTION="Super-useful stream editor"
SRC_URI="ftp://ftp.gnu.org/pub/gnu/sed/${P}.tar.gz"
@@ -16,11 +16,11 @@ DEPEND="virtual/glibc
RDEPEND="virtual/glibc"
src_compile() {
- econf `use_enable nls` || die
- if [ `use static` ] ; then
- emake || die
+ econf `use_enable nls` || die "Configure failed"
+ if [ -z `use static` ] ; then
+ emake || die "Shared build failed"
else
- emake LDFLAGS=-static || die
+ emake LDFLAGS=-static || die "Static build failed"
fi
}
@@ -29,7 +29,7 @@ src_install() {
dobin sed/sed
if [ -z "`use build`" ]
then
- einstall || die "install failed"
+ einstall || die "Install failed"
dodoc COPYING NEWS README* THANKS TODO AUTHORS BUGS ANNOUNCE ChangeLog
docinto examples
dodoc ${FILESDIR}/dos2unix ${FILESDIR}/unix2dos