summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-08-10 05:04:18 +0000
committerTim Harder <radhermit@gentoo.org>2013-08-10 05:04:18 +0000
commitb693e90684d908a45de2b85c2bd24455fc783b6f (patch)
treee3c524445047754b2df3ebd3089033c04fd6c525 /sys-apps/smartmontools
parentVersion bump. (diff)
downloadgentoo-2-b693e90684d908a45de2b85c2bd24455fc783b6f.tar.gz
gentoo-2-b693e90684d908a45de2b85c2bd24455fc783b6f.tar.bz2
gentoo-2-b693e90684d908a45de2b85c2bd24455fc783b6f.zip
Version bump.
(Portage version: 2.2.0_alpha195/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-apps/smartmontools')
-rw-r--r--sys-apps/smartmontools/ChangeLog7
-rw-r--r--sys-apps/smartmontools/smartmontools-6.2.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/sys-apps/smartmontools/ChangeLog b/sys-apps/smartmontools/ChangeLog
index 0578d890e682..9bf83a1da331 100644
--- a/sys-apps/smartmontools/ChangeLog
+++ b/sys-apps/smartmontools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/smartmontools
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.130 2013/08/03 07:30:55 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.131 2013/08/10 05:04:18 radhermit Exp $
+
+*smartmontools-6.2 (10 Aug 2013)
+
+ 10 Aug 2013; Tim Harder <radhermit@gentoo.org> +smartmontools-6.2.ebuild:
+ Version bump.
03 Aug 2013; Agostino Sarubbo <ago@gentoo.org> smartmontools-6.1.ebuild:
Stable for sparc, wrt bug #475894
diff --git a/sys-apps/smartmontools/smartmontools-6.2.ebuild b/sys-apps/smartmontools/smartmontools-6.2.ebuild
new file mode 100644
index 000000000000..1632bb06296a
--- /dev/null
+++ b/sys-apps/smartmontools/smartmontools-6.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-6.2.ebuild,v 1.1 2013/08/10 05:04:18 radhermit Exp $
+
+EAPI="4"
+
+inherit flag-o-matic systemd
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="https://smartmontools.svn.sourceforge.net/svnroot/smartmontools/trunk/smartmontools"
+ ESVN_PROJECT="smartmontools"
+ inherit subversion autotools
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~x64-macos"
+fi
+
+DESCRIPTION="Self-Monitoring, Analysis and Reporting Technology System (S.M.A.R.T.) monitoring tools"
+HOMEPAGE="http://smartmontools.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="caps minimal selinux static"
+
+DEPEND="caps? ( sys-libs/libcap-ng )
+ selinux? ( sys-libs/libselinux )"
+RDEPEND="${DEPEND}
+ !minimal? ( virtual/mailx )"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ #./autogen.sh
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ use minimal && einfo "Skipping the monitoring daemon for minimal build."
+ use static && append-ldflags -static
+ # The build installs /etc/init.d/smartd, but we clobber it
+ # in our src_install, so no need to manually delete it.
+ econf \
+ --with-docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --with-initscriptdir="${EPREFIX}/etc/init.d" \
+ $(use_with caps libcap-ng) \
+ $(use_with selinux) \
+ $(systemd_with_unitdir)
+}
+
+src_install() {
+ if use minimal ; then
+ dosbin smartctl
+ doman smartctl.8
+ else
+ default
+ newinitd "${FILESDIR}"/smartd.rc smartd
+ newconfd "${FILESDIR}"/smartd.confd smartd
+ fi
+}