summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-11-09 19:41:21 +0000
committerMike Frysinger <vapier@gentoo.org>2003-11-09 19:41:21 +0000
commit1ebf96ab617afa701fb190cc7085fda19871d3d6 (patch)
tree0be772f597d0a7b17350fb6a8729cf8e07301a9e /sys-apps/systrace
parentfix autoconf DEPEND #33047 (diff)
downloadgentoo-2-1ebf96ab617afa701fb190cc7085fda19871d3d6.tar.gz
gentoo-2-1ebf96ab617afa701fb190cc7085fda19871d3d6.tar.bz2
gentoo-2-1ebf96ab617afa701fb190cc7085fda19871d3d6.zip
fix autoconf #33047
Diffstat (limited to 'sys-apps/systrace')
-rw-r--r--sys-apps/systrace/ChangeLog7
-rw-r--r--sys-apps/systrace/files/1.0-no-gtk.patch11
-rw-r--r--sys-apps/systrace/files/digest-systrace-1.0-r41
-rw-r--r--sys-apps/systrace/systrace-1.0-r4.ebuild51
4 files changed, 29 insertions, 41 deletions
diff --git a/sys-apps/systrace/ChangeLog b/sys-apps/systrace/ChangeLog
index 6e078c88504b..72cd04a72069 100644
--- a/sys-apps/systrace/ChangeLog
+++ b/sys-apps/systrace/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for sys-apps/systrace
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systrace/ChangeLog,v 1.5 2003/06/26 23:21:22 natey Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systrace/ChangeLog,v 1.6 2003/11/09 19:41:21 vapier Exp $
*systrace-1.0-r4 (26 Jun 2003)
+ 09 Nov 2003; Mike Frysinger <vapier@gentoo.org> :
+ Remove all the autoconf stuff since it doesnt seem to be needed.
+ Moved the patch to filesdir since it's only 341 bytes. Removed
+ the calls to sleep since they're just an annoyance.
+
26 Jun 2003; Nate Underwood <natey@gentoo.org> systrace-1.0-r1.ebuild,
systrace-1.0-r2.ebuild, systrace-1.0-r3.ebuild, systrace-1.0-r4.ebuild:
Version bump due to new userland sources. Modified ACCEPT_KEYWORDS back to
diff --git a/sys-apps/systrace/files/1.0-no-gtk.patch b/sys-apps/systrace/files/1.0-no-gtk.patch
new file mode 100644
index 000000000000..af7bda2ba5f8
--- /dev/null
+++ b/sys-apps/systrace/files/1.0-no-gtk.patch
@@ -0,0 +1,11 @@
+--- systrace.c 2003-01-23 12:42:47.000000000 -0800
++++ systrace.c-no_x11-1.0 2003-03-17 21:05:36.000000000 -0800
+@@ -521,7 +521,7 @@
+ char *guipath = _PATH_XSYSTRACE;
+ struct timeval tv, tv_wait = {60, 0};
+ pid_t pidattach = 0;
+- int usex11 = 1, count;
++ int usex11 = 0, count;
+ int background;
+ int setcredentials = 0;
+ uid_t cr_uid;
diff --git a/sys-apps/systrace/files/digest-systrace-1.0-r4 b/sys-apps/systrace/files/digest-systrace-1.0-r4
index a0a83bc50ed3..1a9ac3b0d41a 100644
--- a/sys-apps/systrace/files/digest-systrace-1.0-r4
+++ b/sys-apps/systrace/files/digest-systrace-1.0-r4
@@ -1,2 +1 @@
MD5 d7084ce18abda78ff35461fa0a621dd2 usr-systrace-2003-06-23.tar.gz 162235
-MD5 991caa03d07abeb2a5e9bb27bfee2123 systrace.c-no_x11-1.0.patch.gz 275
diff --git a/sys-apps/systrace/systrace-1.0-r4.ebuild b/sys-apps/systrace/systrace-1.0-r4.ebuild
index e3b888d99be8..29dc91017486 100644
--- a/sys-apps/systrace/systrace-1.0-r4.ebuild
+++ b/sys-apps/systrace/systrace-1.0-r4.ebuild
@@ -1,25 +1,21 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systrace/systrace-1.0-r4.ebuild,v 1.2 2003/09/07 00:56:32 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systrace/systrace-1.0-r4.ebuild,v 1.3 2003/11/09 19:41:21 vapier Exp $
DESCRIPTION="Systrace userland binary"
-HOMEPAGE="http://www.systrace.org"
-SRC_URI="http://www.citi.umich.edu/u/provos/systrace/usr-systrace-2003-06-23.tar.gz
- http://cvs.gentoo.org/~natey/systrace/patches/systrace.c-no_x11-1.0.patch.gz"
-SLOT="0"
-LICENSE="GPL-2"
-PATCH1="systrace.c-no_x11-1.0.patch"
-INCLUDE="/usr/include/linux/systrace.h"
-S="${WORKDIR}/${P}"
+HOMEPAGE="http://www.systrace.org/"
+SRC_URI="http://www.citi.umich.edu/u/provos/systrace/usr-systrace-2003-06-23.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86"
IUSE="gtk"
+
DEPEND="dev-libs/libevent
- =sys-devel/autoconf-2.57
gtk? ( =x11-libs/gtk+-1.2* =dev-libs/glib-1.2* )"
pkg_setup() {
- if ! [ -f ${INCLUDE} ] ;
+ if ! [ -f /usr/include/linux/systrace.h ] ;
then
einfo
einfo "ERROR: It does not look like you have a systrace capable kernel. If"
@@ -30,40 +26,17 @@ pkg_setup() {
einfo
einfo "http://www.citi.umich.edu/u/provos/systrace/linux.html"
einfo
- exit 1
+ #die "need systrace in the kernel"
fi
}
-src_compile() {
- if [ "`use gtk`" ]
- then
- einfo
- einfo "You are building systrace with gtk support; this version will not"
- einfo "function without the sys-apps/gtk-systrace package installed. Please"
- einfo "set the USE=\"-gtk\" to build the non-gui capable version of systrace."
- einfo
- sleep 7
- autoconf-2.57
- ./configure || die
- elif [ -z "`use gtk`" ]
- then
- einfo
- einfo "You are building systrace without gtk support; please set USE=\"gtk\""
- einfo "to build the gui capable version of systrace."
- einfo
- sleep 7
- cd ${S}
- epatch ../${PATCH1} || die
- autoconf-2.57
- ./configure || die
- fi
-
- emake || die
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ [ `use gtk` ] || epatch ${FILESDIR}/${PV}-no-gtk.patch
}
src_install() {
dobin systrace
- exeinto /usr/bin
-
doman systrace.1
}