summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-27 12:11:44 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-27 12:11:44 +0000
commit6b71526a8f2cb06b6da53ccd78967dd7a833128f (patch)
treee78445248ea5213f0613f8b12b4ef9acc1233739 /sys-apps/texinfo
parentvarious fixes (diff)
downloadgentoo-2-6b71526a8f2cb06b6da53ccd78967dd7a833128f.tar.gz
gentoo-2-6b71526a8f2cb06b6da53ccd78967dd7a833128f.tar.bz2
gentoo-2-6b71526a8f2cb06b6da53ccd78967dd7a833128f.zip
*** empty log message ***
Diffstat (limited to 'sys-apps/texinfo')
-rw-r--r--sys-apps/texinfo/texinfo-4.0-r2.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/sys-apps/texinfo/texinfo-4.0-r2.ebuild b/sys-apps/texinfo/texinfo-4.0-r2.ebuild
index e2eed3d5ca12..738cd7ed1867 100644
--- a/sys-apps/texinfo/texinfo-4.0-r2.ebuild
+++ b/sys-apps/texinfo/texinfo-4.0-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/texinfo-4.0-r2.ebuild,v 1.1 2001/02/07 15:51:28 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/texinfo-4.0-r2.ebuild,v 1.2 2001/02/27 12:11:44 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -10,13 +10,18 @@ SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/texinfo/${A}
ftp://ftp.gnu.org/pub/gnu/texinfo/${A}"
DEPEND=">=sys-libs/ncurses-5.2-r2
- >=sys-devel/gettext-0.10.35-r2"
+ nls? ( sys-devel/gettext )"
RDEPEND=">=sys-libs/ncurses-5.2-r2"
src_compile() {
-
- try ./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+ try ./configure --host=${CHOST} --prefix=/usr ${myconf} \
+ --mandir=/usr/share/man --infodir=/usr/share/info
try make ${MAKEOPTS}
}