summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-07-21 16:14:37 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-07-21 16:14:37 +0000
commit5e6ca60375a880e1657edf9c2076dc5b0a5cdaf3 (patch)
tree67699b04b78190e8213a2d14f745486ccf11eb04 /sys-apps/textutils
parentbug fix (diff)
downloadgentoo-2-5e6ca60375a880e1657edf9c2076dc5b0a5cdaf3.tar.gz
gentoo-2-5e6ca60375a880e1657edf9c2076dc5b0a5cdaf3.tar.bz2
gentoo-2-5e6ca60375a880e1657edf9c2076dc5b0a5cdaf3.zip
move wc to /bin
Diffstat (limited to 'sys-apps/textutils')
-rw-r--r--sys-apps/textutils/ChangeLog7
-rw-r--r--sys-apps/textutils/files/digest-textutils-2.0.19-r21
-rw-r--r--sys-apps/textutils/textutils-2.0.19-r2.ebuild71
3 files changed, 78 insertions, 1 deletions
diff --git a/sys-apps/textutils/ChangeLog b/sys-apps/textutils/ChangeLog
index ed5d08fa9bc1..15f391815421 100644
--- a/sys-apps/textutils/ChangeLog
+++ b/sys-apps/textutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/textutils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/textutils/ChangeLog,v 1.3 2002/07/14 19:20:19 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/textutils/ChangeLog,v 1.4 2002/07/21 16:14:37 azarah Exp $
+
+*textutils-2.0.19-r1 (21 Jul 2002)
+
+ 21 Jul 2002; Martin Schlemmer <azarah@gentoo.org> :
+ Move /usr/bin/wc to /bin/wc for upcomming baselayout.
*textutils-2.0.19-r1 (18 Mar 2002)
diff --git a/sys-apps/textutils/files/digest-textutils-2.0.19-r2 b/sys-apps/textutils/files/digest-textutils-2.0.19-r2
new file mode 100644
index 000000000000..09c4f38a0863
--- /dev/null
+++ b/sys-apps/textutils/files/digest-textutils-2.0.19-r2
@@ -0,0 +1 @@
+MD5 6959a6753db324e1061ce8f380a6b679 textutils-2.0.19.tar.gz 2456693
diff --git a/sys-apps/textutils/textutils-2.0.19-r2.ebuild b/sys-apps/textutils/textutils-2.0.19-r2.ebuild
new file mode 100644
index 000000000000..7fa73c5f5bbe
--- /dev/null
+++ b/sys-apps/textutils/textutils-2.0.19-r2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/textutils/textutils-2.0.19-r2.ebuild,v 1.1 2002/07/21 16:14:37 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard GNU text utilities"
+SRC_URI="http://fetish.sf.net/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/textutils/"
+
+KEYWORDS="x86 ppc"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc nls?
+ ( sys-devel/gettext )"
+RDEPEND="virtual/glibc"
+
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd ${S}
+ # patch to remove Stallman's su rant
+ patch doc/coreutils.texi ${FILESDIR}/${P}-gentoo.diff || die
+ rm doc/coreutils.info
+}
+
+
+src_compile() {
+ local myconf=""
+ [ -z "`use nls`" ] && myconf="--disable-nls"
+
+ ./configure --host=${CHOST} \
+ --build=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --without-included-regex \
+ ${myconf} || die
+
+ if [ "`use static`" ]
+ then
+ emake LDFLAGS=-static || die
+ else
+ emake || die
+ fi
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dodir /bin
+ mv ${D}/usr/bin/cat ${D}/bin
+ dosym /bin/cat /usr/bin/cat
+ # For baselayout
+ mv ${D}/usr/bin/wc ${D}/bin
+ dosym /bin/wc /usr/bin/wc
+
+ rmdir ${D}/usr/lib
+
+ if [ -z "`use build`" ]
+ then
+ dodoc AUTHORS COPYING ChangeLog NEWS README* THANKS TODO
+ else
+ rm -rf ${D}/usr/share
+ fi
+}
+