summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2003-06-28 12:03:58 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2003-06-28 12:03:58 +0000
commit0c2966d8ff386989dd2d8c54f8fe868cb05cb81c (patch)
treee528bca120f74336f94e3f7ff74b40ea6898ad3a /sys-apps/tpctl
parentPackage now installs man pages properly (diff)
downloadgentoo-2-0c2966d8ff386989dd2d8c54f8fe868cb05cb81c.tar.gz
gentoo-2-0c2966d8ff386989dd2d8c54f8fe868cb05cb81c.tar.bz2
gentoo-2-0c2966d8ff386989dd2d8c54f8fe868cb05cb81c.zip
Package now installs man pages properly
Diffstat (limited to 'sys-apps/tpctl')
-rw-r--r--sys-apps/tpctl/ChangeLog6
-rw-r--r--sys-apps/tpctl/Manifest5
-rw-r--r--sys-apps/tpctl/files/digest-tpctl-4.4-r11
-rw-r--r--sys-apps/tpctl/tpctl-4.4-r1.ebuild55
4 files changed, 64 insertions, 3 deletions
diff --git a/sys-apps/tpctl/ChangeLog b/sys-apps/tpctl/ChangeLog
index a591650473ea..931a859fc0c4 100644
--- a/sys-apps/tpctl/ChangeLog
+++ b/sys-apps/tpctl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/tpctl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tpctl/ChangeLog,v 1.6 2003/05/04 13:18:17 wmertens Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tpctl/ChangeLog,v 1.7 2003/06/28 12:03:49 karltk Exp $
+
+*tpctl-4.4-r1 (28 Jun 2003)
+ 28 Jun 2003; Karl Trygve Kalleberg (karltk@gentoo.org) tpctl-4.4-r1.ebuild :
+ Version bump, installing manpages
*tpctl-4.4 (04 May 2003)
17 Feb 2003; Wout Mertens (wmertens@gentoo.org) tpctl-4.4.ebuild :
diff --git a/sys-apps/tpctl/Manifest b/sys-apps/tpctl/Manifest
index 4bb2afc25b35..86053318c679 100644
--- a/sys-apps/tpctl/Manifest
+++ b/sys-apps/tpctl/Manifest
@@ -1,7 +1,8 @@
-MD5 4dd512702e6ea30b252248872db784b4 ChangeLog 1096
+MD5 0c4af8c4329636e62d8fdad3f7aa6825 ChangeLog 1237
MD5 d7444a351b95bde6c139c5333b81428b tpctl-3.2.ebuild 1601
MD5 291da398c9ac426f945c9d042a58d7a1 tpctl-4.2.ebuild 1600
-MD5 f0d69d677c29754617bf107a7db33f7e tpctl-4.4-r1.ebuild 1630
+MD5 ce0fa7349c9e92a14ceca1cc4aea359f tpctl-4.4.ebuild 1594
+MD5 84c2c7378591d113335f19b93667d37d tpctl-4.4-r1.ebuild 1636
MD5 e4a31c743370d1481eafa0b4eaa6e233 files/apmiser.rc 587
MD5 4a6eccb7b79fc6b89897fa42a9d63835 files/digest-tpctl-3.2 60
MD5 603d662e5051a7e33e5c3cb5cae78962 files/digest-tpctl-4.2 60
diff --git a/sys-apps/tpctl/files/digest-tpctl-4.4-r1 b/sys-apps/tpctl/files/digest-tpctl-4.4-r1
new file mode 100644
index 000000000000..53fc926f7e1d
--- /dev/null
+++ b/sys-apps/tpctl/files/digest-tpctl-4.4-r1
@@ -0,0 +1 @@
+MD5 658968fac5f02ebc6f64c3750b52fc44 tpctl_4.4.tar.gz 83113
diff --git a/sys-apps/tpctl/tpctl-4.4-r1.ebuild b/sys-apps/tpctl/tpctl-4.4-r1.ebuild
new file mode 100644
index 000000000000..3399aaf732c4
--- /dev/null
+++ b/sys-apps/tpctl/tpctl-4.4-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tpctl/tpctl-4.4-r1.ebuild,v 1.1 2003/06/28 12:03:49 karltk Exp $
+
+IUSE="ncurses tpctlir perl"
+
+#transform P to match tarball versioning
+MYPV=${PV/_beta/beta}
+MYP="${PN}_${MYPV}"
+
+DESCRIPTION="Thinkpad system control user space programs"
+SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz"
+HOMEPAGE="http://tpctl.sourceforge.net/tpctlhome.htm"
+KEYWORDS="x86 amd64 -ppc -mips -sparc"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="$DEPEND >=sys-apps/thinkpad-4.3 ncurses? ( sys-libs/ncurses )"
+RDEPEND="$RDEPEND >=sys-apps/thinkpad-4.3 ncurses? ( sys-libs/ncurses ) perl? ( dev-lang/perl )"
+
+src_compile() {
+ emake -C lib || die "lib make failed"
+ emake -C tpctl || die "tpctl make failed"
+ if use ncurses > /dev/null; then
+ emake -C ntpctl || die "ntpctl make failed"
+ fi
+
+ # Only for thinkpad models 760 and 765
+ # build with:
+ # $ USE=tpctlir emerge tpctl
+ if use tpctlir; then
+ emake -C tpctlir || die "tpctlir make failed"
+ fi
+}
+
+src_install() {
+ dodoc AUTHORS COPYING ChangeLog README SUPPORTED-MODELS TROUBLESHOOTING \
+ VGA-MODES
+ dolib lib/libsmapidev.so.2.0
+ dobin tpctl/tpctl
+ [ -e ntpctl/ntpctl ] && dobin ntpctl/ntpctl
+ if use tpctlir && [ -e tpctlir/tpctlir ]; then
+ mv tpctlir/README README.tpctlir
+ dodoc README.tpctlir
+ dobin tpctlir/tpctlir
+ fi
+ if use perl > /dev/null; then
+ mv apmiser/README README.apmiser
+ dodoc README.apmiser
+ dosbin apmiser/apmiser
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/apmiser.rc apmiser
+ fi
+ doman man/{ntpctl,tpctl}.1 man/apmiser.8
+}