summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-10-20 08:17:47 +0000
committerPacho Ramos <pacho@gentoo.org>2012-10-20 08:17:47 +0000
commit63ba734f94cf3a409f7f6b4812674481726790c1 (patch)
treebd613ad6475a6826c730040dd17e7ca7b97ba97c /sys-apps/tuxonice-userui
parentAdd missing dependency on postgresql-base. Convert to EAPI=4 to fix deprecati... (diff)
downloadgentoo-2-63ba734f94cf3a409f7f6b4812674481726790c1.tar.gz
gentoo-2-63ba734f94cf3a409f7f6b4812674481726790c1.tar.bz2
gentoo-2-63ba734f94cf3a409f7f6b4812674481726790c1.zip
Version bump.
(Portage version: 2.1.11.24/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/tuxonice-userui')
-rw-r--r--sys-apps/tuxonice-userui/ChangeLog10
-rw-r--r--sys-apps/tuxonice-userui/tuxonice-userui-1.1.ebuild65
2 files changed, 72 insertions, 3 deletions
diff --git a/sys-apps/tuxonice-userui/ChangeLog b/sys-apps/tuxonice-userui/ChangeLog
index 94d165d37802..bb42931dee89 100644
--- a/sys-apps/tuxonice-userui/ChangeLog
+++ b/sys-apps/tuxonice-userui/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/tuxonice-userui
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tuxonice-userui/ChangeLog,v 1.24 2011/10/16 17:01:25 pacho Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tuxonice-userui/ChangeLog,v 1.25 2012/10/20 08:17:47 pacho Exp $
+
+*tuxonice-userui-1.1 (20 Oct 2012)
+
+ 20 Oct 2012; Pacho Ramos <pacho@gentoo.org> +tuxonice-userui-1.1.ebuild:
+ Version bump.
16 Oct 2011; Pacho Ramos <pacho@gentoo.org> tuxonice-userui-1.0.ebuild:
Fix dependency on bzip2 static for future versions as reported by Arfrever.
@@ -256,4 +261,3 @@
+suspend2-userui-0.5.1.ebuild:
Initial import in preparation for sys-kernel/suspend2-sources, fixes bug
#85334.
-
diff --git a/sys-apps/tuxonice-userui/tuxonice-userui-1.1.ebuild b/sys-apps/tuxonice-userui/tuxonice-userui-1.1.ebuild
new file mode 100644
index 000000000000..7bd87ca6b626
--- /dev/null
+++ b/sys-apps/tuxonice-userui/tuxonice-userui-1.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tuxonice-userui/tuxonice-userui-1.1.ebuild,v 1.1 2012/10/20 08:17:47 pacho Exp $
+
+EAPI=4
+inherit toolchain-funcs eutils
+
+DESCRIPTION="User Interface for TuxOnIce"
+HOMEPAGE="http://www.tuxonice.net"
+SRC_URI="http://tuxonice.net/files/${P}.tar.gz -> ${P}.tar
+ mirror://debian/pool/main/t/${PN}/${PN}_${PV}-2~exp1.debian.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="fbsplash"
+DEPEND="fbsplash? ( >=media-gfx/splashutils-1.5.2.1
+ media-libs/libmng[lcms]
+ >=media-libs/libpng-1.4.8[static-libs]
+ media-libs/freetype[static-libs]
+ || ( <app-arch/bzip2-1.0.6-r3[static] >=app-arch/bzip2-1.0.6-r3[static-libs] )
+ media-libs/lcms:0[static-libs] )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ local d=${WORKDIR}/debian/patches
+ EPATCH_SOURCE=${d} epatch $(<"${d}"/series)
+ sed -i -e 's/make/$(MAKE)/' Makefile || die
+}
+
+src_compile() {
+ # Package contain binaries
+ emake clean
+
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ tuxoniceui || die "emake tuxoniceui_text failed"
+
+ if use fbsplash; then
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ fbsplash || die "emake tuxoniceui_fbsplash failed"
+ fi
+}
+
+src_install() {
+ into /
+ dosbin tuxoniceui
+ dodoc AUTHORS ChangeLog KERNEL_API README TODO USERUI_API
+}
+
+pkg_postinst() {
+ if use fbsplash; then
+ einfo
+ elog "You must create a symlink from /etc/splash/tuxonice"
+ elog "to the theme you want tuxonice to use, e.g.:"
+ elog
+ elog " # ln -sfn /etc/splash/emergence /etc/splash/tuxonice"
+ fi
+ einfo
+ einfo "Please see /usr/share/doc/${PF}/README.* for further"
+ einfo "instructions."
+ einfo
+}