summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-01-07 22:14:55 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-01-07 22:14:55 +0000
commitb4f9bb16cf80c89f4cef1f0918c664931947b935 (patch)
treeada8181560abab0450d9c0910519148c9badfddd /sys-apps/ucspi-unix/ucspi-unix-0.36-r1.ebuild
parentRemoved do_brk_fix.patch (only needed for 2.4.22) (diff)
downloadgentoo-2-b4f9bb16cf80c89f4cef1f0918c664931947b935.tar.gz
gentoo-2-b4f9bb16cf80c89f4cef1f0918c664931947b935.tar.bz2
gentoo-2-b4f9bb16cf80c89f4cef1f0918c664931947b935.zip
fix copyright headers and correct accept keywords tree stuff
Diffstat (limited to 'sys-apps/ucspi-unix/ucspi-unix-0.36-r1.ebuild')
-rw-r--r--sys-apps/ucspi-unix/ucspi-unix-0.36-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/ucspi-unix/ucspi-unix-0.36-r1.ebuild b/sys-apps/ucspi-unix/ucspi-unix-0.36-r1.ebuild
new file mode 100644
index 000000000000..2e05291670c2
--- /dev/null
+++ b/sys-apps/ucspi-unix/ucspi-unix-0.36-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ucspi-unix/ucspi-unix-0.36-r1.ebuild,v 1.1 2004/01/07 22:14:55 robbat2 Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A ucspi implementation for unix sockets."
+SRC_URI="http://untroubled.org/ucspi-unix/${P}.tar.gz"
+
+DEPEND=">=dev-libs/bglibs-1.009-r1"
+HOMEPAGE="http://untroubled.org/ucspi-unix/"
+KEYWORDS="x86 amd64 ~sparc"
+SLOT="0"
+LICENSE="GPL-2"
+
+src_unpack() {
+ unpack ${A}
+
+ # Fix for head syntax in Makefile
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-gentoo-head.patch
+}
+
+src_compile() {
+ echo "${CC} ${CFLAGS} -I/usr/lib/bglibs/include" > conf-cc
+ echo "${CC} -s -L/usr/lib/bglibs/lib" > conf-ld
+ make || die #don't use emake b/c of jobserver
+}
+
+src_install () {
+ exeinto /usr/bin
+ doexe unixserver unixclient unixcat
+ doman unixserver.1 unixclient.1
+
+ dodoc ANNOUNCEMENT ChangeLog NEWS PROTOCOL README TODO
+}