summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-24 08:51:15 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-24 08:51:15 +0000
commit5c4a3e472e88cabe5257112558c0e36306ab5413 (patch)
treeb5c2b06f9822471b0976485e05ee14af3fc87105 /sys-apps/util-linux
parenttouchups (diff)
downloadgentoo-2-5c4a3e472e88cabe5257112558c0e36306ab5413.tar.gz
gentoo-2-5c4a3e472e88cabe5257112558c0e36306ab5413.tar.bz2
gentoo-2-5c4a3e472e88cabe5257112558c0e36306ab5413.zip
clean up the ebuilds a bit
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/util-linux-2.12-r2.ebuild46
-rw-r--r--sys-apps/util-linux/util-linux-2.12-r3.ebuild34
-rw-r--r--sys-apps/util-linux/util-linux-2.12-r4.ebuild34
-rw-r--r--sys-apps/util-linux/util-linux-2.12-r5.ebuild54
4 files changed, 73 insertions, 95 deletions
diff --git a/sys-apps/util-linux/util-linux-2.12-r2.ebuild b/sys-apps/util-linux/util-linux-2.12-r2.ebuild
index e7762cf7ff5d..e2791778e009 100644
--- a/sys-apps/util-linux/util-linux-2.12-r2.ebuild
+++ b/sys-apps/util-linux/util-linux-2.12-r2.ebuild
@@ -1,39 +1,27 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12-r2.ebuild,v 1.4 2004/04/20 03:44:38 lv Exp $
-
-IUSE="crypt nls static pam selinux"
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12-r2.ebuild,v 1.5 2004/04/24 08:51:15 vapier Exp $
inherit eutils flag-o-matic
-## see below for details on pic.patch
-case ${ARCH} in
- "x86"|"hppa"|"sparc"|"ppc"|"amd64")
- ;;
- *)
- filter-flags -fPIC
- ;;
-esac
-
-S="${WORKDIR}/${P}"
CRYPT_PATCH_P="${PN}-2.11z-crypt-gentoo"
SELINUX_PATCH="util-linux-2.12-selinux.diff.bz2"
DESCRIPTION="Various useful Linux utilities"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
SRC_URI="mirror://kernel/linux/utils/${PN}/${P}.tar.gz
ftp://ftp.cwi.nl/pub/aeb/${PN}/${P}.tar.gz
crypt? ( mirror://gentoo/${CRYPT_PATCH_P}.patch.bz2 )"
-HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
-KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~mips ~hppa ia64"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~mips ~hppa ia64"
+IUSE="crypt nls static pam selinux"
DEPEND="virtual/glibc
>=sys-apps/sed-4.0.5
>=sys-libs/ncurses-5.2-r2
selinux? ( sys-libs/libselinux )
pam? ( sys-apps/pam-login )"
-
RDEPEND="${DEPEND} dev-lang/perl
nls? ( sys-devel/gettext )"
@@ -42,9 +30,7 @@ src_unpack() {
cd ${S}
-# if [ ! -z "`use crypt`" ] ; then
-# epatch ${DISTDIR}/${CRYPT_PATCH_P}.patch.bz2
-# fi
+# use crypt && epatch ${DISTDIR}/${CRYPT_PATCH_P}.patch.bz2
# Fix rare failures with -j4 or higher
epatch ${FILESDIR}/${PN}-2.11z-parallel-make.patch
@@ -74,6 +60,15 @@ src_unpack() {
# objects. "prelink" should now also be able to take advantage
epatch ${FILESDIR}/${PN}-2.11z-pic.patch
+ ## see below for details on pic.patch
+ case ${ARCH} in
+ "x86"|"hppa"|"sparc"|"ppc"|"amd64")
+ ;;
+ *)
+ filter-flags -fPIC
+ ;;
+ esac
+
#enable pam only if we use it
use pam && sed -i "s:HAVE_PAM=no:HAVE_PAM=yes:" MCONFIG
@@ -89,7 +84,7 @@ src_unpack() {
-e "s:SUIDMODE=.*4755:SUIDMODE=4711:" \
MCONFIG || die "MCONFIG sed"
- if [ -z "`use nls`" ] ; then
+ if ! use nls ; then
sed -i -e 's/DISABLE_NLS=no/DISABLE_NLS=yes/' MCONFIG ||
die "MCONFIG nls sed"
fi
@@ -99,18 +94,14 @@ src_unpack() {
}
src_compile() {
- if [ "`use static`" ] ; then
- export LDFLAGS="${LDFLAGS} -static"
- fi
-
+ use static && append-ldflags -static
econf || die "configure failed"
-
emake || die "emake failed"
cd sys-utils && makeinfo *.texi || die "makeinfo failed"
}
src_install() {
- make DESTDIR="${D}" install || die "install failed"
+ make DESTDIR=${D} install || die "install failed"
dodoc HISTORY MAINTAINER README VERSION
docinto licenses
@@ -118,4 +109,3 @@ src_install() {
docinto examples
dodoc example.files/*
}
-
diff --git a/sys-apps/util-linux/util-linux-2.12-r3.ebuild b/sys-apps/util-linux/util-linux-2.12-r3.ebuild
index d9f506b4c315..4cf2a431477c 100644
--- a/sys-apps/util-linux/util-linux-2.12-r3.ebuild
+++ b/sys-apps/util-linux/util-linux-2.12-r3.ebuild
@@ -1,32 +1,21 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12-r3.ebuild,v 1.6 2004/04/20 03:44:38 lv Exp $
-
-IUSE="crypt nls static pam selinux"
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12-r3.ebuild,v 1.7 2004/04/24 08:51:15 vapier Exp $
inherit eutils flag-o-matic
-## see below for details on pic.patch
-case ${ARCH} in
- "x86"|"hppa"|"sparc"|"ppc"|"amd64")
- ;;
- *)
- filter-flags -fPIC
- ;;
-esac
-
-S="${WORKDIR}/${P}"
CRYPT_PATCH_P="${P}-cryptoapi-losetup"
SELINUX_PATCH="util-linux-2.12-selinux.diff.bz2"
DESCRIPTION="Various useful Linux utilities"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
SRC_URI="mirror://kernel/linux/utils/${PN}/${P}.tar.gz
ftp://ftp.cwi.nl/pub/aeb/${PN}/${P}.tar.gz
crypt? ( mirror://gentoo/${CRYPT_PATCH_P}.patch.bz2 )"
-HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
-KEYWORDS="~x86 ~amd64 ppc ~sparc ~alpha ~mips ~hppa ~ia64 ppc64"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ppc ~sparc ~alpha ~mips ~hppa ~ia64 ppc64"
+IUSE="crypt nls static pam selinux"
DEPEND="virtual/glibc
>=sys-apps/sed-4.0.5
@@ -34,8 +23,8 @@ DEPEND="virtual/glibc
selinux? ( sys-libs/libselinux )
pam? ( sys-apps/pam-login )
crypt? ( app-crypt/hashalot )"
-
-RDEPEND="${DEPEND} dev-lang/perl
+RDEPEND="${DEPEND}
+ dev-lang/perl
nls? ( sys-devel/gettext )"
src_unpack() {
@@ -80,6 +69,15 @@ src_unpack() {
# objects. "prelink" should now also be able to take advantage
epatch ${FILESDIR}/${PN}-2.11z-pic.patch
+ ## see below for details on pic.patch
+ case ${ARCH} in
+ "x86"|"hppa"|"sparc"|"ppc"|"amd64")
+ ;;
+ *)
+ filter-flags -fPIC
+ ;;
+ esac
+
# allow util-linux to compile with 2.6.x headers #31286
epatch ${FILESDIR}/${P}-kernel-2.6.patch
diff --git a/sys-apps/util-linux/util-linux-2.12-r4.ebuild b/sys-apps/util-linux/util-linux-2.12-r4.ebuild
index bc8d71bce718..cca55cc46c5e 100644
--- a/sys-apps/util-linux/util-linux-2.12-r4.ebuild
+++ b/sys-apps/util-linux/util-linux-2.12-r4.ebuild
@@ -1,32 +1,21 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12-r4.ebuild,v 1.9 2004/04/20 03:44:38 lv Exp $
-
-IUSE="crypt nls static pam selinux"
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12-r4.ebuild,v 1.10 2004/04/24 08:51:15 vapier Exp $
inherit eutils flag-o-matic
-## see below for details on pic.patch
-case ${ARCH} in
- "x86"|"hppa"|"sparc"|"ppc"|"amd64")
- ;;
- *)
- filter-flags -fPIC
- ;;
-esac
-
-S="${WORKDIR}/${P}"
CRYPT_PATCH_P="${P}-cryptoapi-losetup"
SELINUX_PATCH="util-linux-2.12-selinux.diff.bz2"
DESCRIPTION="Various useful Linux utilities"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
SRC_URI="mirror://kernel/linux/utils/${PN}/${P}.tar.gz
ftp://ftp.cwi.nl/pub/aeb/${PN}/${P}.tar.gz
crypt? ( mirror://gentoo/${CRYPT_PATCH_P}.patch.bz2 )"
-HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
-KEYWORDS="x86 amd64 ~ppc sparc alpha mips hppa ia64 ~ppc64 s390"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64 ~ppc sparc alpha mips hppa ia64 ~ppc64 s390"
+IUSE="crypt nls static pam selinux"
DEPEND="virtual/glibc
>=sys-apps/sed-4.0.5
@@ -34,8 +23,8 @@ DEPEND="virtual/glibc
selinux? ( sys-libs/libselinux )
pam? ( sys-apps/pam-login )
crypt? ( app-crypt/hashalot )"
-
-RDEPEND="${DEPEND} dev-lang/perl
+RDEPEND="${DEPEND}
+ dev-lang/perl
nls? ( sys-devel/gettext )"
src_unpack() {
@@ -80,6 +69,15 @@ src_unpack() {
# objects. "prelink" should now also be able to take advantage
epatch ${FILESDIR}/${PN}-2.11z-pic.patch
+ ## see below for details on pic.patch
+ case ${ARCH} in
+ "x86"|"hppa"|"sparc"|"ppc"|"amd64")
+ ;;
+ *)
+ filter-flags -fPIC
+ ;;
+ esac
+
# Allow util-linux to compile with 2.6.x headers #31286
epatch ${FILESDIR}/${P}-kernel-2.6.patch
diff --git a/sys-apps/util-linux/util-linux-2.12-r5.ebuild b/sys-apps/util-linux/util-linux-2.12-r5.ebuild
index 440fd9b329c2..98186dc6f264 100644
--- a/sys-apps/util-linux/util-linux-2.12-r5.ebuild
+++ b/sys-apps/util-linux/util-linux-2.12-r5.ebuild
@@ -1,32 +1,21 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12-r5.ebuild,v 1.5 2004/04/07 19:49:23 kumba Exp $
-
-IUSE="crypt nls static pam selinux"
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12-r5.ebuild,v 1.6 2004/04/24 08:51:15 vapier Exp $
inherit eutils flag-o-matic
-## see below for details on pic.patch
-case ${ARCH} in
- "x86"|"hppa"|"sparc"|"ppc"|"amd64")
- ;;
- *)
- filter-flags -fPIC
- ;;
-esac
-
-S="${WORKDIR}/${P}"
CRYPT_PATCH_P="${P}-cryptoapi-losetup"
SELINUX_PATCH="util-linux-2.12-selinux.diff.bz2"
DESCRIPTION="Various useful Linux utilities"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
SRC_URI="mirror://kernel/linux/utils/${PN}/${P}.tar.gz
ftp://ftp.cwi.nl/pub/aeb/${PN}/${P}.tar.gz
crypt? ( mirror://gentoo/${CRYPT_PATCH_P}.patch.bz2 )"
-HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
-KEYWORDS="x86 ~amd64 ~ppc ~sparc ~alpha mips ~hppa ~ia64 ~ppc64"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~ppc64 ~sparc mips ~alpha arm ~hppa ~amd64 ~ia64"
+IUSE="crypt nls static pam selinux"
DEPEND="virtual/glibc
>=sys-apps/sed-4.0.5
@@ -34,8 +23,8 @@ DEPEND="virtual/glibc
selinux? ( sys-libs/libselinux )
pam? ( sys-apps/pam-login )
crypt? ( app-crypt/hashalot )"
-
-RDEPEND="${DEPEND} dev-lang/perl
+RDEPEND="${DEPEND}
+ dev-lang/perl
nls? ( sys-devel/gettext )"
src_unpack() {
@@ -68,11 +57,10 @@ src_unpack() {
epatch ${FILESDIR}/${PN}-2.11z-agetty-domainname-option.patch
# Add NFS4 support (kernel 2.5/2.6).
-# if [ ! -z "`use crypt`" ] ; then
-# epatch ${FILESDIR}/${PN}-2.11z-01-nfsv4-crypt.dif
-# else
- epatch ${FILESDIR}/${PN}-2.11z-01-nfsv4.dif
-# fi
+# use crypt \
+# && epatch ${FILESDIR}/${PN}-2.11z-01-nfsv4-crypt.dif \
+# ||
+ epatch ${FILESDIR}/${PN}-2.11z-01-nfsv4.dif
# <solar@gentoo.org> This patch should allow us to remove -fPIC
# out of the filter-flags we need this be able to emit position
@@ -80,6 +68,15 @@ src_unpack() {
# objects. "prelink" should now also be able to take advantage
epatch ${FILESDIR}/${PN}-2.11z-pic.patch
+ ## see below for details on pic.patch
+ case ${ARCH} in
+ "x86"|"hppa"|"sparc"|"ppc"|"amd64")
+ ;;
+ *)
+ filter-flags -fPIC
+ ;;
+ esac
+
# Allow util-linux to compile with 2.6.x headers #31286
epatch ${FILESDIR}/${P}-kernel-2.6.patch
@@ -104,7 +101,7 @@ src_unpack() {
-e "s:SUIDMODE=.*4755:SUIDMODE=4711:" \
MCONFIG || die "MCONFIG sed"
- if [ -z "`use nls`" ] ; then
+ if ! use nls ; then
sed -i -e 's/DISABLE_NLS=no/DISABLE_NLS=yes/' MCONFIG ||
die "MCONFIG nls sed"
fi
@@ -117,18 +114,14 @@ src_unpack() {
}
src_compile() {
- if [ "`use static`" ] ; then
- export LDFLAGS="${LDFLAGS} -static"
- fi
-
+ use static && append-ldflags -static
econf || die "configure failed"
-
emake || die "emake failed"
cd sys-utils && makeinfo *.texi || die "makeinfo failed"
}
src_install() {
- make DESTDIR="${D}" install || die "install failed"
+ make DESTDIR=${D} install || die "install failed"
dodoc HISTORY MAINTAINER README VERSION
docinto licenses
@@ -136,4 +129,3 @@ src_install() {
docinto examples
dodoc example.files/*
}
-