summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-02 06:20:31 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-02 06:20:31 +0000
commit78897a490164ea476e47804d654b31b5c52af32d (patch)
treec63244eb26f35ca82c2214d9d7e9521cc82ce371 /sys-apps/util-linux
parentregen Manifest to not contain missing ruby-1.8.5_pre1.ebuild.orig <- flameeyes (diff)
downloadgentoo-2-78897a490164ea476e47804d654b31b5c52af32d.tar.gz
gentoo-2-78897a490164ea476e47804d654b31b5c52af32d.tar.bz2
gentoo-2-78897a490164ea476e47804d654b31b5c52af32d.zip
old
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/files/digest-util-linux-2.13_pre66
-rw-r--r--sys-apps/util-linux/util-linux-2.13_pre6.ebuild131
2 files changed, 0 insertions, 137 deletions
diff --git a/sys-apps/util-linux/files/digest-util-linux-2.13_pre6 b/sys-apps/util-linux/files/digest-util-linux-2.13_pre6
deleted file mode 100644
index 4b853665bef8..000000000000
--- a/sys-apps/util-linux/files/digest-util-linux-2.13_pre6
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 b4d13d6421382ea048e113ad8a868dfa loop-AES-v3.1d.tar.bz2 169228
-RMD160 36707f6ed2f57dabd7278c9d6386a25c2c012d59 loop-AES-v3.1d.tar.bz2 169228
-SHA256 05826b3238d5d9f134426cb8575496508205ef607e0a9075b50510c8e0e8a23c loop-AES-v3.1d.tar.bz2 169228
-MD5 1db1249029439e5e965c2c7178149616 util-linux-2.13-pre6.tar.bz2 2393796
-RMD160 9d2427be4e4f6ece16a960e9e326eb8bca661279 util-linux-2.13-pre6.tar.bz2 2393796
-SHA256 9d9e3be68b618f70dacc1bc7fe2497c4821118c9db0a573176fd8ff66c28c43d util-linux-2.13-pre6.tar.bz2 2393796
diff --git a/sys-apps/util-linux/util-linux-2.13_pre6.ebuild b/sys-apps/util-linux/util-linux-2.13_pre6.ebuild
deleted file mode 100644
index 1bab74539c0e..000000000000
--- a/sys-apps/util-linux/util-linux-2.13_pre6.ebuild
+++ /dev/null
@@ -1,131 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.13_pre6.ebuild,v 1.6 2006/04/11 00:35:43 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-MY_PV=${PV/_/-}
-MY_P=${PN}-${MY_PV}
-S=${WORKDIR}/${MY_P}
-
-LOOP_AES_VER=3.1d
-DESCRIPTION="Various useful Linux utilities"
-HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
-SRC_URI="mirror://kernel/linux/utils/${PN}/testing/${MY_P}.tar.bz2
- crypt? ( http://loop-aes.sourceforge.net/loop-AES/loop-AES-v${LOOP_AES_VER}.tar.bz2 )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="crypt nls static selinux perl"
-
-RDEPEND="!sys-process/schedutils
- >=sys-libs/ncurses-5.2-r2
- >=sys-fs/e2fsprogs-1.34
- selinux? ( sys-libs/libselinux )
- crypt? ( app-crypt/hashalot )
- perl? ( dev-lang/perl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- virtual/os-headers"
-
-yesno() { useq $1 && echo yes || echo no; }
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
-
- # crypto support
- use crypt && die "Sorry, no loop-AES support in this version"
-# use crypt && epatch "${WORKDIR}"/loop-AES-v${LOOP_AES_VER}/util-linux-2.12r.diff
-
- # Fall back to cracklib if default words file doesnt exist #114416
- epatch "${FILESDIR}"/${PN}-2.12r-cracklib-words.patch
-
- # Fix -f usage with -a and in general
- epatch "${FILESDIR}"/${PN}-2.12q-more-fake-checks-v2.patch
-
- # Fix mtab updates with `mount --move /foo /bar` #104697
- epatch "${FILESDIR}"/${PN}-2.12q-update-mtab-when-moving.patch
-
- # A few fixes to beat update_mtab() into submission.
- epatch "${FILESDIR}"/${PN}-2.12q-update_mtab-fixes.patch
-
- # Use update_mtab() to avoid dups in mtab for 'mount -f'
- epatch "${FILESDIR}"/${PN}-2.12q-use-update_mtab-for-fake.patch
-
- # Fix building with USE=-nls #123826
- epatch "${FILESDIR}"/${PN}-2.13-no-nls.patch
-
- # Fix unreadable df output when using devfs ... this check is kind of
- # a hack, but whatever, the output isnt critical at all :P
- [[ -e /dev/.devfsd ]] && epatch "${FILESDIR}"/no-symlink-resolve.patch
-
- # Add the O option to agetty to display DNS domainname in the issue
- # file, thanks to Marius Mauch <genone@genone.de>, bug #22275.
- #
- # NOTE: Removing this will break future baselayout, so PLEASE
- # consult with me before doing so.
- epatch "${FILESDIR}"/${PN}-2.11z-agetty-domainname-option.patch
-
- # Fix french translation typo #75693
- epatch "${FILESDIR}"/${PN}-2.12q-i18n-update.patch
-
-# # Add NFS4 support (kernel 2.5/2.6)
-# epatch "${FILESDIR}"/${PN}-2.13-nfsv4.patch
-
- # ignore managed/kudzu options #70873
- epatch "${FILESDIR}"/${PN}-2.12i-ignore-managed.patch
-
- # swapon gets confused by symlinks in /dev #69162
- epatch "${FILESDIR}"/${PN}-2.12p-swapon-check-symlinks.patch
-
- # don't force umask to 022 #93671
- epatch "${FILESDIR}"/${PN}-2.12q-dont-umask.patch
-
- # fix cal display when using featureless terminals #112406
- epatch "${FILESDIR}"/${PN}-2.12r-cal-dumb-terminal.patch
-
- sed -i -e '/chmod/s:4755:4711:' mount/Makefile.in
-}
-
-src_compile() {
-# append-ldflags $(bindnow-flags)
- use static && append-ldflags -static
- econf \
- --prefix=/ \
- $(use_with selinux) \
- $(use_enable nls) \
- --without-pam \
- --enable-agetty \
- --enable-cramfs \
- --disable-init \
- --disable-kill \
- --disable-last \
- --disable-mesg \
- --enable-partx \
- --enable-raw \
- --enable-rdev \
- --enable-rename \
- --disable-reset \
- --disable-login-utils \
- --enable-schedutils \
- --disable-wall \
- --enable-write \
- || die "configure failed"
- emake || die "emake failed"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die "install failed"
- dosym ../man8/agetty.8 /usr/share/man/man1/getty.1
- use perl || rm -f "${D}"/usr/bin/chkdupexe
-
- newinitd "${FILESDIR}"/crypto-loop.initd crypto-loop
- newconfd "${FILESDIR}"/crypto-loop.confd crypto-loop
-
- dodoc AUTHORS NEWS README
- docinto examples
- dodoc example.files/*
-}