summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-04-13 10:59:26 +0000
committerMike Frysinger <vapier@gentoo.org>2007-04-13 10:59:26 +0000
commita5b0ebab3579f02cdf90624cdecf4cac232ca056 (patch)
treeccdcb67398f4e51f0c23bfc13fcd404a27edaea9 /sys-apps/util-linux
parentDont install rpc stuf when USE=-rpc #174208 by Simon Arlott. (diff)
downloadgentoo-2-a5b0ebab3579f02cdf90624cdecf4cac232ca056.tar.gz
gentoo-2-a5b0ebab3579f02cdf90624cdecf4cac232ca056.tar.bz2
gentoo-2-a5b0ebab3579f02cdf90624cdecf4cac232ca056.zip
Testing ebuild for current git version.
(Portage version: 2.1.2.3)
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/ChangeLog7
-rw-r--r--sys-apps/util-linux/files/digest-util-linux-99990
-rw-r--r--sys-apps/util-linux/util-linux-9999.ebuild65
3 files changed, 71 insertions, 1 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index 3ad1a13107d6..10415a95490b 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/util-linux
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.181 2007/03/03 21:22:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.182 2007/04/13 10:59:26 vapier Exp $
+
+*util-linux-9999 (13 Apr 2007)
+
+ 13 Apr 2007; Mike Frysinger <vapier@gentoo.org> +util-linux-9999.ebuild:
+ Testing ebuild for current git version.
03 Mar 2007; Mike Frysinger <vapier@gentoo.org>
files/util-linux-2.12r-HAVE_asm_page_h.patch,
diff --git a/sys-apps/util-linux/files/digest-util-linux-9999 b/sys-apps/util-linux/files/digest-util-linux-9999
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sys-apps/util-linux/files/digest-util-linux-9999
diff --git a/sys-apps/util-linux/util-linux-9999.ebuild b/sys-apps/util-linux/util-linux-9999.ebuild
new file mode 100644
index 000000000000..3f9e5088a130
--- /dev/null
+++ b/sys-apps/util-linux/util-linux-9999.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-9999.ebuild,v 1.1 2007/04/13 10:59:26 vapier Exp $
+
+EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux-ng/util-linux-ng.git"
+EGIT_BRANCH="devel"
+inherit eutils git
+
+MY_PV=${PV/_/-}
+MY_P=${PN}-${MY_PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Various useful Linux utilities"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="nls old-linux selinux"
+
+RDEPEND="!sys-process/schedutils
+ >=sys-libs/ncurses-5.2-r2
+ >=sys-fs/e2fsprogs-1.34
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/os-headers"
+
+src_unpack() {
+ git_src_unpack
+ cd "${S}"
+ ./autogen.sh || die
+}
+
+src_compile() {
+ econf \
+ --prefix=/ \
+ $(use_enable nls) \
+ --enable-agetty \
+ --enable-cramfs \
+ $(use_enable old-linux elvtune) \
+ --disable-init \
+ --disable-kill \
+ --disable-last \
+ --disable-mesg \
+ --enable-partx \
+ --enable-raw \
+ --enable-rdev \
+ --enable-rename \
+ --disable-reset \
+ --disable-login-utils \
+ --enable-schedutils \
+ --disable-wall \
+ --enable-write \
+ --without-pam \
+ $(use_with selinux) \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ dodoc AUTHORS DEPRECATED NEWS README TODO
+}