summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-04-11 19:40:10 +0000
committerChristian Heim <phreak@gentoo.org>2007-04-11 19:40:10 +0000
commit464d3d8f119d664ba92c6e4e0231ab99125a9ef8 (patch)
treea04173a758e51a740c9b2f208ffc4e0f1f73b2fc /sys-apps/watchdog/watchdog-5.3.1_p2.ebuild
parentppc stable, bug #144833 (diff)
downloadgentoo-2-464d3d8f119d664ba92c6e4e0231ab99125a9ef8.tar.gz
gentoo-2-464d3d8f119d664ba92c6e4e0231ab99125a9ef8.tar.bz2
gentoo-2-464d3d8f119d664ba92c6e4e0231ab99125a9ef8.zip
Version bump, thanks to Martin von Gagern <Martin.vGagern at gmx.net> in #171786.
(Portage version: 2.1.2.3)
Diffstat (limited to 'sys-apps/watchdog/watchdog-5.3.1_p2.ebuild')
-rw-r--r--sys-apps/watchdog/watchdog-5.3.1_p2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/watchdog/watchdog-5.3.1_p2.ebuild b/sys-apps/watchdog/watchdog-5.3.1_p2.ebuild
new file mode 100644
index 000000000000..11cd041fcf3c
--- /dev/null
+++ b/sys-apps/watchdog/watchdog-5.3.1_p2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/watchdog/watchdog-5.3.1_p2.ebuild,v 1.1 2007/04/11 19:40:10 phreak Exp $
+
+inherit eutils
+
+MY_P=${PN}_${PV/_p*/}
+S="${WORKDIR}"/${P/_p*/}
+PATCH_LEVEL=${PV##*_p}
+
+DESCRIPTION="A software watchdog"
+HOMEPAGE="http://www.ibiblio.org/pub/Linux/system/daemons/watchdog/"
+SRC_URI="mirror://debian/pool/main/w/watchdog/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/w/watchdog/${MY_P}-${PATCH_LEVEL}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~m68k ~mips ~ppc ~s390 ~sh ~x86"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-${PV/_p*/}-sundries.patch
+ epatch "${FILESDIR}"/${PN}-${PV/_p*/}-headers.patch
+ epatch "${FILESDIR}"/${PN}-${PV/_p*/}-uclibc.patch
+ epatch "${WORKDIR}"/${MY_P}-${PATCH_LEVEL}.diff
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ newconfd "${FILESDIR}"/${PN}-conf.d ${PN}
+ newinitd "${FILESDIR}"/${PN}-init.d ${PN}
+
+ dodoc AUTHORS README TODO
+ docinto examples
+ dodoc examples/*
+}