summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-06-09 01:36:47 +0000
committerMike Frysinger <vapier@gentoo.org>2011-06-09 01:36:47 +0000
commit546f6a8d5cc81f586c6574b6fff8e32970301d59 (patch)
tree142036bb06008cebb8b4d294d79aa61bdfa37bed /sys-apps/watchdog/watchdog-5.9-r1.ebuild
parentmedia-video/cheese: Fix conclict with sys-fs/udev-171 (bug ##370381) (diff)
downloadgentoo-2-546f6a8d5cc81f586c6574b6fff8e32970301d59.tar.gz
gentoo-2-546f6a8d5cc81f586c6574b6fff8e32970301d59.tar.bz2
gentoo-2-546f6a8d5cc81f586c6574b6fff8e32970301d59.zip
Control nfs support via USE=nfs to fix building with glibc-2.14 #370655 by Diego Elio Pettenò.
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/watchdog/watchdog-5.9-r1.ebuild')
-rw-r--r--sys-apps/watchdog/watchdog-5.9-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/watchdog/watchdog-5.9-r1.ebuild b/sys-apps/watchdog/watchdog-5.9-r1.ebuild
new file mode 100644
index 000000000000..49755dadc502
--- /dev/null
+++ b/sys-apps/watchdog/watchdog-5.9-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/watchdog/watchdog-5.9-r1.ebuild,v 1.1 2011/06/09 01:36:47 vapier Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="A software watchdog"
+HOMEPAGE="http://sourceforge.net/projects/watchdog/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~m68k ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE="nfs"
+
+DEPEND="nfs? ( net-libs/libtirpc )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-nfs.patch #370655
+}
+
+src_configure() {
+ if use nfs ; then
+ append-cppflags $($(tc-getPKG_CONFIG) libtirpc --cflags)
+ export LIBS+=" $($(tc-getPKG_CONFIG) libtirpc --libs)"
+ fi
+ econf $(use_enable nfs)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ newconfd "${FILESDIR}"/${PN}-conf.d ${PN}
+ newinitd "${FILESDIR}"/${PN}-init.d ${PN}
+
+ dodoc AUTHORS README TODO NEWS ChangeLog
+ docinto examples
+ dodoc examples/*
+}