summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-01-13 20:07:52 +0000
committerAchim Gottinger <achim@gentoo.org>2001-01-13 20:07:52 +0000
commitb2e2ad8e094ec4aa9b5cb303ee4d14812983005c (patch)
tree115e44a6209f554c8a90361e32d2b1cef842455f /sys-apps/xinetd
parentHere are the actuall kernel sources (diff)
downloadgentoo-2-b2e2ad8e094ec4aa9b5cb303ee4d14812983005c.tar.gz
gentoo-2-b2e2ad8e094ec4aa9b5cb303ee4d14812983005c.tar.bz2
gentoo-2-b2e2ad8e094ec4aa9b5cb303ee4d14812983005c.zip
*** empty log message ***
Diffstat (limited to 'sys-apps/xinetd')
-rwxr-xr-xsys-apps/xinetd/files/svc-xinetd7
-rw-r--r--sys-apps/xinetd/xinetd-2.1.8.8_p3-r4.ebuild3
2 files changed, 5 insertions, 5 deletions
diff --git a/sys-apps/xinetd/files/svc-xinetd b/sys-apps/xinetd/files/svc-xinetd
index 2fb309754ecd..4b0d40970012 100755
--- a/sys-apps/xinetd/files/svc-xinetd
+++ b/sys-apps/xinetd/files/svc-xinetd
@@ -3,7 +3,7 @@
. /etc/rc.d/config/functions
-SERVICE=svc-xinetd
+SERVICE=xinetd
opts="start stop"
prepconfig() {
@@ -23,13 +23,14 @@ prepconfig() {
}
start() {
- ebegin "Starting ${SERVICE}"
+ prepconfig
+ ebegin "Starting supervised ${SERVICE}"
ln -sf ../services/${SERVICE} ${SVCDIR}/control/${SERVICE}
eend $?
}
stop() {
- ebegin "Stopping ${SERVICE}"
+ ebegin "Stopping supervised ${SERVICE}"
if [ -e ${SVCDIR}/control/${SERVICE} ]
then
/usr/bin/svc -dx ${SVCDIR}/control/${SERVICE}
diff --git a/sys-apps/xinetd/xinetd-2.1.8.8_p3-r4.ebuild b/sys-apps/xinetd/xinetd-2.1.8.8_p3-r4.ebuild
index e96257a05aba..c39ed3ba68eb 100644
--- a/sys-apps/xinetd/xinetd-2.1.8.8_p3-r4.ebuild
+++ b/sys-apps/xinetd/xinetd-2.1.8.8_p3-r4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/xinetd-2.1.8.8_p3-r4.ebuild,v 1.1 2001/01/10 07:05:10 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/xinetd-2.1.8.8_p3-r4.ebuild,v 1.2 2001/01/13 20:07:52 achim Exp $
P=xinetd-2.1.8.8p3
A=${P}.tar.gz
@@ -29,7 +29,6 @@ src_install() {
doexe ${FILESDIR}/xinetd ${FILESDIR}/svc-xinetd
insinto /etc
# doins ${FILESDIR}/xinetd.conf
- dodir /etc/supervise
exeinto /var/lib/supervise/services/xinetd
newexe ${FILESDIR}/xinetd-run run
}